summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2010-01-20 01:24:42 +0000
committerBen de Groot <yngwin@gentoo.org>2010-01-20 01:24:42 +0000
commitd8e4d96802888849bf637e2fb6a584e604c60f4c (patch)
tree7894ee652e62b6782b3452fe8fd070bd9a556a01 /dev-php5/ZendFramework
parentKeyword ~x86-linux (diff)
downloadgentoo-2-d8e4d96802888849bf637e2fb6a584e604c60f4c.tar.gz
gentoo-2-d8e4d96802888849bf637e2fb6a584e604c60f4c.tar.bz2
gentoo-2-d8e4d96802888849bf637e2fb6a584e604c60f4c.zip
Version bump
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-php5/ZendFramework')
-rw-r--r--dev-php5/ZendFramework/ChangeLog9
-rw-r--r--dev-php5/ZendFramework/ZendFramework-1.9.7.ebuild79
2 files changed, 86 insertions, 2 deletions
diff --git a/dev-php5/ZendFramework/ChangeLog b/dev-php5/ZendFramework/ChangeLog
index fdffc29bd82f..e0af85ddb6ff 100644
--- a/dev-php5/ZendFramework/ChangeLog
+++ b/dev-php5/ZendFramework/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php5/ZendFramework
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/ZendFramework/ChangeLog,v 1.60 2009/12/14 12:35:44 gurligebis Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/ZendFramework/ChangeLog,v 1.61 2010/01/20 01:24:42 yngwin Exp $
+
+*ZendFramework-1.9.7 (20 Jan 2010)
+
+ 20 Jan 2010; Ben de Groot <yngwin@gentoo.org> +ZendFramework-1.9.7.ebuild:
+ Version bump
*ZendFramework-1.9.6 (14 Dec 2009)
diff --git a/dev-php5/ZendFramework/ZendFramework-1.9.7.ebuild b/dev-php5/ZendFramework/ZendFramework-1.9.7.ebuild
new file mode 100644
index 000000000000..f550f5aee6a4
--- /dev/null
+++ b/dev-php5/ZendFramework/ZendFramework-1.9.7.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/ZendFramework/ZendFramework-1.9.7.ebuild,v 1.1 2010/01/20 01:24:42 yngwin Exp $
+
+EAPI="2"
+
+PHP_LIB_NAME="Zend"
+
+inherit php-lib-r1
+
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+
+DESCRIPTION="Zend Framework is a high quality and open source framework for developing Web Applications."
+HOMEPAGE="http://framework.zend.com/"
+SRC_URI="!minimal? ( http://framework.zend.com/releases/${P}/${P}.tar.gz )
+ minimal? ( http://framework.zend.com/releases/${P}/${P}-minimal.tar.gz )
+ doc? (
+ http://framework.zend.com/releases/${P}/${P}-apidoc.tar.gz
+ http://framework.zend.com/releases/${P}/${P}-manual-en.tar.gz )"
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc examples minimal cli"
+
+DEPEND="cli? ( dev-lang/php[simplexml,tokenizer] )"
+RDEPEND="${DEPEND}"
+need_php_by_category
+
+src_prepare() {
+ if use minimal ; then
+ S="${WORKDIR}/${P}-minimal"
+ if use doc ; then
+ mv "${WORKDIR}/${P}/documentation" "${S}"
+ fi
+ fi
+}
+
+src_install() {
+ if use cli ; then
+ insinto /usr/bin
+ doins bin/zf.php
+ dobin bin/zf.sh
+ dosym /usr/bin/zf.sh /usr/bin/zf
+ fi
+ php-lib-r1_src_install library/Zend $(cd library/Zend ; find . -type f -print)
+
+ if ! use minimal ; then
+ insinto /usr/share/php5
+ doins -r externals/dojo
+ fi
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+
+ if ! use minimal ; then
+ doins -r demos
+ fi
+ fi
+
+ dodoc README.txt
+ if use doc ; then
+ dohtml -r documentation/*
+ fi
+}
+
+pkg_postinst() {
+ elog "For more info, please take a look at the manual at:"
+ elog "http://framework.zend.com/manual"
+ elog ""
+
+ if use minimal; then
+ elog "You have installed the minimal version of ZendFramework,"
+ elog "so the Dojo toolkit, demos and tests have not been installed."
+ else
+ elog "You have installed the full version of ZendFramework, which"
+ elog "includes the Dojo toolkit, demos and tests."
+ elog "To install ZendFramework without there, enable the"
+ elog "minimal USE flag."
+ fi
+}