summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2010-11-04 09:03:50 +0000
committerOle Markus With <olemarkus@gentoo.org>2010-11-04 09:03:50 +0000
commitf614227de24af5a584729d5f61a7bddbcc338b79 (patch)
treed0d94c31ff664dfbad5ecde8fe8b23c67d96e066 /dev-php5/pecl-apc
parentx86 stable wrt bug #343117 (diff)
downloadgentoo-2-f614227de24af5a584729d5f61a7bddbcc338b79.tar.gz
gentoo-2-f614227de24af5a584729d5f61a7bddbcc338b79.tar.bz2
gentoo-2-f614227de24af5a584729d5f61a7bddbcc338b79.zip
Created versions for php-ext-*r{1,2}. The revbumps is there to get the version ordering straight
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'dev-php5/pecl-apc')
-rw-r--r--dev-php5/pecl-apc/ChangeLog10
-rw-r--r--dev-php5/pecl-apc/pecl-apc-3.1.5-r1.ebuild72
-rw-r--r--dev-php5/pecl-apc/pecl-apc-3.1.5-r2.ebuild (renamed from dev-php5/pecl-apc/pecl-apc-3.1.5.ebuild)2
3 files changed, 82 insertions, 2 deletions
diff --git a/dev-php5/pecl-apc/ChangeLog b/dev-php5/pecl-apc/ChangeLog
index 716e1bcbfa43..9137168c1836 100644
--- a/dev-php5/pecl-apc/ChangeLog
+++ b/dev-php5/pecl-apc/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-php5/pecl-apc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-apc/ChangeLog,v 1.63 2010/11/02 19:55:03 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-apc/ChangeLog,v 1.64 2010/11/04 09:03:50 olemarkus Exp $
+
+*pecl-apc-3.1.5-r2 (04 Nov 2010)
+*pecl-apc-3.1.5-r1 (04 Nov 2010)
+
+ 04 Nov 2010; <olemarkus@gentoo.org> -pecl-apc-3.1.5.ebuild,
+ +pecl-apc-3.1.5-r1.ebuild, +pecl-apc-3.1.5-r2.ebuild:
+ Created versions for php-ext-*r{1,2}. The revbumps is there to get the
+ version ordering straight
*pecl-apc-3.1.5 (02 Nov 2010)
diff --git a/dev-php5/pecl-apc/pecl-apc-3.1.5-r1.ebuild b/dev-php5/pecl-apc/pecl-apc-3.1.5-r1.ebuild
new file mode 100644
index 000000000000..099cc5da7a84
--- /dev/null
+++ b/dev-php5/pecl-apc/pecl-apc-3.1.5-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-apc/pecl-apc-3.1.5-r1.ebuild,v 1.1 2010/11/04 09:03:50 olemarkus Exp $
+
+EAPI=2
+
+PHP_EXT_NAME="apc"
+PHP_EXT_PECL_PKG="APC"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="CHANGELOG INSTALL NOTICE TECHNOTES.txt TODO"
+
+inherit php-ext-pecl-r1 confutils eutils
+
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+DESCRIPTION="A free, open, and robust framework for caching and optimizing PHP code."
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE="mmap"
+
+DEPEND="!dev-php5/eaccelerator !dev-php5/xcache
+ || ( dev-lang/php[apache2] dev-lang/php[cgi] dev-lang/php[fpm] )"
+RDEPEND="${DEPEND}"
+
+need_php_by_category
+
+src_compile() {
+ my_conf="--enable-apc"
+ enable_extension_enable "apc-mmap" "mmap" 0
+
+ php-ext-pecl-r1_src_compile
+}
+
+src_install() {
+ php-ext-pecl-r1_src_install
+
+ php-ext-base-r1_addtoinifiles "apc.enabled" '"1"'
+ php-ext-base-r1_addtoinifiles "apc.shm_segments" '"1"'
+ php-ext-base-r1_addtoinifiles "apc.shm_size" '"30"'
+ php-ext-base-r1_addtoinifiles "apc.num_files_hint" '"1024"'
+ php-ext-base-r1_addtoinifiles "apc.ttl" '"7200"'
+ php-ext-base-r1_addtoinifiles "apc.user_ttl" '"7200"'
+ php-ext-base-r1_addtoinifiles "apc.gc_ttl" '"3600"'
+ php-ext-base-r1_addtoinifiles "apc.cache_by_default" '"1"'
+ php-ext-base-r1_addtoinifiles ";apc.filters" '""'
+ php-ext-base-r1_addtoinifiles ";apc.mmap_file_mask" '"/tmp/apcphp5.XXXXXX"'
+ php-ext-base-r1_addtoinifiles "apc.slam_defense" '"0"'
+ php-ext-base-r1_addtoinifiles "apc.file_update_protection" '"2"'
+ php-ext-base-r1_addtoinifiles "apc.enable_cli" '"0"'
+ php-ext-base-r1_addtoinifiles "apc.max_file_size" '"1M"'
+ php-ext-base-r1_addtoinifiles "apc.stat" '"1"'
+ php-ext-base-r1_addtoinifiles "apc.write_lock" '"1"'
+ php-ext-base-r1_addtoinifiles "apc.report_autofilter" '"0"'
+ php-ext-base-r1_addtoinifiles "apc.include_once_override" '"0"'
+ php-ext-base-r1_addtoinifiles "apc.rfc1867" '"0"'
+ php-ext-base-r1_addtoinifiles "apc.rfc1867_prefix" '"upload_"'
+ php-ext-base-r1_addtoinifiles "apc.rfc1867_name" '"APC_UPLOAD_PROGRESS"'
+ php-ext-base-r1_addtoinifiles "apc.rfc1867_freq" '"0"'
+ php-ext-base-r1_addtoinifiles "apc.localcache" '"0"'
+ php-ext-base-r1_addtoinifiles "apc.localcache.size" '"512"'
+ php-ext-base-r1_addtoinifiles "apc.coredump_unmap" '"0"'
+
+ dodir "${PHP_EXT_SHARED_DIR}"
+ insinto "${PHP_EXT_SHARED_DIR}"
+ doins apc.php
+}
+
+pkg_postinst() {
+ elog "The apc.php file shipped with this release of PECL-APC was"
+ elog "installed into ${ROOT}usr/share/php5/apc/."
+}
diff --git a/dev-php5/pecl-apc/pecl-apc-3.1.5.ebuild b/dev-php5/pecl-apc/pecl-apc-3.1.5-r2.ebuild
index 2237dc84cf98..ff0523edfe8c 100644
--- a/dev-php5/pecl-apc/pecl-apc-3.1.5.ebuild
+++ b/dev-php5/pecl-apc/pecl-apc-3.1.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-apc/pecl-apc-3.1.5.ebuild,v 1.1 2010/11/02 19:55:03 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-apc/pecl-apc-3.1.5-r2.ebuild,v 1.1 2010/11/04 09:03:50 olemarkus Exp $
EAPI=2