summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2008-03-04 19:43:06 +0000
committerMarkus Ullmann <jokey@gentoo.org>2008-03-04 19:43:06 +0000
commit6bc4d1f8b8fc2f3985da4954c041f56b298b2d2b (patch)
tree41fede031e7ea16cce8ce493f8485f2e0d74a197 /dev-php5/phpunit
parentVersion bump from project overlay (diff)
downloadgentoo-2-6bc4d1f8b8fc2f3985da4954c041f56b298b2d2b.tar.gz
gentoo-2-6bc4d1f8b8fc2f3985da4954c041f56b298b2d2b.tar.bz2
gentoo-2-6bc4d1f8b8fc2f3985da4954c041f56b298b2d2b.zip
Version bump from project overlay
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-php5/phpunit')
-rw-r--r--dev-php5/phpunit/ChangeLog11
-rw-r--r--dev-php5/phpunit/phpunit-3.2.15.ebuild35
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-php5/phpunit/ChangeLog b/dev-php5/phpunit/ChangeLog
index 4a3aa1b19f7c..2263dd1938f4 100644
--- a/dev-php5/phpunit/ChangeLog
+++ b/dev-php5/phpunit/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-php5/phpunit
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/ChangeLog,v 1.15 2008/02/26 16:38:21 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/ChangeLog,v 1.16 2008/03/04 19:43:06 jokey Exp $
+
+*phpunit-3.2.15 (04 Mar 2008)
+
+ 04 Mar 2008; Markus Ullmann <jokey@gentoo.org> +phpunit-3.2.15.ebuild:
+ Version bump from project overlay
+
+ 03 Mar 2008; Jakub Moc <jakub@gentoo.org>
+ +phpunit-3.2.15.ebuild:
+ Version bump
*phpunit-3.2.13 (26 Feb 2008)
diff --git a/dev-php5/phpunit/phpunit-3.2.15.ebuild b/dev-php5/phpunit/phpunit-3.2.15.ebuild
new file mode 100644
index 000000000000..75b4103f6ebb
--- /dev/null
+++ b/dev-php5/phpunit/phpunit-3.2.15.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/phpunit-3.2.15.ebuild,v 1.1 2008/03/04 19:43:06 jokey Exp $
+
+inherit php-pear-lib-r1
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~sparc ~x86"
+
+DESCRIPTION="Unit Testing framework for PHP 5."
+HOMEPAGE="http://www.phpunit.de/"
+SRC_URI="http://pear.phpunit.de/get/PHPUnit-${PV}.tgz"
+LICENSE="BSD"
+SLOT="0"
+IUSE="minimal"
+
+DEPEND="!dev-php4/phpunit"
+RDEPEND="${DEPEND}
+ !minimal? ( >=dev-php5/xdebug-2.0.0
+ >=dev-php/PEAR-Image_GraphViz-1.2.1
+ >=dev-php/PEAR-Log-1.8.7-r1
+ >=dev-php/PEAR-Testing_Selenium-0.2.0 )"
+
+S="${WORKDIR}/PHPUnit-${PV}"
+
+need_php_by_category
+
+pkg_setup() {
+ require_php_with_use pcre reflection spl xml tokenizer
+}
+
+pkg_postinst() {
+ has_php
+ elog "${PN} can optionally use json, pdo-sqlite and pdo-mysql features."
+ elog "If you want those, emerge ${PHP_PKG} with USE=\"json pdo sqlite mysql\"."
+}