summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2005-09-04 17:28:45 +0000
committerStuart Herbert <stuart@gentoo.org>2005-09-04 17:28:45 +0000
commit0fc5ec937a049e17b81125bcea01b8ba97675d6a (patch)
tree030eb9923c54e116c7fa41517015d6a6601f82ad /dev-php
parentRemove stale ebuilds. (diff)
downloadgentoo-2-0fc5ec937a049e17b81125bcea01b8ba97675d6a.tar.gz
gentoo-2-0fc5ec937a049e17b81125bcea01b8ba97675d6a.tar.bz2
gentoo-2-0fc5ec937a049e17b81125bcea01b8ba97675d6a.zip
Removed obsolete versions; use dev-lang/php instead
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/php/ChangeLog6
-rw-r--r--dev-php/php/files/digest-php-5.0.4-r12
-rw-r--r--dev-php/php/files/digest-php-5.1.0_beta-r21
-rw-r--r--dev-php/php/files/php-5.0.3-gcc4.patch11
-rw-r--r--dev-php/php/files/php5_soap_persistence_session.diff35
-rw-r--r--dev-php/php/php-5.0.4-r1.ebuild36
-rw-r--r--dev-php/php/php-5.1.0_beta-r2.ebuild38
7 files changed, 5 insertions, 124 deletions
diff --git a/dev-php/php/ChangeLog b/dev-php/php/ChangeLog
index be843a930de7..874e69f2aa4a 100644
--- a/dev-php/php/ChangeLog
+++ b/dev-php/php/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-php/php
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php/ChangeLog,v 1.187 2005/07/24 05:02:31 hardave Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php/ChangeLog,v 1.188 2005/09/04 17:28:45 stuart Exp $
+
+ 04 Sep 2005; Stuart Herbert <stuart@gentoo.org> -php-5.0.4-r1.ebuild,
+ -php-5.1.0_beta-r2.ebuild:
+ Removed obsolete version
24 Jul 2005; Hardave Riar <hardave@gentoo.org> php-4.4.0.ebuild:
Stable on mips, bug #97655.
diff --git a/dev-php/php/files/digest-php-5.0.4-r1 b/dev-php/php/files/digest-php-5.0.4-r1
deleted file mode 100644
index 3f9c2f5bad90..000000000000
--- a/dev-php/php/files/digest-php-5.0.4-r1
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 13d1cec199f3144f9715194a59db3a8f hardening-patch-5.0.4-0.3.2.patch.gz 78117
-MD5 fb1aac107870f897d26563a9cc5053c0 php-5.0.4.tar.bz2 4731383
diff --git a/dev-php/php/files/digest-php-5.1.0_beta-r2 b/dev-php/php/files/digest-php-5.1.0_beta-r2
deleted file mode 100644
index 36de97e6a7c9..000000000000
--- a/dev-php/php/files/digest-php-5.1.0_beta-r2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 06a6f86743b5fd13cf6c95a8ddb1deac php-5.1.0b3.tar.bz2 5938988
diff --git a/dev-php/php/files/php-5.0.3-gcc4.patch b/dev-php/php/files/php-5.0.3-gcc4.patch
deleted file mode 100644
index fdee5f406b31..000000000000
--- a/dev-php/php/files/php-5.0.3-gcc4.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -ur php-5.0.3-orig/Zend/zend_modules.h php-5.0.3/Zend/zend_modules.h
---- php-5.0.3-orig/Zend/zend_modules.h 2005-05-28 16:57:04.000000000 -0400
-+++ php-5.0.3/Zend/zend_modules.h 2005-05-28 16:59:59.000000000 -0400
-@@ -23,6 +23,7 @@
- #define MODULES_H
-
- #include "zend.h"
-+#include "zend_compile.h"
-
- #define INIT_FUNC_ARGS int type, int module_number TSRMLS_DC
- #define INIT_FUNC_ARGS_PASSTHRU type, module_number TSRMLS_CC
diff --git a/dev-php/php/files/php5_soap_persistence_session.diff b/dev-php/php/files/php5_soap_persistence_session.diff
deleted file mode 100644
index 626ac67f9081..000000000000
--- a/dev-php/php/files/php5_soap_persistence_session.diff
+++ /dev/null
@@ -1,35 +0,0 @@
-diff -ruN php-5.0.0RC3.orig/ext/soap/soap.c php-5.0.0RC3/ext/soap/soap.c
---- php-5.0.0RC3.orig/ext/soap/soap.c 2004-06-22 19:35:59.801348936 +0300
-+++ php-5.0.0RC3/ext/soap/soap.c 2004-06-29 13:39:00.506820928 +0300
-@@ -1341,16 +1341,21 @@
- soap_obj = NULL;
- #if HAVE_PHP_SESSION
- /* If persistent then set soap_obj from from the previous created session (if available) */
-+ char soapname[32+sizeof("_bogus_session_name")]; //Now we use max 32 chars from class name, must be overwriten with dynamic allocation with exact length!!
- if (service->soap_class.persistance == SOAP_PERSISTENCE_SESSION) {
- zval **tmp_soap;
-
-+ bzero(soapname,32+sizeof("_bogus_session_name"));
-+ strncpy(soapname,service->soap_class.ce->name,32);
-+ strcat(soapname,"_bogus_session_name");
-+
- if (PS(session_status) != php_session_active &&
- PS(session_status) != php_session_disabled) {
- php_session_start(TSRMLS_C);
- }
-
- /* Find the soap object and assign */
-- if (zend_hash_find(Z_ARRVAL_P(PS(http_session_vars)), "_bogus_session_name", sizeof("_bogus_session_name"), (void **) &tmp_soap) == SUCCESS &&
-+ if (zend_hash_find(Z_ARRVAL_P(PS(http_session_vars)), soapname, sizeof(soapname), (void **) &tmp_soap) == SUCCESS &&
- Z_TYPE_PP(tmp_soap) == IS_OBJECT &&
- Z_OBJCE_PP(tmp_soap) == service->soap_class.ce) {
- soap_obj = *tmp_soap;
-@@ -1432,7 +1437,7 @@
- /* If session then update session hash with new object */
- if (service->soap_class.persistance == SOAP_PERSISTENCE_SESSION) {
- zval **tmp_soap_pp;
-- if (zend_hash_update(Z_ARRVAL_P(PS(http_session_vars)), "_bogus_session_name", sizeof("_bogus_session_name"), &tmp_soap, sizeof(zval *), (void **)&tmp_soap_pp) == SUCCESS) {
-+ if (zend_hash_update(Z_ARRVAL_P(PS(http_session_vars)), soapname, sizeof(soapname), &tmp_soap, sizeof(zval *), (void **)&tmp_soap_pp) == SUCCESS) {
- soap_obj = *tmp_soap_pp;
- }
- } else {
diff --git a/dev-php/php/php-5.0.4-r1.ebuild b/dev-php/php/php-5.0.4-r1.ebuild
deleted file mode 100644
index ce0186e64b7f..000000000000
--- a/dev-php/php/php-5.0.4-r1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php/php-5.0.4-r1.ebuild,v 1.7 2005/08/16 04:07:37 vapier Exp $
-
-PHPSAPI="cli"
-MY_PHP_P="php-${PV}"
-PHP_S="${WORKDIR}/${MY_PHP_P}"
-PHP_PACKAGE=1
-
-inherit php5-sapi-r2 eutils
-
-DESCRIPTION="PHP Shell Interpreter"
-LICENSE="PHP"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~x86"
-PROVIDE="virtual/php"
-SLOT="0"
-
-PHP_INSTALLTARGETS="${PHP_INSTALLTARGETS} install-cli"
-
-src_unpack() {
- php5-sapi-r2_src_unpack
-
- ###########################################################################
- # DO NOT ADD YOUR PATCHES HERE
- #
- # Please add your patches into the eclass, where they belong!
- #
- # Thanks,
- # Stu
- ###########################################################################
-}
-
-src_compile () {
- my_conf="--disable-cgi --enable-cli"
- php5-sapi-r2_src_compile
-}
diff --git a/dev-php/php/php-5.1.0_beta-r2.ebuild b/dev-php/php/php-5.1.0_beta-r2.ebuild
deleted file mode 100644
index 3f5502de62de..000000000000
--- a/dev-php/php/php-5.1.0_beta-r2.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php/php-5.1.0_beta-r2.ebuild,v 1.3 2005/07/16 15:25:44 swegener Exp $
-
-PHPSAPI="cli"
-MY_PV="5.1.0b3"
-MY_PHP_P="php-${MY_PV}"
-PHP_S="${WORKDIR}/${MY_PHP_P}"
-PHP_PACKAGE=1
-
-inherit php5-sapi-r3 eutils
-
-DESCRIPTION="PHP Shell Interpreter"
-LICENSE="PHP"
-KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
-PDEPEND=">=dev-php/PEAR-PEAR-1.3.5-r1"
-PROVIDE="virtual/php"
-SLOT="0"
-
-PHP_INSTALLTARGETS="${PHP_INSTALLTARGETS} install-cli"
-
-src_unpack() {
- php5-sapi-r3_src_unpack
-
- ###########################################################################
- # DO NOT ADD YOUR PATCHES HERE
- #
- # Please add your patches into the eclass, where they belong!
- #
- # Thanks,
- # Stu
- ###########################################################################
-}
-
-src_compile () {
- my_conf="--disable-cgi --enable-cli"
- php5-sapi-r3_src_compile
-}