summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2013-06-26 09:18:23 +0000
committerOle Markus With <olemarkus@gentoo.org>2013-06-26 09:18:23 +0000
commit85db13fe2ece1055c9d06057d634836b7bc99f70 (patch)
treeb6613fe05448aab19fcb37e2eb8d4c53aa3aa2f8 /dev-php
parentVersion bump (diff)
downloadgentoo-2-85db13fe2ece1055c9d06057d634836b7bc99f70.tar.gz
gentoo-2-85db13fe2ece1055c9d06057d634836b7bc99f70.tar.bz2
gentoo-2-85db13fe2ece1055c9d06057d634836b7bc99f70.zip
Revbump. Fix issue with --enable-apcu-mmap disables mmap (!)
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key C4A92BF5)
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-apcu/ChangeLog8
-rw-r--r--dev-php/pecl-apcu/pecl-apcu-4.0.1-r1.ebuild63
2 files changed, 70 insertions, 1 deletions
diff --git a/dev-php/pecl-apcu/ChangeLog b/dev-php/pecl-apcu/ChangeLog
index 666d46fa9f1b..197004653bf9 100644
--- a/dev-php/pecl-apcu/ChangeLog
+++ b/dev-php/pecl-apcu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php/pecl-apcu
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-apcu/ChangeLog,v 1.1 2013/04/30 10:08:33 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-apcu/ChangeLog,v 1.2 2013/06/26 09:18:23 olemarkus Exp $
+
+*pecl-apcu-4.0.1-r1 (26 Jun 2013)
+
+ 26 Jun 2013; Ole Markus With <olemarkus@gentoo.org>
+ +pecl-apcu-4.0.1-r1.ebuild:
+ Revbump. Fix issue with --enable-apcu-mmap disables mmap (!)
*pecl-apcu-4.0.0 (30 Apr 2013)
*pecl-apcu-4.0.1 (30 Apr 2013)
diff --git a/dev-php/pecl-apcu/pecl-apcu-4.0.1-r1.ebuild b/dev-php/pecl-apcu/pecl-apcu-4.0.1-r1.ebuild
new file mode 100644
index 000000000000..09e4d9c8541a
--- /dev/null
+++ b/dev-php/pecl-apcu/pecl-apcu-4.0.1-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-apcu/pecl-apcu-4.0.1-r1.ebuild,v 1.1 2013/06/26 09:18:23 olemarkus Exp $
+
+EAPI=5
+
+PHP_EXT_NAME="apcu"
+PHP_EXT_PECL_PKG="APCu"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="CHANGELOG INSTALL NOTICE TECHNOTES.txt TODO"
+
+USE_PHP="php5-5 php5-3 php5-4"
+
+S="${WORKDIR}/apcu-${PV}"
+PHP_EXT_S="${WORKDIR}/apcu-${PV}"
+
+inherit php-ext-pecl-r2 confutils eutils
+
+S="${WORKDIR}/apcu-${PV}"
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Stripped down version of APC supporting only user cache."
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE="+mmap"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+LOCKS="pthreadmutex pthreadrw spinlock semaphore"
+
+LUSE=""
+for l in ${LOCKS}; do
+ LUSE+="lock_${l} "
+done
+
+IUSE+=" ${LUSE/lock_pthreadrw/+lock_pthreadrw}"
+
+REQUIRED_USE="^^ ( $LUSE )"
+
+src_configure() {
+ my_conf="--enable-apcu"
+ use mmap || my_conf+=" --disable-apcu-mmap"
+
+ enable_extension_enable "apcu-rwlocks" "lock_pthreadrw" 0
+
+ php-ext-source-r2_src_configure
+}
+
+src_install() {
+ php-ext-pecl-r2_src_install
+
+ dodir "${PHP_EXT_SHARED_DIR}"
+ insinto "${PHP_EXT_SHARED_DIR}"
+ doins apc.php
+}
+
+pkg_postinst() {
+ elog "The apc.php file shipped with this release of pecl-apcu was"
+ elog "installed into ${PHP_EXT_SHARED_DIR}/."
+}