summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-11-10 12:19:00 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-11-10 12:19:00 +0000
commit8b0de2854b90f275160eb5d068717f5e217739b1 (patch)
treef52504be46ffea88b90590fe18b64681c4777c52 /dev-python/Numeric
parentA=-fix, try->die, tab-fixes, stylefixes, ... (diff)
downloadgentoo-2-8b0de2854b90f275160eb5d068717f5e217739b1.tar.gz
gentoo-2-8b0de2854b90f275160eb5d068717f5e217739b1.tar.bz2
gentoo-2-8b0de2854b90f275160eb5d068717f5e217739b1.zip
A=-fix, try->die, tab-fixes, stylefixes, ...
Diffstat (limited to 'dev-python/Numeric')
-rw-r--r--dev-python/Numeric/Numeric-19.0.0.ebuild24
1 files changed, 9 insertions, 15 deletions
diff --git a/dev-python/Numeric/Numeric-19.0.0.ebuild b/dev-python/Numeric/Numeric-19.0.0.ebuild
index 30d919b42e79..26a86d065dd7 100644
--- a/dev-python/Numeric/Numeric-19.0.0.ebuild
+++ b/dev-python/Numeric/Numeric-19.0.0.ebuild
@@ -1,33 +1,27 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Tod M. Neidt <tneidt@fidnet.com>
-# $Header: /var/cvsroot/gentoo-x86/dev-python/Numeric/Numeric-19.0.0.ebuild,v 1.3 2001/08/31 03:23:38 pm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/Numeric/Numeric-19.0.0.ebuild,v 1.4 2001/11/10 12:14:29 hallski Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="numerical python module"
-SRC_URI="http://prdownloads.sourceforge.net/numpy/"${A}
+SRC_URI="http://prdownloads.sourceforge.net/numpy/${P}.tar.gz"
HOMEPAGE="http://www.pfdubois.com/numpy/"
DEPEND="virtual/python"
PYTHON_VERSION=
+
src_compile() {
- cd ${S}
- try python setup_all.py build
+ python setup_all.py build || die
}
src_install() {
- cd ${S}
- try python setup_all.py install --prefix=${D}/usr
- dodoc MANIFEST
- dodoc PKG-INFO
- dodoc README*
-#need to automate the python version in the path
- mv Demo/NumTut ${D}/usr/lib/python2.0/site-packages/
-}
-
-
+ python setup_all.py install --prefix=${D}/usr || die
+ dodoc MANIFEST PKG-INFO README*
+ #need to automate the python version in the path
+ mv Demo/NumTut ${D}/usr/lib/python2.0/site-packages/
+}