summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2012-09-03 07:18:12 +0000
committerDavide Pesavento <pesa@gentoo.org>2012-09-03 07:18:12 +0000
commit688709085715bef0ea74c4e225c428531e8b9ab5 (patch)
tree3dc1b6ca02d4038d06f2832d2fd5336d15ed11b1 /dev-python/PyQt4
parentnet-analyzer/linkchecker: Version Bump (diff)
downloadgentoo-2-688709085715bef0ea74c4e225c428531e8b9ab5.tar.gz
gentoo-2-688709085715bef0ea74c4e225c428531e8b9ab5.tar.bz2
gentoo-2-688709085715bef0ea74c4e225c428531e8b9ab5.zip
Apply upstream patch to fix regression in pyuic's handling of custom widgets (bug 431070 by Laurent Bachelier).
(Portage version: 2.2.0_alpha123-r2/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/PyQt4')
-rw-r--r--dev-python/PyQt4/ChangeLog9
-rw-r--r--dev-python/PyQt4/PyQt4-4.9.4-r1.ebuild211
-rw-r--r--dev-python/PyQt4/files/PyQt4-4.9.4-pyuic-custom-widgets.patch93
3 files changed, 312 insertions, 1 deletions
diff --git a/dev-python/PyQt4/ChangeLog b/dev-python/PyQt4/ChangeLog
index 70a9ada24d1b..90635164cabc 100644
--- a/dev-python/PyQt4/ChangeLog
+++ b/dev-python/PyQt4/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/PyQt4
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.196 2012/08/20 18:52:36 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.197 2012/09/03 07:18:12 pesa Exp $
+
+*PyQt4-4.9.4-r1 (03 Sep 2012)
+
+ 03 Sep 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.4-r1.ebuild,
+ +files/PyQt4-4.9.4-pyuic-custom-widgets.patch:
+ Apply upstream patch to fix regression in pyuic's handling of custom widgets
+ (bug 431070 by Laurent Bachelier).
20 Aug 2012; Johannes Huber <johu@gentoo.org> PyQt4-4.9.4.ebuild:
Stable for x86, wrt bug #429042
diff --git a/dev-python/PyQt4/PyQt4-4.9.4-r1.ebuild b/dev-python/PyQt4/PyQt4-4.9.4-r1.ebuild
new file mode 100644
index 000000000000..aa37ba490af1
--- /dev/null
+++ b/dev-python/PyQt4/PyQt4-4.9.4-r1.ebuild
@@ -0,0 +1,211 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.9.4-r1.ebuild,v 1.1 2012/09/03 07:18:12 pesa Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="*"
+PYTHON_EXPORT_PHASE_FUNCTIONS="1"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython *-pypy-*"
+
+inherit eutils toolchain-funcs qt4-r2 python
+
+# Minimal supported version of Qt.
+QT_VER="4.7.2"
+
+DESCRIPTION="Python bindings for the Qt toolkit"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/software/pyqt/intro/ http://pypi.python.org/pypi/PyQt"
+
+if [[ ${PV} == *_pre* ]]; then
+ MY_P="PyQt-x11-gpl-snapshot-${PV%_pre*}-${REVISION}"
+ SRC_URI="http://www.gentoo-el.org/~hwoarang/distfiles/${MY_P}.tar.gz"
+else
+ MY_P="PyQt-x11-gpl-${PV}"
+ SRC_URI="http://www.riverbankcomputing.com/static/Downloads/${PN}/${MY_P}.tar.gz"
+fi
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="X assistant dbus debug declarative doc examples kde multimedia opengl phonon sql svg webkit xmlpatterns"
+
+REQUIRED_USE="
+ assistant? ( X )
+ declarative? ( X )
+ multimedia? ( X )
+ opengl? ( X )
+ phonon? ( X )
+ sql? ( X )
+ svg? ( X )
+ webkit? ( X )
+"
+
+RDEPEND="
+ >=dev-python/sip-4.13.3
+ >=x11-libs/qt-core-${QT_VER}:4
+ >=x11-libs/qt-script-${QT_VER}:4
+ X? (
+ >=x11-libs/qt-gui-${QT_VER}:4[dbus?]
+ >=x11-libs/qt-test-${QT_VER}:4
+ )
+ assistant? ( >=x11-libs/qt-assistant-${QT_VER}:4 )
+ dbus? (
+ >=dev-python/dbus-python-0.80
+ >=x11-libs/qt-dbus-${QT_VER}:4
+ )
+ declarative? ( >=x11-libs/qt-declarative-${QT_VER}:4 )
+ multimedia? ( >=x11-libs/qt-multimedia-${QT_VER}:4 )
+ opengl? (
+ >=x11-libs/qt-opengl-${QT_VER}:4
+ || ( >=x11-libs/qt-opengl-4.8.0:4 <x11-libs/qt-opengl-4.8.0:4[-egl] )
+ )
+ phonon? (
+ !kde? ( || ( >=x11-libs/qt-phonon-${QT_VER}:4 media-libs/phonon ) )
+ kde? ( media-libs/phonon )
+ )
+ sql? ( >=x11-libs/qt-sql-${QT_VER}:4 )
+ svg? ( >=x11-libs/qt-svg-${QT_VER}:4 )
+ webkit? ( >=x11-libs/qt-webkit-${QT_VER}:4 )
+ xmlpatterns? ( >=x11-libs/qt-xmlpatterns-${QT_VER}:4 )
+"
+DEPEND="${RDEPEND}
+ dbus? ( virtual/pkgconfig )
+"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.7.2-configure.py.patch"
+ "${FILESDIR}/${P}-pyuic-custom-widgets.patch"
+)
+
+PYTHON_VERSIONED_EXECUTABLES=("/usr/bin/pyuic4")
+
+src_prepare() {
+ if ! use dbus; then
+ sed -e 's/^\([[:blank:]]\+\)check_dbus()/\1pass/' -i configure.py || die
+ fi
+
+ # Support qreal for arm architecture (bug #322349).
+ use arm && epatch "${FILESDIR}/${PN}-4.7.3-qreal_float_support.patch"
+
+ qt4-r2_src_prepare
+
+ # Use proper include directory.
+ sed -e "s:/usr/include:${EPREFIX}/usr/include:g" -i configure.py || die
+
+ python_copy_sources
+
+ preparation() {
+ if [[ $(python_get_version -l --major) == 3 ]]; then
+ rm -fr pyuic/uic/port_v2
+ else
+ rm -fr pyuic/uic/port_v3
+ fi
+ }
+ python_execute_function -s preparation
+}
+
+pyqt4_use_enable() {
+ use $1 && echo "--enable=${2:-$1}"
+}
+
+src_configure() {
+ configuration() {
+ local myconf=("$(PYTHON)"
+ configure.py
+ --confirm-license
+ --bindir="${EPREFIX}/usr/bin"
+ --destdir="${EPREFIX}$(python_get_sitedir)"
+ --sipdir="${EPREFIX}/usr/share/sip"
+ --assume-shared
+ --no-timestamp
+ --qsci-api
+ $(use debug && echo --debug)
+ --enable=QtCore
+ --enable=QtNetwork
+ --enable=QtScript
+ --enable=QtXml
+ $(pyqt4_use_enable X QtGui)
+ $(pyqt4_use_enable X QtDesigner) $(use X || echo --no-designer-plugin)
+ $(pyqt4_use_enable X QtScriptTools)
+ $(pyqt4_use_enable X QtTest)
+ $(pyqt4_use_enable assistant QtHelp)
+ $(pyqt4_use_enable dbus QtDBus)
+ $(pyqt4_use_enable declarative QtDeclarative)
+ $(pyqt4_use_enable multimedia QtMultimedia)
+ $(pyqt4_use_enable opengl QtOpenGL)
+ $(pyqt4_use_enable phonon)
+ $(pyqt4_use_enable sql QtSql)
+ $(pyqt4_use_enable svg QtSvg)
+ $(pyqt4_use_enable webkit QtWebKit)
+ $(pyqt4_use_enable xmlpatterns QtXmlPatterns)
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
+ LINK="$(tc-getCXX)"
+ LINK_SHLIB="$(tc-getCXX)"
+ CFLAGS="${CFLAGS}"
+ CXXFLAGS="${CXXFLAGS}"
+ LFLAGS="${LDFLAGS}")
+ echo "${myconf[@]}"
+ "${myconf[@]}" || die
+
+ local mod
+ for mod in QtCore \
+ $(use X && echo QtDesigner QtGui) \
+ $(use dbus && echo QtDBus) \
+ $(use declarative && echo QtDeclarative) \
+ $(use opengl && echo QtOpenGL); do
+ # Run eqmake4 inside the qpy subdirectories to respect
+ # CC, CXX, CFLAGS, CXXFLAGS, LDFLAGS and avoid stripping.
+ pushd qpy/${mod} > /dev/null || return 1
+ eqmake4 $(ls w_qpy*.pro)
+ popd > /dev/null || return 1
+
+ # Fix insecure runpaths.
+ sed -e "/^LFLAGS[[:space:]]*=/s:-Wl,-rpath,${BUILDDIR}/qpy/${mod}::" \
+ -i ${mod}/Makefile || die "Failed to fix rpath for ${mod}"
+ done
+
+ # Avoid stripping of libpythonplugin.so.
+ if use X; then
+ pushd designer > /dev/null || return 1
+ eqmake4 python.pro
+ popd > /dev/null || return 1
+ fi
+ }
+ python_execute_function -s configuration
+}
+
+src_install() {
+ installation() {
+ # INSTALL_ROOT is used by designer/Makefile, other Makefiles use DESTDIR.
+ emake DESTDIR="${T}/images/${PYTHON_ABI}" INSTALL_ROOT="${T}/images/${PYTHON_ABI}" install
+ }
+ python_execute_function -s installation
+ python_merge_intermediate_installation_images "${T}/images"
+
+ dodoc NEWS THANKS
+
+ if use doc; then
+ dohtml -r doc/html/*
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
+
+pkg_postinst() {
+ python_mod_optimize PyQt4
+
+ ewarn "When updating dev-python/PyQt4, you usually need to rebuild packages that depend on it,"
+ ewarn "such as dev-python/qscintilla-python and kde-base/pykde4. If you have app-portage/gentoolkit"
+ ewarn "installed, you can find these packages with \`equery d dev-python/PyQt4\`."
+}
+
+pkg_postrm() {
+ python_mod_cleanup PyQt4
+}
diff --git a/dev-python/PyQt4/files/PyQt4-4.9.4-pyuic-custom-widgets.patch b/dev-python/PyQt4/files/PyQt4-4.9.4-pyuic-custom-widgets.patch
new file mode 100644
index 000000000000..20ebeb93e842
--- /dev/null
+++ b/dev-python/PyQt4/files/PyQt4-4.9.4-pyuic-custom-widgets.patch
@@ -0,0 +1,93 @@
+
+
+# HG changeset patch
+# User Phil Thompson <phil@riverbankcomputing.com>
+# Date 2012-07-13 13:39:28 +0100
+# Node ID 29b668ada14c1428a3bbfe8f0324c6626bd5ac9a
+# Parent fd0f3da9d79ca9858d10a20c15fb85456cb832d7
+Fixed a regression in pyuic's handling of custom widgets.
+
+diff --git a/pyuic/uic/Compiler/qobjectcreator.py b/pyuic/uic/Compiler/qobjectcreator.py
+--- a/pyuic/uic/Compiler/qobjectcreator.py
++++ b/pyuic/uic/Compiler/qobjectcreator.py
+@@ -1,6 +1,6 @@
+ #############################################################################
+ ##
+-## Copyright (C) 2011 Riverbank Computing Limited.
++## Copyright (C) 2012 Riverbank Computing Limited.
+ ## Copyright (C) 2006 Thorsten Marek.
+ ## All right reserved.
+ ##
+@@ -100,7 +100,6 @@
+ assert widgetClass not in self._widgets
+ self._widgets[widgetClass] = (baseClass, module)
+
+-
+ def _resolveBaseclass(self, baseClass):
+ try:
+ for x in range(0, 10):
+@@ -114,19 +113,17 @@
+ except KeyError:
+ raise ValueError("unknown baseclass %s" % baseClass)
+
+-
+ def search(self, cls):
+ try:
+- self._usedWidgets.add(cls)
+ baseClass = self._resolveBaseclass(self._widgets[cls][0])
+ DEBUG("resolved baseclass of %s: %s" % (cls, baseClass))
+-
+- return type(cls, (baseClass,),
+- {"module" : ""})
+-
+ except KeyError:
+ return None
+
++ self._usedWidgets.add(cls)
++
++ return type(cls, (baseClass, ), {"module" : ""})
++
+ def _writeImportCode(self):
+ imports = {}
+ for widget in self._usedWidgets:
+diff --git a/pyuic/uic/objcreator.py b/pyuic/uic/objcreator.py
+--- a/pyuic/uic/objcreator.py
++++ b/pyuic/uic/objcreator.py
+@@ -102,19 +102,26 @@
+ self._modules.append(self._customWidgets)
+
+ def createQObject(self, classname, *args, **kwargs):
+- # Handle scoped names, typically static factory methods.
+- parts = classname.split('.')
+- factory = self.findQObjectType(parts[0])
++ # Handle regular and custom widgets.
++ factory = self.findQObjectType(classname)
+
+- if factory is not None:
+- for part in parts[1:]:
+- factory = getattr(factory, part, None)
+- if factory is None:
+- break
+- else:
+- return self._cpolicy.instantiate(factory, *args, **kwargs)
++ if factory is None:
++ # Handle scoped names, typically static factory methods.
++ parts = classname.split('.')
+
+- raise NoSuchWidgetError(classname)
++ if len(parts) > 1:
++ factory = self.findQObjectType(parts[0])
++
++ if factory is not None:
++ for part in parts[1:]:
++ factory = getattr(factory, part, None)
++ if factory is None:
++ break
++
++ if factory is None:
++ raise NoSuchWidgetError(classname)
++
++ return self._cpolicy.instantiate(factory, *args, **kwargs)
+
+ def invoke(self, rname, method, args=()):
+ return self._cpolicy.invoke(rname, method, args)