summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-11-10 12:19:00 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-11-10 12:19:00 +0000
commit8b0de2854b90f275160eb5d068717f5e217739b1 (patch)
treef52504be46ffea88b90590fe18b64681c4777c52 /dev-python/PyQt
parentA=-fix, try->die, tab-fixes, stylefixes, ... (diff)
downloadgentoo-2-8b0de2854b90f275160eb5d068717f5e217739b1.tar.gz
gentoo-2-8b0de2854b90f275160eb5d068717f5e217739b1.tar.bz2
gentoo-2-8b0de2854b90f275160eb5d068717f5e217739b1.zip
A=-fix, try->die, tab-fixes, stylefixes, ...
Diffstat (limited to 'dev-python/PyQt')
-rw-r--r--dev-python/PyQt/PyQt-2.4.ebuild19
1 files changed, 11 insertions, 8 deletions
diff --git a/dev-python/PyQt/PyQt-2.4.ebuild b/dev-python/PyQt/PyQt-2.4.ebuild
index 28ef49db1c61..bc7ef1e39b8e 100644
--- a/dev-python/PyQt/PyQt-2.4.ebuild
+++ b/dev-python/PyQt/PyQt-2.4.ebuild
@@ -1,12 +1,11 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: tools@cvs.gentoo.org
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-2.4.ebuild,v 1.3 2001/08/11 23:23:04 chadh Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-2.4.ebuild,v 1.4 2001/11/10 12:14:29 hallski Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="PyQt is a set of Python bindings for the Qt Toolkit."
-SRC_URI="http://www.river-bank.demon.co.uk/software/"${A}
+SRC_URI="http://www.river-bank.demon.co.uk/software/${P}.tar.gz"
HOMEPAGE="http://www.thekompany.com/projects/pykde/"
DEPEND=">=x11-libs/qt-x11-1.4.2
@@ -14,12 +13,16 @@ DEPEND=">=x11-libs/qt-x11-1.4.2
virtual/python"
src_compile() {
- try ./configure --prefix=/usr --infodir=/usr/share/info --mandir=/usr/share/man --with-doc-install=/usr/share/doc
- try make
+ ./configure --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --with-doc-install=/usr/share/doc
+ assert
+
+ make || die
}
src_install() {
- try make DESTDIR=${D} install
- try make DESTDIR=${D} install-doc
+ make DESTDIR=${D} install || die
+ make DESTDIR=${D} install-doc || die
}
-