summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-06-26 12:35:19 +0000
committerJustin Lecher <jlec@gentoo.org>2015-06-26 12:35:19 +0000
commitfb694f9fc52aacc1a14766949f8df24b83bed73e (patch)
treee0691540625775c05bd290336701af748fd7fd27 /dev-python/algopy
parentVersion Bump (diff)
downloadgentoo-2-fb694f9fc52aacc1a14766949f8df24b83bed73e.tar.gz
gentoo-2-fb694f9fc52aacc1a14766949f8df24b83bed73e.tar.bz2
gentoo-2-fb694f9fc52aacc1a14766949f8df24b83bed73e.zip
Version Bump
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key E9402A79B03529A2!)
Diffstat (limited to 'dev-python/algopy')
-rw-r--r--dev-python/algopy/ChangeLog7
-rw-r--r--dev-python/algopy/algopy-0.5.3.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/dev-python/algopy/ChangeLog b/dev-python/algopy/ChangeLog
index 61862d3ab5d8..1b5b12c23e90 100644
--- a/dev-python/algopy/ChangeLog
+++ b/dev-python/algopy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/algopy
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/algopy/ChangeLog,v 1.3 2015/06/03 11:59:10 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/algopy/ChangeLog,v 1.4 2015/06/26 12:35:19 jlec Exp $
+
+*algopy-0.5.3 (26 Jun 2015)
+
+ 26 Jun 2015; Justin Lecher <jlec@gentoo.org> +algopy-0.5.3.ebuild:
+ Version Bump
03 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Add pypi to remote-id in metadata.xml
diff --git a/dev-python/algopy/algopy-0.5.3.ebuild b/dev-python/algopy/algopy-0.5.3.ebuild
new file mode 100644
index 000000000000..df02441a18b3
--- /dev/null
+++ b/dev-python/algopy/algopy-0.5.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/algopy/algopy-0.5.3.ebuild,v 1.1 2015/06/26 12:35:19 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Taylor Arithmetic Computation and Algorithmic Differentiation"
+HOMEPAGE="https://pypi.python.org/pypi/algopy http://packages.python.org/algopy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ ${EPYTHON} run_tests.py || die
+}