summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2014-05-28 16:02:07 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2014-05-28 16:02:07 +0000
commit483f09860b0ed001e81552918213b0d6adb48958 (patch)
treef3d553aa92763f83613d5f171bc76e717f0c0c32 /dev-python/astropy/astropy-0.3.2.ebuild
parentDrop old (diff)
downloadgentoo-2-483f09860b0ed001e81552918213b0d6adb48958.tar.gz
gentoo-2-483f09860b0ed001e81552918213b0d6adb48958.tar.bz2
gentoo-2-483f09860b0ed001e81552918213b0d6adb48958.zip
Version bump
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'dev-python/astropy/astropy-0.3.2.ebuild')
-rw-r--r--dev-python/astropy/astropy-0.3.2.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/astropy/astropy-0.3.2.ebuild b/dev-python/astropy/astropy-0.3.2.ebuild
new file mode 100644
index 000000000000..bed48c5b17a5
--- /dev/null
+++ b/dev-python/astropy/astropy-0.3.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/astropy/astropy-0.3.2.ebuild,v 1.1 2014/05/28 16:02:07 bicatali Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Core functionality for performing astrophysics with Python"
+HOMEPAGE="http://astropy.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ dev-libs/expat:0=
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-astronomy/erfa:0=
+ sci-astronomy/wcslib:0=
+ >=sci-libs/cfitsio-3.350:0=
+ sys-libs/zlib:0="
+DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+ doc? (
+ dev-python/matplotlib
+ dev-python/sphinx
+ media-gfx/graphviz
+ )
+ test? (
+ dev-libs/libxml2
+ dev-python/h5py[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ )"
+
+python_compile() {
+ distutils-r1_python_compile --use-system-libraries
+}
+
+python_compile_all() {
+ if use doc; then
+ python_export_best
+ VARTEXFONTS="${T}"/fonts \
+ MPLCONFIGDIR="${BUILD_DIR}" \
+ PYTHONPATH="${BUILD_DIR}"/lib \
+ esetup.py build_sphinx
+ fi
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}