summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2007-03-28 20:18:37 +0000
committerChristian Faulhammer <opfer@gentoo.org>2007-03-28 20:18:37 +0000
commit81a477a6ffd02f05bc4445b25080d0328d69f1ee (patch)
tree862c49b1c5cc9e0382eebc6ceddfbfec379be3c7 /dev-python/cgkit
parentapp-misc/pyge gone (diff)
downloadgentoo-2-81a477a6ffd02f05bc4445b25080d0328d69f1ee.tar.gz
gentoo-2-81a477a6ffd02f05bc4445b25080d0328d69f1ee.tar.bz2
gentoo-2-81a477a6ffd02f05bc4445b25080d0328d69f1ee.zip
force a file to be regenerated, so compilation with GCC 4 succeeds. Fixes bug 152210, reported by Andy <andyreif@studcs.uni-sb.de>
(Portage version: 2.1.2.2)
Diffstat (limited to 'dev-python/cgkit')
-rw-r--r--dev-python/cgkit/ChangeLog6
-rw-r--r--dev-python/cgkit/cgkit-1.2.0.ebuild11
2 files changed, 14 insertions, 3 deletions
diff --git a/dev-python/cgkit/ChangeLog b/dev-python/cgkit/ChangeLog
index 8c1540eddc2d..f2c6c8854fb5 100644
--- a/dev-python/cgkit/ChangeLog
+++ b/dev-python/cgkit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/cgkit
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cgkit/ChangeLog,v 1.16 2007/02/15 14:02:08 chrb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cgkit/ChangeLog,v 1.17 2007/03/28 20:18:37 opfer Exp $
+
+ 28 Mar 2007; Christian Faulhammer <opfer@gentoo.org> cgkit-1.2.0.ebuild:
+ force a file to be regenerated, so compilation with GCC 4 succeeds. Fixes
+ bug 152210, reported by Andy <andyreif@studcs.uni-sb.de>
*cgkit-2.0.0_alpha7 (15 Feb 2007)
diff --git a/dev-python/cgkit/cgkit-1.2.0.ebuild b/dev-python/cgkit/cgkit-1.2.0.ebuild
index 5770a662c104..1dbe36dbd099 100644
--- a/dev-python/cgkit/cgkit-1.2.0.ebuild
+++ b/dev-python/cgkit/cgkit-1.2.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cgkit/cgkit-1.2.0.ebuild,v 1.3 2006/03/19 22:42:32 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cgkit/cgkit-1.2.0.ebuild,v 1.4 2007/03/28 20:18:37 opfer Exp $
inherit distutils
@@ -17,6 +17,13 @@ LICENSE="GPL-2"
KEYWORDS="x86 ~ppc"
IUSE="doc"
+src_unpack() {
+ unpack ${A}
+ # this forces the file to be regenerated by the build system using
+ # pyrex. Compilation with GCC 4 would fail otherwise, see
+ # bug #152210
+ rm "${S}/cgtypes.c"
+}
src_install () {
distutils_src_install
if use doc; then