summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-10-23 03:23:26 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-10-23 03:23:26 +0000
commitdf06369d171b0d3d48f290d823d8ebf676a920bf (patch)
treeccc28e569c0ee0ddc0f7f99b6b4823f7cd914144 /dev-python/cliff
parentupdate of cmd2 (yay better pyparsing) (diff)
downloadgentoo-2-df06369d171b0d3d48f290d823d8ebf676a920bf.tar.gz
gentoo-2-df06369d171b0d3d48f290d823d8ebf676a920bf.tar.bz2
gentoo-2-df06369d171b0d3d48f290d823d8ebf676a920bf.zip
update of cliff for openstack (better pyparsing as well)
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/cliff')
-rw-r--r--dev-python/cliff/ChangeLog7
-rw-r--r--dev-python/cliff/cliff-1.4.5.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-python/cliff/ChangeLog b/dev-python/cliff/ChangeLog
index fa5e8a701595..0e9c97f1ce61 100644
--- a/dev-python/cliff/ChangeLog
+++ b/dev-python/cliff/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/cliff
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cliff/ChangeLog,v 1.6 2013/10/13 08:38:01 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cliff/ChangeLog,v 1.7 2013/10/23 03:23:26 prometheanfire Exp $
+
+*cliff-1.4.5 (23 Oct 2013)
+
+ 23 Oct 2013; Matthew Thode <prometheanfire@gentoo.org> +cliff-1.4.5.ebuild:
+ update of cliff for openstack (better pyparsing as well)
13 Oct 2013; Pacho Ramos <pacho@gentoo.org> cliff-1.4.ebuild:
Also compatible with python3_3
diff --git a/dev-python/cliff/cliff-1.4.5.ebuild b/dev-python/cliff/cliff-1.4.5.ebuild
new file mode 100644
index 000000000000..201a6fa77d43
--- /dev/null
+++ b/dev-python/cliff/cliff-1.4.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cliff/cliff-1.4.5.ebuild,v 1.1 2013/10/23 03:23:26 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_2,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Command Line Interface Formulation Framework"
+HOMEPAGE="https://github.com/dreamhost/cliff"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.6[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/cmd2-0.6.7[${PYTHON_USEDEP}]
+ virtual/python-argparse[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/pep8[${PYTHON_USEDEP}]
+ dev-python/cmd2[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests tests || die "Tests fail with ${EPYTHON}"
+}