summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-03-03 19:02:55 +0000
committerJustin Lecher <jlec@gentoo.org>2015-03-03 19:02:55 +0000
commita854d56b118f4233d6cf3b38c836e9ee4ca22836 (patch)
tree3ae3237e26a71705e4e915a06a1e7fe9b458d24e /dev-python/curtsies
parentNew package written by me (diff)
downloadgentoo-2-a854d56b118f4233d6cf3b38c836e9ee4ca22836.tar.gz
gentoo-2-a854d56b118f4233d6cf3b38c836e9ee4ca22836.tar.bz2
gentoo-2-a854d56b118f4233d6cf3b38c836e9ee4ca22836.zip
Version BUmp; fix deps and test
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-python/curtsies')
-rw-r--r--dev-python/curtsies/ChangeLog8
-rw-r--r--dev-python/curtsies/curtsies-0.1.18.ebuild21
-rw-r--r--dev-python/curtsies/curtsies-0.2.3.ebuild35
3 files changed, 58 insertions, 6 deletions
diff --git a/dev-python/curtsies/ChangeLog b/dev-python/curtsies/ChangeLog
index 7f6cd405df0a..949854c273eb 100644
--- a/dev-python/curtsies/ChangeLog
+++ b/dev-python/curtsies/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/curtsies
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/curtsies/ChangeLog,v 1.1 2015/02/17 13:26:45 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/curtsies/ChangeLog,v 1.2 2015/03/03 19:02:55 jlec Exp $
+
+*curtsies-0.2.3 (03 Mar 2015)
+
+ 03 Mar 2015; Justin Lecher <jlec@gentoo.org> +curtsies-0.2.3.ebuild,
+ curtsies-0.1.18.ebuild:
+ Version BUmp; fix deps and test
*curtsies-0.1.18 (17 Feb 2015)
diff --git a/dev-python/curtsies/curtsies-0.1.18.ebuild b/dev-python/curtsies/curtsies-0.1.18.ebuild
index c48573793f2b..c49e4ddccbc2 100644
--- a/dev-python/curtsies/curtsies-0.1.18.ebuild
+++ b/dev-python/curtsies/curtsies-0.1.18.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/curtsies/curtsies-0.1.18.ebuild,v 1.1 2015/02/17 13:26:45 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/curtsies/curtsies-0.1.18.ebuild,v 1.2 2015/03/03 19:02:55 jlec Exp $
EAPI=5
@@ -15,10 +15,21 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
SLOT="0"
LICENSE="MIT"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
+IUSE="test"
RDEPEND="
- dev-python/blessings[${PYTHON_USEDEP}]
- dev-python/wcwidth[${PYTHON_USEDEP}]
+ >=dev-python/blessings-1.5[${PYTHON_USEDEP}]
+ >=dev-python/wcwidth-0.1.4[${PYTHON_USEDEP}]
"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pyte[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ nosetests tests || die
+}
diff --git a/dev-python/curtsies/curtsies-0.2.3.ebuild b/dev-python/curtsies/curtsies-0.2.3.ebuild
new file mode 100644
index 000000000000..ea0987ad5392
--- /dev/null
+++ b/dev-python/curtsies/curtsies-0.2.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/curtsies/curtsies-0.2.3.ebuild,v 1.1 2015/03/03 19:02:55 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Curses-like terminal wrapper, with colored strings"
+HOMEPAGE="https://github.com/thomasballinger/curtsies"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/blessings-1.5[${PYTHON_USEDEP}]
+ >=dev-python/wcwidth-0.1.4[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pyte[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ nosetests tests || die
+}