summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-07-21 16:33:25 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-07-21 16:33:25 +0000
commit403abdbcb08a11c6aef6a610e73ab54ee6ca4ff3 (patch)
tree77fae01082a022a944908cb925b209bd13352392 /dev-python/dbus-python
parentamd64/ppc/ppc64 stable wrt #416725 (diff)
downloadgentoo-2-403abdbcb08a11c6aef6a610e73ab54ee6ca4ff3.tar.gz
gentoo-2-403abdbcb08a11c6aef6a610e73ab54ee6ca4ff3.tar.bz2
gentoo-2-403abdbcb08a11c6aef6a610e73ab54ee6ca4ff3.zip
old
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/dbus-python')
-rw-r--r--dev-python/dbus-python/ChangeLog7
-rw-r--r--dev-python/dbus-python/dbus-python-0.84.0.ebuild84
-rw-r--r--dev-python/dbus-python/dbus-python-1.1.0.ebuild77
-rw-r--r--dev-python/dbus-python/files/dbus-python-0.83.1-workaround-broken-test.patch16
4 files changed, 6 insertions, 178 deletions
diff --git a/dev-python/dbus-python/ChangeLog b/dev-python/dbus-python/ChangeLog
index 4b62a54ac6ac..cea86af90657 100644
--- a/dev-python/dbus-python/ChangeLog
+++ b/dev-python/dbus-python/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/dbus-python
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/ChangeLog,v 1.102 2012/07/21 16:30:33 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/ChangeLog,v 1.103 2012/07/21 16:33:25 ssuominen Exp $
+
+ 21 Jul 2012; Samuli Suominen <ssuominen@gentoo.org>
+ -files/dbus-python-0.83.1-workaround-broken-test.patch,
+ -dbus-python-0.84.0.ebuild, -dbus-python-1.1.0.ebuild:
+ old
21 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> dbus-python-1.1.1.ebuild:
amd64/ppc/ppc64 stable wrt #416725
diff --git a/dev-python/dbus-python/dbus-python-0.84.0.ebuild b/dev-python/dbus-python/dbus-python-0.84.0.ebuild
deleted file mode 100644
index 3d998c3434d2..000000000000
--- a/dev-python/dbus-python/dbus-python-0.84.0.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-0.84.0.ebuild,v 1.13 2012/05/04 15:12:13 patrick Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
-PYTHON_TESTS_RESTRICTED_ABIS="2.4 2.5"
-PYTHON_EXPORT_PHASE_FUNCTIONS="1"
-
-inherit eutils python
-
-DESCRIPTION="Python bindings for the D-Bus messagebus"
-HOMEPAGE="http://www.freedesktop.org/wiki/Software/DBusBindings http://dbus.freedesktop.org/doc/dbus-python/"
-SRC_URI="http://dbus.freedesktop.org/releases/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="doc examples test"
-
-RDEPEND=">=dev-libs/dbus-glib-0.88
- >=sys-apps/dbus-1.4.1"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( =dev-python/epydoc-3* )
- test? ( dev-python/pygobject:2 )"
-
-src_prepare() {
- # Disable compiling of .pyc files.
- mv py-compile py-compile.orig
- ln -s $(type -P true) py-compile
-
- # Workaround testsuite issues
- epatch "${FILESDIR}/${PN}-0.83.1-workaround-broken-test.patch"
-
- # Simple sed to avoid an eautoreconf
- # bug #363679, https://bugs.freedesktop.org/show_bug.cgi?id=43735
- sed -e 's/\(RST2HTMLFLAGS=\)$/\1--input-encoding=UTF-8/' \
- -i configure || die "sed failed"
-
- python_src_prepare
-}
-
-src_configure() {
- configuration() {
- econf \
- --docdir="${EPREFIX}/usr/share/doc/${PF}" \
- $(use_enable doc api-docs)
- }
- python_execute_function -s configuration
-}
-
-src_test() {
- unset DBUS_SESSION_BUS_ADDRESS
- python_src_test
-}
-
-src_install() {
- python_src_install
-
- if use doc; then
- install_documentation() {
- dohtml api/* || return 1
- }
- python_execute_function -f -q -s install_documentation
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}/
- doins -r examples || die
- fi
-
- python_clean_installation_image
-}
-
-pkg_postinst() {
- python_mod_optimize dbus dbus_bindings.py
-}
-
-pkg_postrm() {
- python_mod_cleanup dbus dbus_bindings.py
-}
diff --git a/dev-python/dbus-python/dbus-python-1.1.0.ebuild b/dev-python/dbus-python/dbus-python-1.1.0.ebuild
deleted file mode 100644
index 52f52eea4f06..000000000000
--- a/dev-python/dbus-python/dbus-python-1.1.0.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-1.1.0.ebuild,v 1.2 2012/05/15 21:20:13 ssuominen Exp $
-
-EAPI=4
-
-PYTHON_DEPEND="2:2.6 3:3.2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4 2.5 3.0 3.1 *-jython 2.7-pypy-*"
-PYTHON_EXPORT_PHASE_FUNCTIONS="1"
-
-inherit python
-
-DESCRIPTION="Python bindings for the D-Bus messagebus"
-HOMEPAGE="http://www.freedesktop.org/wiki/Software/DBusBindings http://dbus.freedesktop.org/doc/dbus-python/"
-SRC_URI="http://dbus.freedesktop.org/releases/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="doc examples test"
-
-RDEPEND=">=dev-libs/dbus-glib-0.98
- >=sys-apps/dbus-1.4.20"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( =dev-python/epydoc-3* )
- test? (
- dev-python/pygobject:2
- dev-python/pygobject:3
- )"
-
-src_prepare() {
- >py-compile
- python_src_prepare
-}
-
-src_configure() {
- configuration() {
- econf \
- --docdir="${EPREFIX}"/usr/share/doc/${PF} \
- --disable-html-docs \
- $(use_enable doc api-docs)
- }
- python_execute_function -s configuration
-}
-
-src_test() {
- unset DBUS_SESSION_BUS_ADDRESS
- python_src_test
-}
-
-src_install() {
- python_src_install
-
- if use doc; then
- install_documentation() {
- nonfatal dohtml -r api/*
- }
- python_execute_function -f -q -s install_documentation
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-
- python_clean_installation_image
-}
-
-pkg_postinst() {
- python_mod_optimize dbus
-}
-
-pkg_postrm() {
- python_mod_cleanup dbus
-}
diff --git a/dev-python/dbus-python/files/dbus-python-0.83.1-workaround-broken-test.patch b/dev-python/dbus-python/files/dbus-python-0.83.1-workaround-broken-test.patch
deleted file mode 100644
index c764edbb1165..000000000000
--- a/dev-python/dbus-python/files/dbus-python-0.83.1-workaround-broken-test.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-For some reason this test fails. As it was not working in previous releases either, just disable this one to allow test suite to succeed.
-
- test-client.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/test/test-client.py 2010-03-01 22:56:40.000000000 +0100
-+++ b/test/test-client.py 2010-03-01 22:56:52.000000000 +0100
-@@ -235,7 +235,7 @@
- methods = [
- (self.iface.ReturnOneString, 'SignalOneString', set([0]), set([0])),
- (self.iface.ReturnTwoStrings, 'SignalTwoStrings', set([1, 5]), set([1])),
-- (self.iface.ReturnStruct, 'SignalStruct', set([1, 5]), set([1])),
-+ #(self.iface.ReturnStruct, 'SignalStruct', set([1, 5]), set([1])),
- # all of our test values are sequences so will marshall correctly into an array :P
- (self.iface.ReturnArray, 'SignalArray', set(range(len(values))), set([3, 5, 6])),
- (self.iface.ReturnDict, 'SignalDict', set([0, 3, 4]), set([4]))