summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-11-23 16:26:09 +0000
committerMike Gilbert <floppym@gentoo.org>2014-11-23 16:26:09 +0000
commitc168962e18adddba6d7babe867a1a43effb7e1b1 (patch)
treedc6d4ea6d6b8ba86cee63c40efe2308517e3c0d2 /dev-python/dbus-python
parentfix bug #529866: add dependency on lxqt-base/lxqt-common, thanks to Kris Scott (diff)
downloadgentoo-2-c168962e18adddba6d7babe867a1a43effb7e1b1.tar.gz
gentoo-2-c168962e18adddba6d7babe867a1a43effb7e1b1.tar.bz2
gentoo-2-c168962e18adddba6d7babe867a1a43effb7e1b1.zip
Update py-compile to fix pyc file installation, bug 529502.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/dbus-python')
-rw-r--r--dev-python/dbus-python/ChangeLog5
-rw-r--r--dev-python/dbus-python/dbus-python-1.2.0.ebuild6
2 files changed, 8 insertions, 3 deletions
diff --git a/dev-python/dbus-python/ChangeLog b/dev-python/dbus-python/ChangeLog
index 4ccd9316fd05..48e5cd474a8d 100644
--- a/dev-python/dbus-python/ChangeLog
+++ b/dev-python/dbus-python/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/dbus-python
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/ChangeLog,v 1.140 2014/06/20 16:05:41 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/ChangeLog,v 1.141 2014/11/23 16:26:09 floppym Exp $
+
+ 23 Nov 2014; Mike Gilbert <floppym@gentoo.org> dbus-python-1.2.0.ebuild:
+ Update py-compile to fix pyc file installation, bug 529502.
20 Jun 2014; Ian Delaney <idella4@gentoo.org> dbus-python-1.2.0.ebuild:
add py3.4 support
diff --git a/dev-python/dbus-python/dbus-python-1.2.0.ebuild b/dev-python/dbus-python/dbus-python-1.2.0.ebuild
index e31f631e5cea..3ec8dcdf4bae 100644
--- a/dev-python/dbus-python/dbus-python-1.2.0.ebuild
+++ b/dev-python/dbus-python/dbus-python-1.2.0.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-1.2.0.ebuild,v 1.15 2014/06/20 16:05:41 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-1.2.0.ebuild,v 1.16 2014/11/23 16:26:09 floppym Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
-inherit eutils python-r1
+inherit autotools eutils python-r1
DESCRIPTION="Python bindings for the D-Bus messagebus"
HOMEPAGE="http://www.freedesktop.org/wiki/Software/DBusBindings http://dbus.freedesktop.org/doc/dbus-python/"
@@ -30,6 +30,8 @@ DEPEND="${RDEPEND}
test? ( dev-python/pygobject:3[${PYTHON_USEDEP}] )"
src_prepare() {
+ # Update py-compile, bug 529502.
+ eautoreconf
python_copy_sources
}