summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-08-24 11:46:59 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-08-24 11:46:59 +0000
commitf11f2821ccc0ab664966a3161a2f8c2db2cb219b (patch)
treebba6744face714fa9359a7063a05463197bf5ce6 /dev-python/dbus-python
parentold (diff)
downloadgentoo-2-f11f2821ccc0ab664966a3161a2f8c2db2cb219b.tar.gz
gentoo-2-f11f2821ccc0ab664966a3161a2f8c2db2cb219b.tar.bz2
gentoo-2-f11f2821ccc0ab664966a3161a2f8c2db2cb219b.zip
old
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'dev-python/dbus-python')
-rw-r--r--dev-python/dbus-python/ChangeLog6
-rw-r--r--dev-python/dbus-python/dbus-python-1.1.1-r1.ebuild79
2 files changed, 5 insertions, 80 deletions
diff --git a/dev-python/dbus-python/ChangeLog b/dev-python/dbus-python/ChangeLog
index 1f4f93ded17b..332d11af80e4 100644
--- a/dev-python/dbus-python/ChangeLog
+++ b/dev-python/dbus-python/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/dbus-python
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/ChangeLog,v 1.136 2013/07/04 13:34:03 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/ChangeLog,v 1.137 2013/08/24 11:46:59 ssuominen Exp $
+
+ 24 Aug 2013; Samuli Suominen <ssuominen@gentoo.org>
+ -dbus-python-1.1.1-r1.ebuild:
+ old
04 Jul 2013; Agostino Sarubbo <ago@gentoo.org> dbus-python-1.2.0.ebuild:
Stable for ppc64, wrt bug #453086
diff --git a/dev-python/dbus-python/dbus-python-1.1.1-r1.ebuild b/dev-python/dbus-python/dbus-python-1.1.1-r1.ebuild
deleted file mode 100644
index ce82c2388a72..000000000000
--- a/dev-python/dbus-python/dbus-python-1.1.1-r1.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-1.1.1-r1.ebuild,v 1.16 2013/04/10 19:49:43 ago Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-
-inherit eutils python-r1
-
-DESCRIPTION="Python bindings for the D-Bus messagebus"
-HOMEPAGE="http://www.freedesktop.org/wiki/Software/DBusBindings http://dbus.freedesktop.org/doc/dbus-python/"
-SRC_URI="http://dbus.freedesktop.org/releases/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="doc examples test"
-# API docs generated with epydoc, which is python2-only
-REQUIRED_USE="doc? ( || ( python_targets_python2_6 python_targets_python2_7 ) )"
-
-RDEPEND=">=dev-libs/dbus-glib-0.100:=
- >=sys-apps/dbus-1.6:=
- ${PYTHON_DEPS}"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? (
- dev-python/docutils[python_targets_python2_6?,python_targets_python2_7?]
- =dev-python/epydoc-3*[python_targets_python2_6?,python_targets_python2_7?] )
- test? ( dev-python/pygobject:3[${PYTHON_USEDEP}] )"
-
-src_prepare() {
- python_copy_sources
-}
-
-src_configure() {
- configuring() {
- # epydoc is python2-only, bug #447642
- local apidocs=--disable-api-docs
- [[ ${EPYTHON/.*} = "python2" ]] && apidocs=$(use_enable doc api-docs)
-
- econf \
- --docdir="${EPREFIX}"/usr/share/doc/${PF} \
- --disable-html-docs \
- ${apidocs} \
- PYTHON_LIBS="$(python-config --ldflags)"
- # configure assumes that ${PYTHON}-config executable exists :/
- }
- python_foreach_impl run_in_build_dir configuring
-}
-
-src_compile() {
- python_foreach_impl run_in_build_dir default
-}
-
-src_test() {
- unset DBUS_SESSION_BUS_ADDRESS
- python_foreach_impl run_in_build_dir default
-}
-
-src_install() {
- installing() {
- default
- [[ ${EPYTHON/.*} = "python2" ]] && use doc && dohtml -r api/*
- }
- python_foreach_impl run_in_build_dir installing
- prune_libtool_files --modules
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}
-
-run_in_build_dir() {
- pushd "${BUILD_DIR}" > /dev/null || die
- "$@"
- popd > /dev/null
-}