summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2012-02-23 00:31:47 +0000
committerMarien Zwart <marienz@gentoo.org>2012-02-23 00:31:47 +0000
commitdcb99f52faa1c76adffbec930eea901f7c784029 (patch)
treeab0408300af1a916aa8296f1d24e842e3532b8cc /dev-python/deform
parentcleanup. (diff)
downloadgentoo-2-dcb99f52faa1c76adffbec930eea901f7c784029.tar.gz
gentoo-2-dcb99f52faa1c76adffbec930eea901f7c784029.tar.bz2
gentoo-2-dcb99f52faa1c76adffbec930eea901f7c784029.zip
Version bump, adding Python 3 compatibility.
(Portage version: 2.2.0_alpha88/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/deform')
-rw-r--r--dev-python/deform/ChangeLog7
-rw-r--r--dev-python/deform/deform-0.9.4.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-python/deform/ChangeLog b/dev-python/deform/ChangeLog
index b27e4d4821cf..6d5117649e14 100644
--- a/dev-python/deform/ChangeLog
+++ b/dev-python/deform/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/deform
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/deform/ChangeLog,v 1.2 2012/02/08 02:56:49 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/deform/ChangeLog,v 1.3 2012/02/23 00:31:47 marienz Exp $
+
+*deform-0.9.4 (23 Feb 2012)
+
+ 23 Feb 2012; Marien Zwart <marienz@gentoo.org> +deform-0.9.4.ebuild:
+ Version bump, adding Python 3 compatibility.
*deform-0.9.3 (08 Feb 2012)
diff --git a/dev-python/deform/deform-0.9.4.ebuild b/dev-python/deform/deform-0.9.4.ebuild
new file mode 100644
index 000000000000..74eeb01f0cfa
--- /dev/null
+++ b/dev-python/deform/deform-0.9.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/deform/deform-0.9.4.ebuild,v 1.1 2012/02/23 00:31:45 marienz Exp $
+
+EAPI="3"
+
+SUPPORT_PYTHON_ABIS=1
+PYTHON_DEPEND="2:2.6 3:3.2"
+RESTRICT_PYTHON_ABIS="2.5 3.0 3.1"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils
+
+DESCRIPTION="Another form generation library"
+HOMEPAGE="http://docs.pylonsproject.org/projects/deform/en/latest/ http://pypi.python.org/pypi/deform https://github.com/Pylons/deform"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Depend on peppercorn, translationstring and colander with Python 3 support
+RDEPEND=">=dev-python/translationstring-1.1
+ >=dev-python/colander-0.9.6
+ >=dev-python/peppercorn-0.4
+ >=dev-python/chameleon-1.2.3"
+
+# The tests depend on beautifulsoup4, which is not currently packaged.
+# They will pass because setuptools downloads it from crummy.com
+# during the test phase. This is undesirable, so restrict the tests for now.
+# Revisit this in the future if beautifulsoup4 is packaged.
+DEPEND="${RDEPEND}"
+# test? ( dev-python/beautifulsoup )"
+RESTRICT="test"
+
+# Include COPYRIGHT.txt because the license seems to require it.
+DOCS="CHANGES.txt COPYRIGHT.txt README.txt"
+
+src_install() {
+ distutils_src_install
+
+ # Install only the .rst source, as sphinx processing requires
+ # a theme only available from git that contains hardcoded
+ # references to files on https://static.pylonsproject.org/ (so
+ # the docs would not actually work offline). Install the
+ # source, which is somewhat readable.
+ docinto docs
+ dodoc docs/*.rst
+}