summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohann Schmitz <ercpe@gentoo.org>2014-10-12 08:47:58 +0000
committerJohann Schmitz <ercpe@gentoo.org>2014-10-12 08:47:58 +0000
commitc97c91a6059ecd9963d3ce532e27ad25fa0c075a (patch)
tree3e7f91666383f5175824b14033980c67bfe5c756 /dev-python/django-extensions
parentStable for x86, wrt bug #516674 (diff)
downloadgentoo-2-c97c91a6059ecd9963d3ce532e27ad25fa0c075a.tar.gz
gentoo-2-c97c91a6059ecd9963d3ce532e27ad25fa0c075a.tar.bz2
gentoo-2-c97c91a6059ecd9963d3ce532e27ad25fa0c075a.zip
Version bump of django-extensions
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 77C501ED)
Diffstat (limited to 'dev-python/django-extensions')
-rw-r--r--dev-python/django-extensions/ChangeLog8
-rw-r--r--dev-python/django-extensions/django-extensions-1.4.0.ebuild56
2 files changed, 63 insertions, 1 deletions
diff --git a/dev-python/django-extensions/ChangeLog b/dev-python/django-extensions/ChangeLog
index 02e6a262d739..111082e00fd6 100644
--- a/dev-python/django-extensions/ChangeLog
+++ b/dev-python/django-extensions/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/django-extensions
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-extensions/ChangeLog,v 1.9 2014/06/01 02:06:38 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-extensions/ChangeLog,v 1.10 2014/10/12 08:47:58 ercpe Exp $
+
+*django-extensions-1.4.0 (12 Oct 2014)
+
+ 12 Oct 2014; Johann Schmitz <ercpe@gentoo.org>
+ +django-extensions-1.4.0.ebuild:
+ Version bump of django-extensions
01 Jun 2014; Ian Delaney <idella4@gentoo.org> django-extensions-1.3.3.ebuild,
django-extensions-1.3.7.ebuild:
diff --git a/dev-python/django-extensions/django-extensions-1.4.0.ebuild b/dev-python/django-extensions/django-extensions-1.4.0.ebuild
new file mode 100644
index 000000000000..d79819ed261c
--- /dev/null
+++ b/dev-python/django-extensions/django-extensions-1.4.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-extensions/django-extensions-1.4.0.ebuild,v 1.1 2014/10/12 08:47:58 ercpe Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3} )
+
+inherit distutils-r1
+
+GIT_HASH_TAG="32ffe9b"
+
+DESCRIPTION="Django Command Extensions"
+HOMEPAGE="http://github.com/django-extensions/django-extensions http://code.google.com/p/django-command-extensions/"
+SRC_URI="http://github.com/django-extensions/django-extensions/tarball/${PV}/${P}.tgz"
+
+LICENSE="BSD || ( MIT GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc graphviz mysql postgres s3 sqlite test vcard"
+# Req'd for tests
+DISTUTILS_IN_SOURCE_BUILD=1
+
+PY2_USEDEP=$(python_gen_usedep 'python2*')
+RDEPEND=">=dev-python/django-1.5.4[${PYTHON_USEDEP},mysql?,postgres?,sqlite?]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ graphviz? ( dev-python/pygraphviz[${PY2_USEDEP}] )
+ s3? ( dev-python/boto[${PY2_USEDEP}] )
+ vcard? ( dev-python/vobject[${PY2_USEDEP}] )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( ${RDEPEND}
+ dev-python/shortuuid[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${PN}-${PN}-${GIT_HASH_TAG}"
+
+PY2_REQUSE="|| ( $(python_gen_useflags python2* ) )"
+REQUIRED_USE="
+ graphviz? ( ${PY2_REQUSE} )
+ s3? ( ${PY2_REQUSE} )
+ vcard? ( ${PY2_REQUSE} )"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ "${PYTHON}" run_tests.py || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}