summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-07-08 06:49:45 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-07-08 06:49:45 +0000
commit6dd4c20d037eab32e3f835cf098bbb3cb0edda84 (patch)
tree0119346aaad8d549e6cda71ae2e98c2ef63629e4 /dev-python/django-oauth-plus
parentsys-fs/aufs3: Bump to latest aufs release (diff)
downloadgentoo-2-6dd4c20d037eab32e3f835cf098bbb3cb0edda84.tar.gz
gentoo-2-6dd4c20d037eab32e3f835cf098bbb3cb0edda84.tar.bz2
gentoo-2-6dd4c20d037eab32e3f835cf098bbb3cb0edda84.zip
Bump
(Portage version: 2.2.0_alpha187/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/django-oauth-plus')
-rw-r--r--dev-python/django-oauth-plus/ChangeLog8
-rw-r--r--dev-python/django-oauth-plus/django-oauth-plus-2.1.2.ebuild31
2 files changed, 38 insertions, 1 deletions
diff --git a/dev-python/django-oauth-plus/ChangeLog b/dev-python/django-oauth-plus/ChangeLog
index 0212a6887874..aa9e6956fb4d 100644
--- a/dev-python/django-oauth-plus/ChangeLog
+++ b/dev-python/django-oauth-plus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/django-oauth-plus
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-oauth-plus/ChangeLog,v 1.4 2013/05/31 10:19:19 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-oauth-plus/ChangeLog,v 1.5 2013/07/08 06:49:45 patrick Exp $
+
+*django-oauth-plus-2.1.2 (08 Jul 2013)
+
+ 08 Jul 2013; Patrick Lauer <patrick@gentoo.org>
+ +django-oauth-plus-2.1.2.ebuild:
+ Bump
31 May 2013; Ian Delaney <idella4@gentoo.org>
django-oauth-plus-2.1.0-r1.ebuild:
diff --git a/dev-python/django-oauth-plus/django-oauth-plus-2.1.2.ebuild b/dev-python/django-oauth-plus/django-oauth-plus-2.1.2.ebuild
new file mode 100644
index 000000000000..ec46dad3b94d
--- /dev/null
+++ b/dev-python/django-oauth-plus/django-oauth-plus-2.1.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-oauth-plus/django-oauth-plus-2.1.2.ebuild,v 1.1 2013/07/08 06:49:45 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Support of OAuth 1.0a in Django using python-oauth2"
+HOMEPAGE="http://pypi.python.org/pypi/django-oauth-plus http://code.welldev.org/django-oauth-plus/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/django-1.2.4[${PYTHON_USEDEP}]
+ >=dev-python/oauth2-1.5.170[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_hg[${PYTHON_USEDEP}]"
+
+python_test() {
+ if "${PYTHON}" oauth_provider/runtests/manage.py test; then
+ einfo "Testsuite passed under ${EPYTHON}"
+ else
+ die "Testsuite failed under ${EPYTHON}"
+ fi
+}