summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-05-29 02:47:33 +0000
committerMike Gilbert <floppym@gentoo.org>2013-05-29 02:47:33 +0000
commit6699c5bf75ba7766834e03d695e9343264a20c5a (patch)
tree56443296e240ca863bf9360e00c7766395cfe1a2 /dev-python/django
parentVersion bump and add pcre32 use flag (bug #471608). (diff)
downloadgentoo-2-6699c5bf75ba7766834e03d695e9343264a20c5a.tar.gz
gentoo-2-6699c5bf75ba7766834e03d695e9343264a20c5a.tar.bz2
gentoo-2-6699c5bf75ba7766834e03d695e9343264a20c5a.zip
Add 1.2.7 by special request of hwoarang. Bug 471614.
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/django')
-rw-r--r--dev-python/django/ChangeLog7
-rw-r--r--dev-python/django/django-1.2.7.ebuild83
2 files changed, 89 insertions, 1 deletions
diff --git a/dev-python/django/ChangeLog b/dev-python/django/ChangeLog
index a4246da7b758..55b56eb34d90 100644
--- a/dev-python/django/ChangeLog
+++ b/dev-python/django/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/django
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/ChangeLog,v 1.107 2013/05/27 22:30:12 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django/ChangeLog,v 1.108 2013/05/29 02:47:33 floppym Exp $
+
+*django-1.2.7 (29 May 2013)
+
+ 29 May 2013; Mike Gilbert <floppym@gentoo.org> +django-1.2.7.ebuild:
+ Add 1.2.7 by special request of hwoarang. Bug 471614.
27 May 2013; Ian Delaney <idella4@gentoo.org> +files/django-1.5-objects.patch,
+files/django-1.5-py3tests.patch, -files/django-1.5.1-objects.patch,
diff --git a/dev-python/django/django-1.2.7.ebuild b/dev-python/django/django-1.2.7.ebuild
new file mode 100644
index 000000000000..ff0f45bbf554
--- /dev/null
+++ b/dev-python/django/django-1.2.7.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-1.2.7.ebuild,v 1.1 2013/05/29 02:47:33 floppym Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+PYTHON_REQ_USE='sqlite?'
+
+inherit bash-completion-r1 distutils-r1 versionator webapp
+
+MY_P="Django-${PV}"
+
+DESCRIPTION="High-level Python web framework"
+HOMEPAGE="http://www.djangoproject.com/ http://pypi.python.org/pypi/Django"
+SRC_URI="https://www.djangoproject.com/m/releases/$(get_version_component_range 1-2)/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc mysql postgres sqlite test"
+
+RDEPEND="dev-python/imaging[${PYTHON_USEDEP}]
+ postgres? ( dev-python/psycopg:2[${PYTHON_USEDEP}] )
+ mysql? ( >=dev-python/mysql-python-1.2.3[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-python/sphinx-1.0.7[${PYTHON_USEDEP}] )
+ test? ( ${PYTHON_DEPS//sqlite?/sqlite} )"
+
+S="${WORKDIR}/${MY_P}"
+
+WEBAPP_MANUAL_SLOT="yes"
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html
+ fi
+}
+
+python_test() {
+ # Tests have non-standard assumptions about PYTHONPATH,
+ # and don't work with ${BUILD_DIR}/lib.
+ # https://code.djangoproject.com/ticket/20514
+ PYTHONPATH=. \
+ "${PYTHON}" tests/runtests.py --settings=test_sqlite -v1 \
+ || die "Tests fail with ${EPYTHON}"
+}
+
+src_test() {
+ # Port conflict in django.test.testcases.LiveServerTestCase.
+ # Several other races with temp files.
+ DISTUTILS_NO_PARALLEL_BUILD=1 distutils-r1_src_test
+}
+
+src_install() {
+ distutils-r1_src_install
+ webapp_src_install
+}
+
+python_install_all() {
+ newbashcomp extras/django_bash_completion ${PN}
+
+ if use doc; then
+ rm -fr docs/_build/html/_sources
+ local HTML_DOCS=( docs/_build/html/. )
+ fi
+
+ insinto "${MY_HTDOCSDIR#${EPREFIX}}"
+ doins -r django/contrib/admin/media/.
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ elog "A copy of the admin media is available to"
+ elog "webapp-config for installation in a webroot,"
+ elog "as well as the traditional location in python's"
+ elog "site-packages dir for easy development"
+ elog
+ ewarn "If you build Django ${PV} without USE=\"vhosts\""
+
+ # XXX: call webapp_pkg_postinst? the old ebuild didn't do that...
+ ewarn "webapp-config will automatically install the"
+ ewarn "admin media into the localhost webroot."
+}