summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-23 23:22:06 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-23 23:22:06 +0000
commit67dffd091bea6a0d63fbb5adffa6ab9a739c73dc (patch)
treefed55ce4edf936992d853c7e09f6a7328a4757d6 /dev-python/django
parentVersion bump, bug 359709 (diff)
downloadgentoo-2-67dffd091bea6a0d63fbb5adffa6ab9a739c73dc.tar.gz
gentoo-2-67dffd091bea6a0d63fbb5adffa6ab9a739c73dc.tar.bz2
gentoo-2-67dffd091bea6a0d63fbb5adffa6ab9a739c73dc.zip
Version bump.
(Portage version: 2.2.0_alpha28_p4/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/django')
-rw-r--r--dev-python/django/ChangeLog8
-rw-r--r--dev-python/django/django-1.3.ebuild96
2 files changed, 103 insertions, 1 deletions
diff --git a/dev-python/django/ChangeLog b/dev-python/django/ChangeLog
index 4896065c7330..3937f7653f15 100644
--- a/dev-python/django/ChangeLog
+++ b/dev-python/django/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/django
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/ChangeLog,v 1.66 2011/02/10 20:15:02 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django/ChangeLog,v 1.67 2011/03/23 23:22:06 arfrever Exp $
+
+*django-1.3 (23 Mar 2011)
+
+ 23 Mar 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +django-1.3.ebuild:
+ Version bump.
10 Feb 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
-django-1.2.4-r1.ebuild, -files/django-1.2.4-python-2.7.patch,
diff --git a/dev-python/django/django-1.3.ebuild b/dev-python/django/django-1.3.ebuild
new file mode 100644
index 000000000000..0e5ebaece9a4
--- /dev/null
+++ b/dev-python/django/django-1.3.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-1.3.ebuild,v 1.1 2011/03/23 23:22:06 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit bash-completion distutils versionator webapp
+
+MY_P="Django-${PV}"
+
+DESCRIPTION="High-level Python web framework"
+HOMEPAGE="http://www.djangoproject.com/ http://pypi.python.org/pypi/Django"
+SRC_URI="http://media.djangoproject.com/releases/$(get_version_component_range 1-2)/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc mysql postgres sqlite test"
+
+RDEPEND="dev-python/imaging
+ sqlite? ( || ( dev-lang/python:2.7[sqlite] dev-lang/python:2.6[sqlite] dev-lang/python:2.5[sqlite] dev-python/pysqlite:2 ) )
+ postgres? ( dev-python/psycopg )
+ mysql? ( >=dev-python/mysql-python-1.2.1_p2 )"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-python/sphinx-0.3 )
+ test? ( || ( dev-lang/python:2.7[sqlite] dev-lang/python:2.6[sqlite] dev-lang/python:2.5[sqlite] dev-python/pysqlite:2 ) )"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="docs/* AUTHORS"
+WEBAPP_MANUAL_SLOT="yes"
+
+pkg_setup() {
+ python_pkg_setup
+ webapp_pkg_setup
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ pushd docs > /dev/null
+ emake html || die "Generation of documentation failed"
+ popd > /dev/null
+ fi
+}
+
+src_test() {
+ testing() {
+ # Tests have non-standard assumptions about PYTHONPATH and
+ # don't work with usual "build-${PYTHON_ABI}/lib".
+ PYTHONPATH="." "$(PYTHON)" tests/runtests.py --settings=test_sqlite -v1
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ dobashcompletion extras/django_bash_completion
+
+ if use doc; then
+ rm -fr docs/_build/html/_sources
+ dohtml -A txt -r docs/_build/html/* || die "dohtml failed"
+ fi
+
+ insinto "${MY_HTDOCSDIR#${EPREFIX}}"
+ doins -r django/contrib/admin/media/* || die "doins failed"
+
+ webapp_src_install
+}
+
+pkg_preinst() {
+ :
+}
+
+pkg_postinst() {
+ bash-completion_pkg_postinst
+ distutils_pkg_postinst
+
+ einfo "Now, Django has the best of both worlds with Gentoo,"
+ einfo "ease of deployment for production and development."
+ echo
+ elog "A copy of the admin media is available to"
+ elog "webapp-config for installation in a webroot,"
+ elog "as well as the traditional location in python's"
+ elog "site-packages dir for easy development"
+ echo
+ ewarn "If you build Django ${PV} without USE=\"vhosts\""
+ ewarn "webapp-config will automatically install the"
+ ewarn "admin media into the localhost webroot."
+}