summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2015-04-05 00:42:29 +0000
committerAlex Brandt <alunduil@gentoo.org>2015-04-05 00:42:29 +0000
commit3dd259044747eedf651d7ed48a1e70aa20cc401c (patch)
tree3f4d669daa9b488d263a05751de809627770973f /dev-python/docker-py
parentMark s390/sh stable. (diff)
downloadgentoo-2-3dd259044747eedf651d7ed48a1e70aa20cc401c.tar.gz
gentoo-2-3dd259044747eedf651d7ed48a1e70aa20cc401c.tar.bz2
gentoo-2-3dd259044747eedf651d7ed48a1e70aa20cc401c.zip
use github tarball that includes docs
The 1.1.0 release of docker-py does not include the documentation. Thus, we use the github tarball until the documentation is included in the pypi release. (Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 11A8217C!)
Diffstat (limited to 'dev-python/docker-py')
-rw-r--r--dev-python/docker-py/ChangeLog9
-rw-r--r--dev-python/docker-py/docker-py-1.1.0-r1.ebuild48
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-python/docker-py/ChangeLog b/dev-python/docker-py/ChangeLog
index 876572c28ada..1a9cb5d391af 100644
--- a/dev-python/docker-py/ChangeLog
+++ b/dev-python/docker-py/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/docker-py
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/docker-py/ChangeLog,v 1.18 2015/03/13 22:31:49 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/docker-py/ChangeLog,v 1.19 2015/04/05 00:42:29 alunduil Exp $
+
+*docker-py-1.1.0-r1 (05 Apr 2015)
+
+ 05 Apr 2015; Alex Brandt <alunduil@gentoo.org> +docker-py-1.1.0-r1.ebuild:
+ use github tarball that includes docs The 1.1.0 release of docker-py does not
+ include the documentation. Thus, we use the github tarball until the
+ documentation is included in the pypi release.
*docker-py-1.1.0 (13 Mar 2015)
diff --git a/dev-python/docker-py/docker-py-1.1.0-r1.ebuild b/dev-python/docker-py/docker-py-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..4b8cda86a2de
--- /dev/null
+++ b/dev-python/docker-py/docker-py-1.1.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/docker-py/docker-py-1.1.0-r1.ebuild,v 1.1 2015/04/05 00:42:29 alunduil Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Python client for Docker."
+HOMEPAGE="https://github.com/docker/docker-py"
+SRC_URI="https://github.com/docker/${PN}/archive/${PV}.tar.gz -> ${P}-r1.tar.gz"
+
+S="${S}-r1"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( >=dev-python/mkdocs-0.9[${PYTHON_USEDEP}] )
+ test? (
+ >=dev-python/coverage-3.7.1
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ =dev-python/requests-2.5*[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.5.3[${PYTHON_USEDEP}]
+ >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/websocket-client-0.11.0[${PYTHON_USEDEP}]' python2_7)
+"
+
+python_compile_all() {
+ use doc && mkdocs build || die "docs failed to build"
+}
+
+python_test() {
+ "${PYTHON}" tests/test.py || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( site/. )
+
+ distutils-r1_python_install_all
+}