summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-12 00:33:22 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-12 00:33:22 +0000
commit510c16f091a755f663296ba54c1bcf0f195917f2 (patch)
treec386e7ec38b2697425ad370775ccbe8dda18d310 /dev-python/dulwich
parentversion bump (diff)
downloadgentoo-2-510c16f091a755f663296ba54c1bcf0f195917f2.tar.gz
gentoo-2-510c16f091a755f663296ba54c1bcf0f195917f2.tar.bz2
gentoo-2-510c16f091a755f663296ba54c1bcf0f195917f2.zip
Version bump.
(Portage version: 2.2.0_alpha23_p1/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/dulwich')
-rw-r--r--dev-python/dulwich/ChangeLog10
-rw-r--r--dev-python/dulwich/dulwich-0.7.0.ebuild40
2 files changed, 48 insertions, 2 deletions
diff --git a/dev-python/dulwich/ChangeLog b/dev-python/dulwich/ChangeLog
index a8c606039f91..8d13a619e54e 100644
--- a/dev-python/dulwich/ChangeLog
+++ b/dev-python/dulwich/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/dulwich
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/ChangeLog,v 1.21 2010/11/28 02:04:24 arfrever Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/ChangeLog,v 1.22 2011/02/12 00:33:22 arfrever Exp $
+
+*dulwich-0.7.0 (12 Feb 2011)
+
+ 12 Feb 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +dulwich-0.7.0.ebuild:
+ Version bump.
28 Nov 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
-dulwich-0.6.1.ebuild:
diff --git a/dev-python/dulwich/dulwich-0.7.0.ebuild b/dev-python/dulwich/dulwich-0.7.0.ebuild
new file mode 100644
index 000000000000..cafa5b050001
--- /dev/null
+++ b/dev-python/dulwich/dulwich-0.7.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/dulwich-0.7.0.ebuild,v 1.1 2011/02/12 00:33:22 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+DESCRIPTION="Dulwich is a pure-Python implementation of the Git file formats and protocols."
+HOMEPAGE="http://samba.org/~jelmer/dulwich/ http://pypi.python.org/pypi/dulwich"
+SRC_URI="http://samba.org/~jelmer/dulwich/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc-macos ~x86-solaris"
+IUSE=""
+
+DEPEND="dev-python/setuptools"
+RDEPEND=""
+
+src_prepare() {
+ distutils_src_prepare
+
+ sed -e "s/from dulwich.utils import/from dulwich.tests.compat.utils import/" -i dulwich/tests/compat/test_web.py
+ sed -e "/test_merge_entries =/,+1d" -i dulwich/tests/test_diff_tree.py
+ sed -e "s/test_fetch_from_dulwich(/_&/" -i dulwich/tests/compat/server_utils.py
+}
+
+src_install() {
+ distutils_src_install
+
+ delete_tests() {
+ rm -fr "${ED}$(python_get_sitedir)/dulwich/tests"
+ }
+ python_execute_function -q delete_tests
+}