summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-05-14 13:57:22 +0000
committerIan Delaney <idella4@gentoo.org>2013-05-14 13:57:22 +0000
commit5415c8c43bb44651d96898d85ccdeee686352018 (patch)
tree1ec06a7c3bbd5d786d4f281c96a5ed5e12f241e8 /dev-python/enable
parentStable for HPPA (bug #469680). (diff)
downloadgentoo-2-5415c8c43bb44651d96898d85ccdeee686352018.tar.gz
gentoo-2-5415c8c43bb44651d96898d85ccdeee686352018.tar.bz2
gentoo-2-5415c8c43bb44651d96898d85ccdeee686352018.zip
bump, re-make of enable-4-rogue-tests.patch for new version, drop old
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/enable')
-rw-r--r--dev-python/enable/ChangeLog10
-rw-r--r--dev-python/enable/enable-3.4.0.ebuild91
-rw-r--r--dev-python/enable/enable-3.4.1.ebuild88
-rw-r--r--dev-python/enable/enable-4.0.0.ebuild70
-rw-r--r--dev-python/enable/enable-4.1.0.ebuild71
-rw-r--r--dev-python/enable/enable-4.2.0.ebuild72
-rw-r--r--dev-python/enable/enable-4.3.0.ebuild (renamed from dev-python/enable/enable-4.2.0-r1.ebuild)11
-rw-r--r--dev-python/enable/files/enable-4-rogue-tests.patch64
8 files changed, 41 insertions, 436 deletions
diff --git a/dev-python/enable/ChangeLog b/dev-python/enable/ChangeLog
index a8c1cc65b448..34a5b24f20d2 100644
--- a/dev-python/enable/ChangeLog
+++ b/dev-python/enable/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/enable
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/enable/ChangeLog,v 1.23 2013/04/15 19:31:48 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/enable/ChangeLog,v 1.24 2013/05/14 13:57:21 idella4 Exp $
+
+*enable-4.3.0 (14 May 2013)
+
+ 14 May 2013; Ian Delaney <idella4@gentoo.org> +enable-4.3.0.ebuild,
+ -enable-3.4.0.ebuild, -enable-3.4.1.ebuild, -enable-4.0.0.ebuild,
+ -enable-4.1.0.ebuild, -enable-4.2.0-r1.ebuild, -enable-4.2.0.ebuild,
+ files/enable-4-rogue-tests.patch:
+ bump, re-make of enable-4-rogue-tests.patch for new version, drop old
15 Apr 2013; Ian Delaney <idella4@gentoo.org> enable-4.2.0-r1.ebuild:
minor corrections/tidyup
diff --git a/dev-python/enable/enable-3.4.0.ebuild b/dev-python/enable/enable-3.4.0.ebuild
deleted file mode 100644
index fa51659f7e2c..000000000000
--- a/dev-python/enable/enable-3.4.0.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/enable/enable-3.4.0.ebuild,v 1.4 2012/02/24 09:37:06 patrick Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
-DISTUTILS_SRC_TEST="setup.py"
-
-inherit distutils eutils virtualx
-
-MY_PN="Enable"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Enthought Tool Suite: Drawing and interaction packages"
-HOMEPAGE="http://code.enthought.com/projects/enable/ http://pypi.python.org/pypi/Enable"
-SRC_URI="http://www.enthought.com/repo/ETS/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples test"
-
-RDEPEND=">=dev-python/enthoughtbase-3.1.0
- dev-python/numpy
- dev-python/reportlab
- dev-python/setuptools
- >=dev-python/traitsgui-3.6.0[wxwidgets]
- >=media-libs/freetype-2
- virtual/opengl
- x11-libs/libX11"
-DEPEND="${RDEPEND}
- dev-lang/swig
- dev-python/cython
- doc? ( dev-python/sphinx )
- test? (
- dev-python/coverage
- dev-python/nose
- media-fonts/font-cursor-misc
- media-fonts/font-misc-misc
- x11-apps/xhost
- )"
-
-S="${WORKDIR}/${MY_P}"
-
-PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
-
-DOCS="docs/*.txt"
-PYTHON_MODNAME="enthought"
-
-src_prepare() {
- distutils_src_prepare
-
- # "${S}/enthought/enable2/tests" does not exist.
- sed -e "s:,enthought/enable2/tests::" -i setup.cfg || die "sed setup.cfg failed"
-
- epatch "${FILESDIR}/${PN}-3.3.0-nofreetype.patch"
-}
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- pushd docs > /dev/null
- emake html || die "Generation of documentation failed"
- popd > /dev/null
- fi
-}
-
-src_test() {
- VIRTUALX_COMMAND="distutils_src_test" virtualmake
-}
-
-src_install() {
- find -name "*LICENSE.txt" -delete
- distutils_src_install
-
- if use doc; then
- pushd docs/build/html > /dev/null
- insinto /usr/share/doc/${PF}/html
- doins -r [a-z]* _static || die "Installation of documentation failed"
- popd > /dev/null
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r examples/* || die "Installation of examples failed"
- fi
-}
diff --git a/dev-python/enable/enable-3.4.1.ebuild b/dev-python/enable/enable-3.4.1.ebuild
deleted file mode 100644
index 03e8d993b898..000000000000
--- a/dev-python/enable/enable-3.4.1.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/enable/enable-3.4.1.ebuild,v 1.2 2012/02/24 09:37:06 patrick Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
-DISTUTILS_SRC_TEST="setup.py"
-
-inherit distutils eutils virtualx
-
-MY_PN="Enable"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Enthought Tool Suite: Drawing and interaction packages"
-HOMEPAGE="http://code.enthought.com/projects/enable/ http://pypi.python.org/pypi/Enable"
-SRC_URI="http://www.enthought.com/repo/ETS/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples test"
-
-RDEPEND=">=dev-python/enthoughtbase-3.1.0
- dev-python/numpy
- dev-python/reportlab
- dev-python/setuptools
- >=dev-python/traitsgui-3.6.0[wxwidgets]
- >=media-libs/freetype-2
- virtual/opengl
- x11-libs/libX11"
-DEPEND="${RDEPEND}
- dev-lang/swig
- dev-python/cython
- doc? ( dev-python/sphinx )
- test? (
- dev-python/coverage
- dev-python/nose
- media-fonts/font-cursor-misc
- media-fonts/font-misc-misc
- x11-apps/xhost
- )"
-
-S="${WORKDIR}/${MY_P}"
-
-PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
-
-DOCS="docs/*.txt"
-PYTHON_MODNAME="enthought"
-
-src_prepare() {
- distutils_src_prepare
-
- epatch "${FILESDIR}/${PN}-3.3.0-nofreetype.patch"
-}
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- pushd docs > /dev/null
- emake html || die "Generation of documentation failed"
- popd > /dev/null
- fi
-}
-
-src_test() {
- VIRTUALX_COMMAND="distutils_src_test" virtualmake
-}
-
-src_install() {
- find -name "*LICENSE.txt" -delete
- distutils_src_install
-
- if use doc; then
- pushd docs/build/html > /dev/null
- insinto /usr/share/doc/${PF}/html
- doins -r [a-z]* _static || die "Installation of documentation failed"
- popd > /dev/null
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r examples/* || die "Installation of examples failed"
- fi
-}
diff --git a/dev-python/enable/enable-4.0.0.ebuild b/dev-python/enable/enable-4.0.0.ebuild
deleted file mode 100644
index 3d934676c732..000000000000
--- a/dev-python/enable/enable-4.0.0.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/enable/enable-4.0.0.ebuild,v 1.4 2012/02/24 09:37:06 patrick Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
-DISTUTILS_SRC_TEST="nosetests"
-
-inherit distutils eutils virtualx
-
-DESCRIPTION="Enthought Tool Suite: drawing and interaction packages"
-HOMEPAGE="http://code.enthought.com/projects/enable/ http://pypi.python.org/pypi/enable"
-SRC_URI="http://www.enthought.com/repo/ets/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples test"
-
-RDEPEND="dev-python/numpy
- dev-python/reportlab
- >=dev-python/traitsui-4.0
- >=media-libs/freetype-2
- virtual/opengl
- x11-libs/libX11"
-DEPEND="dev-python/setuptools
- dev-lang/swig
- dev-python/cython
- doc? ( dev-python/sphinx )
- test? (
- ${RDEPEND}
- media-fonts/font-cursor-misc
- media-fonts/font-misc-misc
- )"
-
-DOCS="docs/*.txt"
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- pushd docs > /dev/null
- emake html || die "Generation of documentation failed"
- popd > /dev/null
- fi
-}
-
-src_test() {
- VIRTUALX_COMMAND="distutils_src_test" virtualmake
-}
-
-src_install() {
- find -name "*LICENSE*.txt" -delete
- distutils_src_install
-
- if use doc; then
- pushd docs/build/html > /dev/null
- insinto /usr/share/doc/${PF}/html
- doins -r [a-z]* _static || die "Installation of documentation failed"
- popd > /dev/null
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r examples/* || die "Installation of examples failed"
- fi
-}
diff --git a/dev-python/enable/enable-4.1.0.ebuild b/dev-python/enable/enable-4.1.0.ebuild
deleted file mode 100644
index 5e7be4697777..000000000000
--- a/dev-python/enable/enable-4.1.0.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/enable/enable-4.1.0.ebuild,v 1.5 2012/11/29 16:30:12 mr_bones_ Exp $
-
-EAPI=4
-PYTHON_DEPEND="2:2.6"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
-PYTHON_TESTS_RESTRICTED_ABIS="2.6"
-DISTUTILS_SRC_TEST="nosetests"
-
-inherit distutils eutils virtualx
-
-DESCRIPTION="Enthought Tool Suite: Drawing and interaction packages"
-HOMEPAGE="http://code.enthought.com/projects/enable/ http://pypi.python.org/pypi/enable"
-SRC_URI="http://www.enthought.com/repo/ets/${P}.tar.gz
- http://dev.gentoo.org/~idella4/${PN}-4-TestsPaths.patch"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples test"
-
-RDEPEND="dev-python/numpy
- dev-python/reportlab
- >=dev-python/traitsui-4
- >=media-libs/freetype-2
- virtual/opengl
- x11-libs/libX11"
-DEPEND="dev-python/setuptools
- dev-lang/swig
- dev-python/cython
- doc? ( dev-python/sphinx )
- test? (
- ${RDEPEND}
- media-fonts/font-cursor-misc
- media-fonts/font-misc-misc
- )"
-
-DOCS="docs/*.txt"
-
-src_prepare() {
- distutils_src_prepare
-
- # Remove check for Darwin systems, set py.test style xfails,
- # Re-set import paths in tests, 'enabling' enable to find its own in source modules!!?!
- epatch "${DISTDIR}"/${PN}-4-TestsPaths.patch \
- "${FILESDIR}"/${PN}-4-rogue-tests.patch
-}
-
-src_compile() {
- distutils_src_compile
- use doc && emake -C docs html
-}
-
-src_test() {
- # Hardcoding build-2.7, 2.7 being the only fully capable candidate
- VIRTUALX_COMMAND="python_execute_nosetests -P $(ls -d build-2.7/lib.linux-*/):." virtualmake
-}
-
-src_install() {
- find -name "*LICENSE*.txt" -delete
- distutils_src_install
-
- use doc && dohtml -r docs/build/html/*
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}
diff --git a/dev-python/enable/enable-4.2.0.ebuild b/dev-python/enable/enable-4.2.0.ebuild
deleted file mode 100644
index b46cc0a09e21..000000000000
--- a/dev-python/enable/enable-4.2.0.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/enable/enable-4.2.0.ebuild,v 1.5 2013/04/03 08:59:47 patrick Exp $
-
-EAPI=4
-PYTHON_DEPEND="2:2.6"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
-PYTHON_TESTS_RESTRICTED_ABIS="2.6"
-DISTUTILS_SRC_TEST="nosetests"
-
-inherit distutils eutils virtualx
-
-DESCRIPTION="Enthought Tool Suite: Drawing and interaction packages"
-HOMEPAGE="http://code.enthought.com/projects/enable/ http://pypi.python.org/pypi/enable"
-SRC_URI="http://www.enthought.com/repo/ets/${P}.tar.gz
- http://dev.gentoo.org/~idella4/${PN}-4-TestsPaths.patch"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples test"
-
-RDEPEND="dev-python/numpy
- dev-python/reportlab
- >=dev-python/traitsui-4
- >=media-libs/freetype-2
- virtual/opengl
- virtual/glu
- x11-libs/libX11"
-DEPEND="${RDEPEND}
- dev-python/setuptools
- dev-lang/swig
- dev-python/cython
- doc? ( dev-python/sphinx )
- test? (
- media-fonts/font-cursor-misc
- media-fonts/font-misc-misc
- )"
-
-DOCS="docs/*.txt"
-
-src_prepare() {
- distutils_src_prepare
-
- # Remove check for Darwin systems, set py.test style xfails,
- # Re-set import paths in tests, 'enabling' enable to find its own in source modules!!?!
- epatch "${DISTDIR}"/${PN}-4-TestsPaths.patch \
- "${FILESDIR}"/${PN}-4-rogue-tests.patch
-}
-
-src_compile() {
- distutils_src_compile
- use doc && emake -C docs html
-}
-
-src_test() {
- # Hardcoding build-2.7, 2.7 being the only fully capable candidate
- VIRTUALX_COMMAND="python_execute_nosetests -P $(ls -d build-2.7/lib.linux-*/):." virtualmake
-}
-
-src_install() {
- find -name "*LICENSE*.txt" -delete
- distutils_src_install
-
- use doc && dohtml -r docs/build/html/*
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}
diff --git a/dev-python/enable/enable-4.2.0-r1.ebuild b/dev-python/enable/enable-4.3.0.ebuild
index 22c7c2337edc..8e2e1003cbdf 100644
--- a/dev-python/enable/enable-4.2.0-r1.ebuild
+++ b/dev-python/enable/enable-4.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/enable/enable-4.2.0-r1.ebuild,v 1.2 2013/04/15 19:31:48 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/enable/enable-4.3.0.ebuild,v 1.1 2013/05/14 13:57:21 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -51,13 +51,8 @@ python_test() {
}
python_install_all() {
- find -name "*LICENSE*.txt" -delete
- distutils-r1_python_install_all
-
use doc && dohtml -r docs/build/html/*
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
}
diff --git a/dev-python/enable/files/enable-4-rogue-tests.patch b/dev-python/enable/files/enable-4-rogue-tests.patch
index 02e5474972df..f08f7b00ce36 100644
--- a/dev-python/enable/files/enable-4-rogue-tests.patch
+++ b/dev-python/enable/files/enable-4-rogue-tests.patch
@@ -1,53 +1,47 @@
-tests skipped that; access the network, are expected fails, target Darwin system.
-diff -ur enable-4.2.0.orig/enable/savage/svg/tests/test_document.py enable-4.2.0/enable/savage/svg/tests/test_document.py
---- enable/savage/svg/tests/test_document.py 2011-12-22 07:11:25.000000000 +0800
-+++ enable/savage/svg/tests/test_document.py 2012-11-29 10:01:51.449181783 +0800
-@@ -61,6 +61,8 @@
- self.document.getBrushFromState().color[-1],
+diff -ur enable-4.3.0.orig/enable/savage/svg/tests/test_document.py enable-4.3.0/enable/savage/svg/tests/test_document.py
+--- enable/savage/svg/tests/test_document.py 2013-03-28 21:58:28.000000000 +0800
++++ enable/savage/svg/tests/test_document.py 2013-05-14 21:23:18.641569707 +0800
+@@ -63,6 +63,7 @@
0
)
-+
+
+ @unittest.skip("This tests accesses the internet")
def testURLFallback(self):
self.document.state["fill"] = "url(http://google.com) red"
self.assertEqual(
-@@ -73,6 +75,7 @@
- def testDefault(self):
- got = document.valueToPixels("12")
- self.assertEqual(got, 12)
-+ @unittest.expectedFailure
- def testPointConversion(self):
- got = document.valueToPixels('14pt')
- self.assertEqual(got, 22)
-diff -ur enable-4.2.0.orig/enable/tests/kiva_graphics_context_test_case.py enable-4.2.0/enable/tests/kiva_graphics_context_test_case.py
---- enable/tests/kiva_graphics_context_test_case.py 2011-12-22 07:11:25.000000000 +0800
-+++ enable/tests/kiva_graphics_context_test_case.py 2012-11-29 13:22:15.262079475 +0800
-@@ -7,7 +7,7 @@
+diff -ur enable-4.3.0.orig/enable/tests/kiva_graphics_context_test_case.py enable-4.3.0/enable/tests/kiva_graphics_context_test_case.py
+--- enable/tests/kiva_graphics_context_test_case.py 2013-03-28 21:58:28.000000000 +0800
++++ enable/tests/kiva_graphics_context_test_case.py 2013-05-14 21:24:53.897573114 +0800
+@@ -1,4 +1,3 @@
+-
+ import numpy as np
+ import unittest
+@@ -8,6 +7,7 @@
class TestGCErrors(unittest.TestCase):
"""Test some cases where a ValueError should be raised."""
--
-+ @unittest.expectedFailure
+
++ @unittest.expectedFailure
def test_bad_image_size(self):
arr = np.array([[1, 2], [3, 4]], dtype=np.uint8)
gc = GraphicsContext((50, 50))
-diff -ur enable-4.2.0.orig/kiva/quartz/__init__.py enable-4.2.0/kiva/quartz/__init__.py
---- kiva/quartz/__init__.py 2011-12-22 07:11:26.000000000 +0800
-+++ kiva/quartz/__init__.py 2012-11-29 15:23:35.641412031 +0800
-@@ -2,10 +2,10 @@
+diff -ur enable-4.3.0.orig/kiva/quartz/__init__.py enable-4.3.0/kiva/quartz/__init__.py
+--- kiva/quartz/__init__.py 2013-03-28 21:58:28.000000000 +0800
++++ kiva/quartz/__init__.py 2013-05-14 21:32:10.473588730 +0800
+@@ -2,16 +2,3 @@
# :Copyright: 2004, Enthought, Inc.
# :License: BSD Style
--from macport import get_macport as _get_macport
-+#from macport import get_macport as _get_macport
-
+-from mac_context import get_mac_context
+-
+-
-def get_macport(dc):
- """
-- Returns the m_macPort of a wxDC (or child class) instance.
+- Returns the Port or the CGContext of a wxDC (or child class) instance.
- """
-- return _get_macport(str(dc.this))
-+#def get_macport(dc):
-+ #"""
-+ #Returns the m_macPort of a wxDC (or child class) instance.
-+ #"""
-+ #return _get_macport(str(dc.this))
+- if 'GetCGContext' in dir(dc):
+- ptr = dc.GetCGContext()
+- return int(ptr)
+- else:
+- from macport import get_macport as _get_macport
+- return _get_macport(str(dc.this))