summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-05-06 05:25:21 +0000
committerIan Delaney <idella4@gentoo.org>2014-05-06 05:25:21 +0000
commitb48d6ef457b10d7bec6b2d8d405768081eda4603 (patch)
tree2f15987e60086411907578722116a917979284a2 /dev-python/flask
parentVersion bump. (diff)
downloadgentoo-2-b48d6ef457b10d7bec6b2d8d405768081eda4603.tar.gz
gentoo-2-b48d6ef457b10d7bec6b2d8d405768081eda4603.tar.bz2
gentoo-2-b48d6ef457b10d7bec6b2d8d405768081eda4603.zip
drop py2.6 add pypy support upgrade ebuild accordingly
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/flask')
-rw-r--r--dev-python/flask/ChangeLog5
-rw-r--r--dev-python/flask/flask-0.10.1-r1.ebuild25
2 files changed, 26 insertions, 4 deletions
diff --git a/dev-python/flask/ChangeLog b/dev-python/flask/ChangeLog
index 09e427febe4f..2fc0bafcdc44 100644
--- a/dev-python/flask/ChangeLog
+++ b/dev-python/flask/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/flask
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask/ChangeLog,v 1.29 2014/02/13 20:42:13 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask/ChangeLog,v 1.30 2014/05/06 05:25:21 idella4 Exp $
+
+ 06 May 2014; Ian Delaney <idella4@gentoo.org> flask-0.10.1-r1.ebuild:
+ drop py2.6 add pypy support upgrade ebuild accordingly
13 Feb 2014; Sébastien Fabbro <bicatali@gentoo.org> flask-0.10.1-r1.ebuild:
after better testing, remove python-3.2 support
diff --git a/dev-python/flask/flask-0.10.1-r1.ebuild b/dev-python/flask/flask-0.10.1-r1.ebuild
index ed1954e907e3..f741dda8fdea 100644
--- a/dev-python/flask/flask-0.10.1-r1.ebuild
+++ b/dev-python/flask/flask-0.10.1-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask/flask-0.10.1-r1.ebuild,v 1.4 2014/02/13 20:42:13 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask/flask-0.10.1-r1.ebuild,v 1.5 2014/05/06 05:25:21 idella4 Exp $
EAPI="5"
-PYTHON_COMPAT=( python{2_6,2_7,3_3} )
+PYTHON_COMPAT=( python{2_7,3_3} pypy )
inherit distutils-r1
@@ -24,13 +24,32 @@ RDEPEND="dev-python/blinker[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/werkzeug-0.7[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}"
+# Usual; test phase
+DISTUTILS_IN_SOURCE_BUILD=1
S="${WORKDIR}/${MY_P}"
PATCHES=( "${FILESDIR}"/${P}-is_package.patch )
-python_test() {
+python_prepare_all() {
# https://github.com/mitsuhiko/flask/issues/837
+ sed -e s':test_uninstalled_package_paths:_&:' \
+ -i flask/testsuite/config.py || die
+ sed -e s':test_json_key_sorting:_&:' \
+ -i flask/testsuite/helpers.py || die
+ sed -e s':test_appcontext_signals:_&:' \
+ -i flask/testsuite/signals.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # https://github.com/mitsuhiko/flask/issues/837, 1047
+ if [[ "${EPYTHON}" == pypy ]]; then
+ sed -e s':test_build_error_handler:_&:' \
+ -i flask/testsuite/basic.py || die
+ sed -e s':test_session_transactions_no_null_sessions:_&:' \
+ -i flask/testsuite/testing.py || die
+ fi
"${PYTHON}" run-tests.py || die "Testing failed with ${EPYTHON}"
}