summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-01-27 22:05:31 +0000
committerMike Frysinger <vapier@gentoo.org>2015-01-27 22:05:31 +0000
commitff934dfbbe6b96980a18cbd6da9053636395f14a (patch)
treeac16a5878cfe85b34102fce1d05d4317a18076c6 /dev-python/gcs-oauth2-boto-plugin
parentVersion bump. (diff)
downloadgentoo-2-ff934dfbbe6b96980a18cbd6da9053636395f14a.tar.gz
gentoo-2-ff934dfbbe6b96980a18cbd6da9053636395f14a.tar.bz2
gentoo-2-ff934dfbbe6b96980a18cbd6da9053636395f14a.zip
Fix RDEPEND for binary packages.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'dev-python/gcs-oauth2-boto-plugin')
-rw-r--r--dev-python/gcs-oauth2-boto-plugin/ChangeLog10
-rw-r--r--dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-1.8-r1.ebuild32
2 files changed, 40 insertions, 2 deletions
diff --git a/dev-python/gcs-oauth2-boto-plugin/ChangeLog b/dev-python/gcs-oauth2-boto-plugin/ChangeLog
index 91285030346a..e00659b1e69b 100644
--- a/dev-python/gcs-oauth2-boto-plugin/ChangeLog
+++ b/dev-python/gcs-oauth2-boto-plugin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/gcs-oauth2-boto-plugin
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gcs-oauth2-boto-plugin/ChangeLog,v 1.3 2014/10/27 02:53:09 patrick Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gcs-oauth2-boto-plugin/ChangeLog,v 1.4 2015/01/27 22:05:31 vapier Exp $
+
+*gcs-oauth2-boto-plugin-1.8-r1 (27 Jan 2015)
+
+ 27 Jan 2015; Mike Frysinger <vapier@gentoo.org>
+ +gcs-oauth2-boto-plugin-1.8-r1.ebuild:
+ Fix RDEPEND for binary packages.
27 Oct 2014; Patrick Lauer <patrick@gentoo.org>
gcs-oauth2-boto-plugin-1.7.ebuild, gcs-oauth2-boto-plugin-1.8.ebuild:
diff --git a/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-1.8-r1.ebuild b/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-1.8-r1.ebuild
new file mode 100644
index 000000000000..252d8c40f7ff
--- /dev/null
+++ b/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-1.8-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-1.8-r1.ebuild,v 1.1 2015/01/27 22:05:31 vapier Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="OAuth 2.0 plugin for Google Cloud Storage credentials in the Boto library"
+HOMEPAGE="https://pypi.python.org/pypi/gcs-oauth2-boto-plugin"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}/${P}-use-friendy-version-checks.patch"
+)
+
+# Keep versions in sync with setup.py.
+DEPEND="${PYTHON_DEPS}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${PYTHON_DEPS}
+ >=dev-python/boto-2.29.1[${PYTHON_USEDEP}]
+ >=dev-python/httplib2-0.8[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
+ >=dev-python/google-api-python-client-1.1[${PYTHON_USEDEP}]
+ >=dev-python/retry-decorator-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/socksipy-1.01[${PYTHON_USEDEP}]"