summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-06-21 20:56:54 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-06-21 20:56:54 +0000
commit64e46585b98fc4628f61edde3dd7c5543825ab2a (patch)
treef034267f1934e56121339aa3084368bd599b2844 /dev-python/git-python
parentInitial commit of couchdb-python-0.5. Ebuild by Juergen Geuter. Fixes #273719 (diff)
downloadgentoo-2-64e46585b98fc4628f61edde3dd7c5543825ab2a.tar.gz
gentoo-2-64e46585b98fc4628f61edde3dd7c5543825ab2a.tar.bz2
gentoo-2-64e46585b98fc4628f61edde3dd7c5543825ab2a.zip
Initial import of git-python. Ebuild by Juergen Geuter.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/git-python')
-rw-r--r--dev-python/git-python/ChangeLog10
-rw-r--r--dev-python/git-python/git-python-0.1.6.ebuild25
-rw-r--r--dev-python/git-python/metadata.xml5
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/git-python/ChangeLog b/dev-python/git-python/ChangeLog
new file mode 100644
index 000000000000..8e85b1a5879b
--- /dev/null
+++ b/dev-python/git-python/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/git-python
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/git-python/ChangeLog,v 1.1 2009/06/21 20:56:54 patrick Exp $
+
+*git-python-0.1.6 (21 Jun 2009)
+
+ 21 Jun 2009; Patrick Lauer <patrick@gentoo.org> +git-python-0.1.6.ebuild,
+ +metadata.xml:
+ Initial import of git-python. Ebuild by Juergen Geuter.
+
diff --git a/dev-python/git-python/git-python-0.1.6.ebuild b/dev-python/git-python/git-python-0.1.6.ebuild
new file mode 100644
index 000000000000..6fa89d2b2473
--- /dev/null
+++ b/dev-python/git-python/git-python-0.1.6.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/git-python/git-python-0.1.6.ebuild,v 1.1 2009/06/21 20:56:54 patrick Exp $
+
+inherit python distutils
+
+DESCRIPTION="git-python is a python library used to interact with Git
+repositories."
+HOMEPAGE="http://gitorious.org/git-python"
+SRC_URI="http://pypi.python.org/packages/source/G/GitPython/GitPython-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="dev-lang/python"
+RDEPEND="dev-lang/python
+ dev-util/git"
+
+S=${WORKDIR}/GitPython-${PV}
+
+src_install (){
+ distutils_src_install
+}
diff --git a/dev-python/git-python/metadata.xml b/dev-python/git-python/metadata.xml
new file mode 100644
index 000000000000..301d2207cc29
--- /dev/null
+++ b/dev-python/git-python/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+</pkgmetadata>