summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-05-26 18:01:37 +0000
committerMichał Górny <mgorny@gentoo.org>2014-05-26 18:01:37 +0000
commitedaf2a1331b7eb2d8d4c852159b88b848f4b2cd5 (patch)
treee21dec5abf89ec8ed53b1224d3ae4d4e7029a7e0 /dev-python/gnome-keyring-python
parentConvert to gnome-python-common-r1. (diff)
downloadgentoo-2-edaf2a1331b7eb2d8d4c852159b88b848f4b2cd5.tar.gz
gentoo-2-edaf2a1331b7eb2d8d4c852159b88b848f4b2cd5.tar.bz2
gentoo-2-edaf2a1331b7eb2d8d4c852159b88b848f4b2cd5.zip
Convert to gnome-python-common-r1.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-python/gnome-keyring-python')
-rw-r--r--dev-python/gnome-keyring-python/ChangeLog11
-rw-r--r--dev-python/gnome-keyring-python/gnome-keyring-python-2.32.0-r1.ebuild23
2 files changed, 31 insertions, 3 deletions
diff --git a/dev-python/gnome-keyring-python/ChangeLog b/dev-python/gnome-keyring-python/ChangeLog
index 1facc6507ce8..06b716686026 100644
--- a/dev-python/gnome-keyring-python/ChangeLog
+++ b/dev-python/gnome-keyring-python/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/gnome-keyring-python
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-keyring-python/ChangeLog,v 1.50 2011/03/23 20:22:29 eva Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-keyring-python/ChangeLog,v 1.51 2014/05/26 18:01:37 mgorny Exp $
+
+*gnome-keyring-python-2.32.0-r1 (26 May 2014)
+
+ 26 May 2014; Michał Górny <mgorny@gentoo.org>
+ +gnome-keyring-python-2.32.0-r1.ebuild:
+ Convert to gnome-python-common-r1.
23 Mar 2011; Gilles Dartiguelongue <eva@gentoo.org>
-gnome-keyring-python-2.30.2.ebuild:
@@ -216,4 +222,3 @@
+gnome-keyring-python-2.22.0.ebuild:
Initial import of split gnome-python-desktop. This package installs
bindings for interfacing with the GNOME keyring.
-
diff --git a/dev-python/gnome-keyring-python/gnome-keyring-python-2.32.0-r1.ebuild b/dev-python/gnome-keyring-python/gnome-keyring-python-2.32.0-r1.ebuild
new file mode 100644
index 000000000000..f1ed41f0e8a7
--- /dev/null
+++ b/dev-python/gnome-keyring-python/gnome-keyring-python-2.32.0-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-keyring-python/gnome-keyring-python-2.32.0-r1.ebuild,v 1.1 2014/05/26 18:01:37 mgorny Exp $
+
+EAPI="5"
+
+GNOME_ORG_MODULE="gnome-python-desktop"
+G_PY_BINDINGS="gnomekeyring"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome-python-common-r1
+
+DESCRIPTION="Python bindings for the interfacing with the GNOME keyring"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="examples"
+
+RDEPEND=">=gnome-base/gnome-keyring-0.5.0
+ !<dev-python/gnome-python-desktop-2.22.0-r10"
+DEPEND="${RDEPEND}"
+
+EXAMPLES=( examples/keyring.py examples/keyring-async.py )