summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-05-10 13:45:23 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-05-10 13:45:23 +0000
commit1df6e020ceaf44e3e3b63ce54a82508db896d248 (patch)
treeaabed275d7f692c9ea7d102a615d8581432120de /dev-python/gnosis-utils/gnosis-utils-1.0.6.ebuild
parentVersion bump and fixes (diff)
downloadgentoo-2-1df6e020ceaf44e3e3b63ce54a82508db896d248.tar.gz
gentoo-2-1df6e020ceaf44e3e3b63ce54a82508db896d248.tar.bz2
gentoo-2-1df6e020ceaf44e3e3b63ce54a82508db896d248.zip
new package
Diffstat (limited to 'dev-python/gnosis-utils/gnosis-utils-1.0.6.ebuild')
-rw-r--r--dev-python/gnosis-utils/gnosis-utils-1.0.6.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/gnosis-utils/gnosis-utils-1.0.6.ebuild b/dev-python/gnosis-utils/gnosis-utils-1.0.6.ebuild
new file mode 100644
index 000000000000..cf7160ce85b4
--- /dev/null
+++ b/dev-python/gnosis-utils/gnosis-utils-1.0.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnosis-utils/gnosis-utils-1.0.6.ebuild,v 1.1 2003/05/10 13:45:13 liquidx Exp $
+
+inherit distutils
+
+IUSE=""
+MY_P=${P/gnosis-utils/Gnosis_Utils}
+
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="XML pickling and objectification with Python."
+SRC_URI="http://www.gnosis.cx/download/${MY_P}.tar.gz"
+HOMEPAGE="http://www.gnosis.cx/download/"
+
+DEPEND="virtual/python"
+
+SLOT="0"
+KEYWORDS="~x86"
+LICENSE="PYTHON"
+
+
+src_compile() {
+ python setup_gnosis.py build || die
+}
+
+src_install() {
+ distutils_python_version
+
+ python setup_gnosis.py install --root=${D} || die
+
+ dodir /usr/share/doc/${PF}
+ dodoc README MANIFEST PKG-INFO
+
+ if [ -e "${D}/usr/lib/python${PYVER}/site-packages/gnosis/doc" ] ; then
+ einfo "Moving documentation to correct location"
+ mv ${D}/usr/lib/python${PYVER}/site-packages/gnosis/doc ${D}/usr/share/doc/${PF}/doc
+ fi
+
+ rm -f ${D}/usr/lib/python${PYVER}/site-packages/gnosis/{README,MANIFEST}
+ rm -f ${D}/usr/lib/python${PYVER}/site-packages/{README,MANIFEST}
+}