summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-01-13 05:37:27 +0000
committerIan Delaney <idella4@gentoo.org>2015-01-13 05:37:27 +0000
commitfe31fe4691cd538defe98611d1dd61db617aadf5 (patch)
treeae3c47693acb00483638497cf22ba7f711a9220a /dev-python/gnuplot-py
parentfixing bug 526450 and a bump (diff)
downloadgentoo-2-fe31fe4691cd538defe98611d1dd61db617aadf5.tar.gz
gentoo-2-fe31fe4691cd538defe98611d1dd61db617aadf5.tar.bz2
gentoo-2-fe31fe4691cd538defe98611d1dd61db617aadf5.zip
tidy
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/gnuplot-py')
-rw-r--r--dev-python/gnuplot-py/ChangeLog8
-rw-r--r--dev-python/gnuplot-py/gnuplot-py-1.8-r1.ebuild25
2 files changed, 14 insertions, 19 deletions
diff --git a/dev-python/gnuplot-py/ChangeLog b/dev-python/gnuplot-py/ChangeLog
index e895daf21481..b0203b0ffb0b 100644
--- a/dev-python/gnuplot-py/ChangeLog
+++ b/dev-python/gnuplot-py/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/gnuplot-py
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gnuplot-py/ChangeLog,v 1.44 2014/06/27 15:12:20 jer Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnuplot-py/ChangeLog,v 1.45 2015/01/13 05:37:27 idella4 Exp $
+
+ 13 Jan 2015; Ian Delaney <idella4@gentoo.org> gnuplot-py-1.8-r1.ebuild:
+ tidy
*gnuplot-py-1.8-r1 (27 Jun 2014)
@@ -161,4 +164,3 @@
19 Jun 2003; Alastair Tse <liquidx@gentoo.org> gnuplot-py-1.6.ebuild:
new ebuild submitted by Chris Bainbridge <chrb@dcs.ed.ac.uk> (#21113)
-
diff --git a/dev-python/gnuplot-py/gnuplot-py-1.8-r1.ebuild b/dev-python/gnuplot-py/gnuplot-py-1.8-r1.ebuild
index 8ed63324133b..6e9437b60075 100644
--- a/dev-python/gnuplot-py/gnuplot-py-1.8-r1.ebuild
+++ b/dev-python/gnuplot-py/gnuplot-py-1.8-r1.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gnuplot-py/gnuplot-py-1.8-r1.ebuild,v 1.3 2014/06/27 15:12:20 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnuplot-py/gnuplot-py-1.8-r1.ebuild,v 1.4 2015/01/13 05:37:27 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
PYTHON_SINGLE_IMPL=true
-inherit distutils-r1 eutils
+inherit distutils-r1
DESCRIPTION="A python wrapper for Gnuplot"
HOMEPAGE="http://gnuplot-py.sourceforge.net/"
@@ -18,23 +18,16 @@ KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86
IUSE="doc"
DEPEND="
- dev-python/numpy[${PYTHON_USEDEP}]
-"
+ dev-python/numpy[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}
sci-visualization/gnuplot"
DOCS=( ANNOUNCE.txt CREDITS.txt FAQ.txt NEWS.txt TODO.txt )
-src_prepare() {
- distutils-r1_src_prepare
- epatch "${FILESDIR}"/${PN}-1.7-mousesupport.patch
-}
-
-src_install() {
- distutils-r1_src_install
+PATCHES=( "${FILESDIR}"/${PN}-1.7-mousesupport.patch )
- if use doc; then
- insinto /usr/share/doc/${PF}/html
- doins -r doc/Gnuplot/*
- fi
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/Gnuplot/. )
+ distutils-r1_python_install_all
}
+# testsuite does NOT run unattended, so left out here