summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-04-23 17:42:59 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-04-23 17:42:59 +0000
commit7da81cb76153dc418951784bd98c35ef1ad5f6d0 (patch)
treeda4d02eae88134cb309d01722f5ae9f3d9803b06 /dev-python/h5py
parentFix yard dependency issue by only building documentation when USE=doc, bug 46... (diff)
downloadgentoo-2-7da81cb76153dc418951784bd98c35ef1ad5f6d0.tar.gz
gentoo-2-7da81cb76153dc418951784bd98c35ef1ad5f6d0.tar.bz2
gentoo-2-7da81cb76153dc418951784bd98c35ef1ad5f6d0.zip
y Version bump
(Portage version: 2.2.01.21890-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'dev-python/h5py')
-rw-r--r--dev-python/h5py/ChangeLog8
-rw-r--r--dev-python/h5py/h5py-2.1.3.ebuild42
-rw-r--r--dev-python/h5py/metadata.xml16
3 files changed, 58 insertions, 8 deletions
diff --git a/dev-python/h5py/ChangeLog b/dev-python/h5py/ChangeLog
index 89c5b5cd22b5..6258ad3015d9 100644
--- a/dev-python/h5py/ChangeLog
+++ b/dev-python/h5py/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/h5py
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/h5py/ChangeLog,v 1.17 2013/03/07 09:43:56 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/h5py/ChangeLog,v 1.18 2013/04/23 17:42:59 bicatali Exp $
+
+*h5py-2.1.3 (23 Apr 2013)
+
+ 23 Apr 2013; Sébastien Fabbro <bicatali@gentoo.org> +h5py-2.1.3.ebuild,
+ metadata.xml:
+ y Version bump
*h5py-2.1.2-r1 (07 Mar 2013)
diff --git a/dev-python/h5py/h5py-2.1.3.ebuild b/dev-python/h5py/h5py-2.1.3.ebuild
new file mode 100644
index 000000000000..79a8aeacadbd
--- /dev/null
+++ b/dev-python/h5py/h5py-2.1.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/h5py/h5py-2.1.3.ebuild,v 1.1 2013/04/23 17:42:59 bicatali Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2} )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Simple Python interface to HDF5 files"
+HOMEPAGE="http://www.h5py.org/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test examples"
+
+RDEPEND="
+ sci-libs/hdf5:=
+ dev-python/numpy[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( virtual/python-unittest2[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ append-cflags -fno-strict-aliasing
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/lib/ && nosetests ./${PN}/lowtest || die
+}
+
+python_install_all() {
+ dodoc README.txt
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/dev-python/h5py/metadata.xml b/dev-python/h5py/metadata.xml
index 2d8aaf2ee743..f7b07dc6d8a1 100644
--- a/dev-python/h5py/metadata.xml
+++ b/dev-python/h5py/metadata.xml
@@ -1,16 +1,18 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>python</herd>
- <herd>sci</herd>
- <longdescription lang="en">HDF5 for Python (h5py) is a general-purpose simple Python interface to the
+<herd>python</herd>
+<herd>sci</herd>
+<longdescription lang="en">
+ HDF5 for Python (h5py) is a general-purpose simple Python interface to the
Hierarchical Data Format library, version 5. Existing Python and
Numpy concepts are used for the interface. Almost all HDF5 features
are available from Python, including things like compound datatypes
(as used with Numpy recarray types), HDF5 attributes, hyperslab and
point-based I/O, and more recent features in HDF 1.8 like resizable
- datasets and recursive iteration over entire files. </longdescription>
- <upstream>
- <remote-id type="google-code">h5py</remote-id>
- </upstream>
+ datasets and recursive iteration over entire files.
+</longdescription>
+<upstream>
+ <remote-id type="google-code">h5py</remote-id>
+</upstream>
</pkgmetadata>