summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-10-25 06:46:23 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-10-25 06:46:23 +0000
commit1eb9fd1c307e3b17f5a01b43e5ca717bf0bf1a9d (patch)
treec4afa9db1ee4b33f51b3f98799df7ba30e27860d /dev-python/hacking
parentAdd ruby20. Drop ppc64 due to yard dependency, bug 465948. (diff)
downloadgentoo-2-1eb9fd1c307e3b17f5a01b43e5ca717bf0bf1a9d.tar.gz
gentoo-2-1eb9fd1c307e3b17f5a01b43e5ca717bf0bf1a9d.tar.bz2
gentoo-2-1eb9fd1c307e3b17f5a01b43e5ca717bf0bf1a9d.zip
bump of hacking, also, test support
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/hacking')
-rw-r--r--dev-python/hacking/ChangeLog8
-rw-r--r--dev-python/hacking/hacking-0.5.6.ebuild10
-rw-r--r--dev-python/hacking/hacking-0.7.2.ebuild36
3 files changed, 49 insertions, 5 deletions
diff --git a/dev-python/hacking/ChangeLog b/dev-python/hacking/ChangeLog
index 4b1ed369c7c9..1ce0fe2396cd 100644
--- a/dev-python/hacking/ChangeLog
+++ b/dev-python/hacking/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/hacking
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/hacking/ChangeLog,v 1.1 2013/08/13 16:05:36 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/hacking/ChangeLog,v 1.2 2013/10/25 06:46:23 prometheanfire Exp $
+
+*hacking-0.7.2 (25 Oct 2013)
+
+ 25 Oct 2013; Matthew Thode <prometheanfire@gentoo.org> +hacking-0.7.2.ebuild,
+ hacking-0.5.6.ebuild:
+ bump of hacking, also, test support
*hacking-0.5.6 (13 Aug 2013)
diff --git a/dev-python/hacking/hacking-0.5.6.ebuild b/dev-python/hacking/hacking-0.5.6.ebuild
index 4d87d0846f50..2e71d1357fed 100644
--- a/dev-python/hacking/hacking-0.5.6.ebuild
+++ b/dev-python/hacking/hacking-0.5.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/hacking/hacking-0.5.6.ebuild,v 1.1 2013/08/13 16:05:36 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/hacking/hacking-0.5.6.ebuild,v 1.2 2013/10/25 06:46:23 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_6 python2_7 )
@@ -15,10 +15,12 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND=">=dev-python/pbr-0.5.21[${PYTHON_USEDEP}]
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.5.21[${PYTHON_USEDEP}]
<dev-python/pbr-1[${PYTHON_USEDEP}]
- ~dev-python/pep8-1.4.5[${PYTHON_USEDEP}]
+ >=dev-python/d2to1-0.2.10[${PYTHON_USEDEP}]
+ <dev-python/d2to1-0.3[${PYTHON_USEDEP}]"
+RDEPEND="~dev-python/pep8-1.4.5[${PYTHON_USEDEP}]
~dev-python/pyflakes-0.7.2[${PYTHON_USEDEP}]
~dev-python/flake8-2.0[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]"
diff --git a/dev-python/hacking/hacking-0.7.2.ebuild b/dev-python/hacking/hacking-0.7.2.ebuild
new file mode 100644
index 000000000000..f8e67d614608
--- /dev/null
+++ b/dev-python/hacking/hacking-0.7.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/hacking/hacking-0.7.2.ebuild,v 1.1 2013/10/25 06:46:23 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Nova API"
+HOMEPAGE="https://github.com/openstack-dev/hacking"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.5.21[${PYTHON_USEDEP}]
+ <dev-python/pbr-1[${PYTHON_USEDEP}]
+ test? ( >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-0.3.14[${PYTHON_USEDEP}]
+ dev-python/subunit[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.17[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.32[${PYTHON_USEDEP}] )"
+RDEPEND="~dev-python/pep8-1.4.5[${PYTHON_USEDEP}]
+ >=dev-python/pyflakes-0.7.2[${PYTHON_USEDEP}]
+ <dev-python/pyflakes-0.7.4[${PYTHON_USEDEP}]
+ ~dev-python/flake8-2.0[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON}" -m subunit.run discover -t ./ . || die
+}