summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-28 21:50:19 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-28 21:50:19 +0000
commit4a1f4483413cd474019201875ff9faa783fbc20a (patch)
tree57cba72b694ec3d74862859a172115c24bd26e94 /dev-python/happydoc
parentAdded two new dependencies of mythweather. bug #330057 (diff)
downloadgentoo-2-4a1f4483413cd474019201875ff9faa783fbc20a.tar.gz
gentoo-2-4a1f4483413cd474019201875ff9faa783fbc20a.tar.bz2
gentoo-2-4a1f4483413cd474019201875ff9faa783fbc20a.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/happydoc')
-rw-r--r--dev-python/happydoc/ChangeLog8
-rw-r--r--dev-python/happydoc/happydoc-3.1.ebuild34
2 files changed, 27 insertions, 15 deletions
diff --git a/dev-python/happydoc/ChangeLog b/dev-python/happydoc/ChangeLog
index 99b3ca59f5c2..0da986b83441 100644
--- a/dev-python/happydoc/ChangeLog
+++ b/dev-python/happydoc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/happydoc
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/happydoc/ChangeLog,v 1.23 2009/02/25 20:59:37 neurogeek Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/happydoc/ChangeLog,v 1.24 2010/07/28 21:50:19 arfrever Exp $
+
+ 28 Jul 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ happydoc-3.1.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
*happydoc-3.1 (25 Feb 2009)
diff --git a/dev-python/happydoc/happydoc-3.1.ebuild b/dev-python/happydoc/happydoc-3.1.ebuild
index 3a3e3d3dbc98..9aa148ee7e07 100644
--- a/dev-python/happydoc/happydoc-3.1.ebuild
+++ b/dev-python/happydoc/happydoc-3.1.ebuild
@@ -1,38 +1,46 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/happydoc/happydoc-3.1.ebuild,v 1.1 2009/02/25 20:59:37 neurogeek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/happydoc/happydoc-3.1.ebuild,v 1.2 2010/07/28 21:50:19 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
inherit distutils versionator
MY_PN="HappyDoc"
MY_PV=$(replace_all_version_separators "_" ${PV})
MY_V=$(get_major_version ${PV})
-DESCRIPTION="tool for extracting documentation from Python sourcecode"
-SRC_URI="mirror://sourceforge/${PN}/${MY_PN}_r${MY_PV}.tar.gz"
+
+DESCRIPTION="Tool for extracting documentation from Python source code"
HOMEPAGE="http://happydoc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}_r${MY_PV}.tar.gz"
-SLOT="0"
LICENSE="as-is"
+SLOT="0"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
IUSE="doc"
-DEPEND="virtual/python"
+DEPEND=""
+RDEPEND=""
-# the tests need extra data not present in the release tarball
-RESTRICT=test
+# Tests need extra data not present in the release tarball.
+RESTRICT="test"
S="${WORKDIR}/${MY_PN}${MY_V}-r${MY_PV}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- cp "${FILESDIR}/${P}-setup.py" "${S}/setup.py" || die "setup.py file not found"
+PYTHON_MODNAME="happydoclib"
+
+src_prepare() {
+ distutils_src_prepare
+ cp "${FILESDIR}/${P}-setup.py" setup.py || die "Copying of setup.py failed"
}
src_install() {
distutils_src_install
if use doc; then
- dohtml -r "srcdocs/${MY_PN}${MY_V}-r${MY_PV}"/*
+ dohtml -r "srcdocs/${MY_PN}${MY_V}-r${MY_PV}"/* || die "Installation of documentation failed"
fi
}