summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-08-24 08:19:25 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-08-24 08:19:25 +0000
commita89e4fc7bfef4d509f0b30df2f67a3d08c7b4bb6 (patch)
treeb6c659a5d786dd619293d5af538e1b14e5ff4d47 /dev-python/http-parser
parentSupport x32 ABI on amd64. (diff)
downloadgentoo-2-a89e4fc7bfef4d509f0b30df2f67a3d08c7b4bb6.tar.gz
gentoo-2-a89e4fc7bfef4d509f0b30df2f67a3d08c7b4bb6.tar.bz2
gentoo-2-a89e4fc7bfef4d509f0b30df2f67a3d08c7b4bb6.zip
Bump
(Portage version: 2.2.0_alpha122/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/http-parser')
-rw-r--r--dev-python/http-parser/ChangeLog8
-rw-r--r--dev-python/http-parser/http-parser-0.7.8.ebuild35
2 files changed, 41 insertions, 2 deletions
diff --git a/dev-python/http-parser/ChangeLog b/dev-python/http-parser/ChangeLog
index 9685365317ed..27d0c909e888 100644
--- a/dev-python/http-parser/ChangeLog
+++ b/dev-python/http-parser/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/http-parser
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/http-parser/ChangeLog,v 1.1 2012/06/07 18:09:36 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/http-parser/ChangeLog,v 1.2 2012/08/24 08:19:25 patrick Exp $
+
+*http-parser-0.7.8 (24 Aug 2012)
+
+ 24 Aug 2012; Patrick Lauer <patrick@gentoo.org> +http-parser-0.7.8.ebuild:
+ Bump
*http-parser-0.7.5 (07 Jun 2012)
@@ -8,4 +13,3 @@
+http-parser-0.7.5.ebuild, +metadata.xml:
Initial import. Ebuild written by Ian Delaney <johneed@hotmail.com>. Fixes
bug 416879
-
diff --git a/dev-python/http-parser/http-parser-0.7.8.ebuild b/dev-python/http-parser/http-parser-0.7.8.ebuild
new file mode 100644
index 000000000000..fa7a9a246420
--- /dev/null
+++ b/dev-python/http-parser/http-parser-0.7.8.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/http-parser/http-parser-0.7.8.ebuild,v 1.1 2012/08/24 08:19:25 patrick Exp $
+
+EAPI=4
+
+SUPPORT_PYTHON_ABIS=1
+RESTRICT_PYTHON_ABIS="*-jython"
+
+inherit distutils
+
+DESCRIPTION="HTTP request/response parser for python in C"
+HOMEPAGE="http://github.com/benoitc/http-parser"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ dev-python/cython"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+src_install() {
+ distutils_src_install
+ if use examples; then
+ docompress -x usr/share/doc/${P}/examples
+ insinto usr/share/doc/${P}
+ doins -r examples/
+ fi
+}