summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2014-02-17 16:06:49 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2014-02-17 16:06:49 +0000
commit40bfc202fa2b0fa8f9a4db3c81a4a6eb334058af (patch)
treef97874b151d52811b5d5d6df9a72345a030432a9 /dev-python/httpretty
parentdrop 2.0.5; fix deps, tex4ht[java] bug #486182, graphicsmagick[png] bug #3142... (diff)
downloadgentoo-2-40bfc202fa2b0fa8f9a4db3c81a4a6eb334058af.tar.gz
gentoo-2-40bfc202fa2b0fa8f9a4db3c81a4a6eb334058af.tar.bz2
gentoo-2-40bfc202fa2b0fa8f9a4db3c81a4a6eb334058af.zip
updating for a dep of a dep of a dep for a cve...
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/httpretty')
-rw-r--r--dev-python/httpretty/ChangeLog8
-rw-r--r--dev-python/httpretty/httpretty-0.8.0.ebuild45
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-python/httpretty/ChangeLog b/dev-python/httpretty/ChangeLog
index 783eb8722e2d..b7930fe5eaea 100644
--- a/dev-python/httpretty/ChangeLog
+++ b/dev-python/httpretty/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/httpretty
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/httpretty/ChangeLog,v 1.3 2014/01/06 11:50:34 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/httpretty/ChangeLog,v 1.4 2014/02/17 16:06:49 prometheanfire Exp $
+
+*httpretty-0.8.0 (17 Feb 2014)
+
+ 17 Feb 2014; Matthew Thode <prometheanfire@gentoo.org>
+ +httpretty-0.8.0.ebuild:
+ updating for a dep of a dep of a dep for a cve...
*httpretty-0.7.1 (06 Jan 2014)
diff --git a/dev-python/httpretty/httpretty-0.8.0.ebuild b/dev-python/httpretty/httpretty-0.8.0.ebuild
new file mode 100644
index 000000000000..bb80c3493fa0
--- /dev/null
+++ b/dev-python/httpretty/httpretty-0.8.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/httpretty/httpretty-0.8.0.ebuild,v 1.1 2014/02/17 16:06:49 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP client mock for Python"
+HOMEPAGE="http://github.com/gabrielfalcao/httpretty"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="dev-python/urllib3[${PYTHON_USEDEP}]
+ "
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( >=dev-python/coverage-3.5[${PYTHON_USEDEP}]
+ >=dev-python/nose-1.2[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ dev-python/sure[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ >=dev-python/requests-1.1[${PYTHON_USEDEP}]
+ >=www-servers/tornado-2.2[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ if ! use test; then
+ rm -rf tests/
+ fi
+}
+
+python_test() {
+ # https://github.com/gabrielfalcao/HTTPretty/issues/125
+ nosetests tests/unit \
+ -e test_recording_calls \
+ -e test_playing_calls \
+ -e test_callback_setting_headers_and_status_response \
+ tests/functional || die "Tests failed under ${EPYTHON}"
+ rm -rf tests/ "${BUILD_DIR}"/lib/tests/ || die
+}