summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCorentin Chary <iksaif@gentoo.org>2012-06-29 15:45:50 +0000
committerCorentin Chary <iksaif@gentoo.org>2012-06-29 15:45:50 +0000
commitb1bce1e9855fdef5467fb54327762b47811c195b (patch)
treea32597d97e44215904336f5c61fe376caf8cb266 /dev-python/kombu
parentStable for HPPA (bug #414745). (diff)
downloadgentoo-2-b1bce1e9855fdef5467fb54327762b47811c195b.tar.gz
gentoo-2-b1bce1e9855fdef5467fb54327762b47811c195b.tar.bz2
gentoo-2-b1bce1e9855fdef5467fb54327762b47811c195b.zip
Bump to 2.2.0. Closes #422723. Patch from Ian Delaney.
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/kombu')
-rw-r--r--dev-python/kombu/ChangeLog7
-rw-r--r--dev-python/kombu/kombu-2.2.0.ebuild63
2 files changed, 69 insertions, 1 deletions
diff --git a/dev-python/kombu/ChangeLog b/dev-python/kombu/ChangeLog
index ca015909c699..20ab4fa6f032 100644
--- a/dev-python/kombu/ChangeLog
+++ b/dev-python/kombu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/kombu
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/kombu/ChangeLog,v 1.1 2012/05/30 06:37:19 iksaif Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kombu/ChangeLog,v 1.2 2012/06/29 15:45:50 iksaif Exp $
+
+*kombu-2.2.0 (29 Jun 2012)
+
+ 29 Jun 2012; Corentin Chary <iksaif@gentoo.org> +kombu-2.2.0.ebuild:
+ Bump to 2.2.0. Closes #422723. Patch from Ian Delaney.
*kombu-2.1.8 (30 May 2012)
diff --git a/dev-python/kombu/kombu-2.2.0.ebuild b/dev-python/kombu/kombu-2.2.0.ebuild
new file mode 100644
index 000000000000..e62dc7fdba75
--- /dev/null
+++ b/dev-python/kombu/kombu-2.2.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kombu/kombu-2.2.0.ebuild,v 1.1 2012/06/29 15:45:50 iksaif Exp $
+
+EAPI="4"
+
+PYTHON_DEPEND="*:2.5"
+RESTRICT_PYTHON_ABIS="2.4"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils eutils
+
+DESCRIPTION="AMQP Messaging Framework for Python"
+HOMEPAGE="https://github.com/ask/kombu"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND=">=dev-python/anyjson-0.3.1
+ >=dev-python/amqplib-1.0"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose-cover3
+ dev-python/mock
+ dev-python/simplejson
+ dev-python/anyjson
+ dev-python/redis-py
+ dev-python/pymongo )
+ doc? ( dev-python/sphinx
+ dev-python/beanstalkc
+ dev-python/couchdb-python )
+ dev-python/setuptools"
+
+src_prepare() {
+ if use test; then
+ epatch "${FILESDIR}/${PN}-2.1.1-add-assertIsInstance-with-unittest.patch"
+ fi
+}
+
+src_compile() {
+ distutils_src_compile
+ use doc && emake -C docs html
+}
+
+src_test() {
+ testing() {
+ nosetests --py3where build-${PYTHON_ABI}/lib/kombu/tests
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+ if use examples; then
+ docompress -x usr/share/doc/${P}/examples/
+ insinto usr/share/doc/${P}/
+ doins -r examples/
+ fi
+ use doc && dohtml -r docs/.build/html/
+}