summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-02-09 17:33:58 +0000
committerIan Delaney <idella4@gentoo.org>2013-02-09 17:33:58 +0000
commitb0ac7fc74b62ff126de06d1584ce836fa7e0239e (patch)
tree78c4a4be7c3506d56e2abbca8215ee42c7f9c819 /dev-python/logilab-common
parentFixed location of ifconfig binary (bug #455902) (diff)
downloadgentoo-2-b0ac7fc74b62ff126de06d1584ce836fa7e0239e.tar.gz
gentoo-2-b0ac7fc74b62ff126de06d1584ce836fa7e0239e.tar.bz2
gentoo-2-b0ac7fc74b62ff126de06d1584ce836fa7e0239e.zip
Add utf8-test.patch to fix locale/utf8 issue in unittest_umessage.py, no bug made
(Portage version: 2.1.11.40/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/logilab-common')
-rw-r--r--dev-python/logilab-common/ChangeLog7
-rw-r--r--dev-python/logilab-common/files/logilab-common-0.59.0-utf8-test.patch22
-rw-r--r--dev-python/logilab-common/logilab-common-0.59.0.ebuild6
3 files changed, 32 insertions, 3 deletions
diff --git a/dev-python/logilab-common/ChangeLog b/dev-python/logilab-common/ChangeLog
index 7594492a4456..fcc1fcf0cb6a 100644
--- a/dev-python/logilab-common/ChangeLog
+++ b/dev-python/logilab-common/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/logilab-common
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-common/ChangeLog,v 1.119 2013/02/09 15:46:33 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-common/ChangeLog,v 1.120 2013/02/09 17:33:58 idella4 Exp $
+
+ 09 Feb 2013; Ian Delaney <idella4@gentoo.org>
+ +files/logilab-common-0.59.0-utf8-test.patch, logilab-common-0.59.0.ebuild:
+ Add utf8-test.patch to fix locale/utf8 issue in unittest_umessage.py, no bug
+ made
09 Feb 2013; Ian Delaney <idella4@gentoo.org>
+files/logilab-common-0.59.0-syntax.patch, logilab-common-0.59.0.ebuild:
diff --git a/dev-python/logilab-common/files/logilab-common-0.59.0-utf8-test.patch b/dev-python/logilab-common/files/logilab-common-0.59.0-utf8-test.patch
new file mode 100644
index 000000000000..f0cd39addbc6
--- /dev/null
+++ b/dev-python/logilab-common/files/logilab-common-0.59.0-utf8-test.patch
@@ -0,0 +1,22 @@
+diff -ur logilab-common-0.59.0.orig/test/unittest_umessage.py logilab-common-0.59.0/test/unittest_umessage.py
+--- test/unittest_umessage.py 2013-01-24 01:42:03.000000000 +0800
++++ test/unittest_umessage.py 2013-02-10 00:53:58.431767641 +0800
+@@ -21,16 +21,17 @@
+
+ from logilab.common.testlib import TestCase, unittest_main
+ from logilab.common.umessage import UMessage, decode_QP
++import io
+
+ DATA = join(dirname(abspath(__file__)), 'data')
+
+ class UMessageTC(TestCase):
+
+ def setUp(self):
+- msg1 = email.message_from_file(open(join(DATA, 'test1.msg')))
++ msg1 = email.message_from_file(io.open(join(DATA, 'test1.msg'), encoding='utf8'))
+ self.umessage1 = UMessage(msg1)
+- msg2 = email.message_from_file(open(join(DATA, 'test2.msg')))
++ msg2 = email.message_from_file(io.open(join(DATA, 'test2.msg'), encoding='utf8'))
+ self.umessage2 = UMessage(msg2)
+
+ def test_get_subject(self):
diff --git a/dev-python/logilab-common/logilab-common-0.59.0.ebuild b/dev-python/logilab-common/logilab-common-0.59.0.ebuild
index b9fe170ddd5f..4be295097bff 100644
--- a/dev-python/logilab-common/logilab-common-0.59.0.ebuild
+++ b/dev-python/logilab-common/logilab-common-0.59.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-common/logilab-common-0.59.0.ebuild,v 1.3 2013/02/09 15:46:33 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-common/logilab-common-0.59.0.ebuild,v 1.4 2013/02/09 17:33:58 idella4 Exp $
EAPI=5
# broken with python3.3, bug #449276
@@ -33,7 +33,8 @@ DEPEND="${RDEPEND}
python_prepare_all() {
sed -e 's:(CURDIR):{S}/${P}:' -i doc/makefile || die
- epatch "${FILESDIR}"/${P}-syntax.patch
+ epatch "${FILESDIR}"/${P}-syntax.patch \
+ "${FILESDIR}"/${P}-utf8-test.patch
distutils-r1_python_prepare_all
}
@@ -62,6 +63,7 @@ python_test() {
local bindir=${tpath}/bin
local libdir=${tpath}/lib
local PYTHONPATH=${libdir}:${PYTHONPATH}
+ export TZ=UTC
mkdir -p "${libdir}" || die
esetup.py egg_info --egg-base="${tpath}" \