summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-11-23 16:36:23 +0000
committerMike Gilbert <floppym@gentoo.org>2014-11-23 16:36:23 +0000
commitb4c5aa849f57c9b25c10d1bdea4bbb9267c0bf93 (patch)
tree939397961c6ce312899159753d3793d7bbecdf25 /dev-python/matplotlib
parentCleanup python_gen_usedep usage. (diff)
downloadgentoo-2-b4c5aa849f57c9b25c10d1bdea4bbb9267c0bf93.tar.gz
gentoo-2-b4c5aa849f57c9b25c10d1bdea4bbb9267c0bf93.tar.bz2
gentoo-2-b4c5aa849f57c9b25c10d1bdea4bbb9267c0bf93.zip
Cleanup python_gen_usdep usage.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/matplotlib')
-rw-r--r--dev-python/matplotlib/ChangeLog7
-rw-r--r--dev-python/matplotlib/matplotlib-1.2.0-r2.ebuild5
-rw-r--r--dev-python/matplotlib/matplotlib-1.2.1.ebuild5
-rw-r--r--dev-python/matplotlib/matplotlib-1.3.0.ebuild5
-rw-r--r--dev-python/matplotlib/matplotlib-1.3.1.ebuild5
-rw-r--r--dev-python/matplotlib/matplotlib-1.4.0.ebuild3
-rw-r--r--dev-python/matplotlib/matplotlib-1.4.2.ebuild3
-rw-r--r--dev-python/matplotlib/matplotlib-9999.ebuild4
8 files changed, 16 insertions, 21 deletions
diff --git a/dev-python/matplotlib/ChangeLog b/dev-python/matplotlib/ChangeLog
index 2ac71a640190..604c0648e50e 100644
--- a/dev-python/matplotlib/ChangeLog
+++ b/dev-python/matplotlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/matplotlib
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/ChangeLog,v 1.172 2014/11/06 04:00:05 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/ChangeLog,v 1.173 2014/11/23 16:36:23 floppym Exp $
+
+ 23 Nov 2014; Mike Gilbert <floppym@gentoo.org> matplotlib-1.2.0-r2.ebuild,
+ matplotlib-1.2.1.ebuild, matplotlib-1.3.0.ebuild, matplotlib-1.3.1.ebuild,
+ matplotlib-1.4.0.ebuild, matplotlib-1.4.2.ebuild, matplotlib-9999.ebuild:
+ Cleanup python_gen_usdep usage.
*matplotlib-1.4.2 (06 Nov 2014)
diff --git a/dev-python/matplotlib/matplotlib-1.2.0-r2.ebuild b/dev-python/matplotlib/matplotlib-1.2.0-r2.ebuild
index 0a5197bb26e0..b4a406c768b9 100644
--- a/dev-python/matplotlib/matplotlib-1.2.0-r2.ebuild
+++ b/dev-python/matplotlib/matplotlib-1.2.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-1.2.0-r2.ebuild,v 1.15 2014/04/26 08:20:26 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-1.2.0-r2.ebuild,v 1.16 2014/11/23 16:36:23 floppym Exp $
EAPI=5
@@ -25,7 +25,6 @@ LICENSE="BitstreamVera BSD matplotlib MIT OFL-1.1"
# #456704 -- a lot of py2-only deps
PY2_USEDEP=$(python_gen_usedep 'python2*')
-PY32_USEDEP=$(python_gen_usedep python{3_2,3_3})
COMMON_DEPEND="dev-python/numpy[${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]
@@ -43,7 +42,7 @@ DEPEND="${COMMON_DEPEND}
virtual/pkgconfig
doc? (
app-text/dvipng
- virtual/python-imaging[${PY2_USEDEP},${PY32_USEDEP}]
+ virtual/python-imaging[${PYTHON_USEDEP}]
dev-python/ipython
dev-python/xlwt[${PY2_USEDEP}]
dev-python/sphinx[${PYTHON_USEDEP}]
diff --git a/dev-python/matplotlib/matplotlib-1.2.1.ebuild b/dev-python/matplotlib/matplotlib-1.2.1.ebuild
index df3a010d3c22..7c565fbc9fe0 100644
--- a/dev-python/matplotlib/matplotlib-1.2.1.ebuild
+++ b/dev-python/matplotlib/matplotlib-1.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-1.2.1.ebuild,v 1.7 2014/04/26 08:20:26 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-1.2.1.ebuild,v 1.8 2014/11/23 16:36:23 floppym Exp $
EAPI=5
@@ -25,7 +25,6 @@ LICENSE="BitstreamVera BSD matplotlib MIT OFL-1.1"
# #456704 -- a lot of py2-only deps
PY2_USEDEP=$(python_gen_usedep 'python2*')
-PY32_USEDEP=$(python_gen_usedep python{3_2,3_3})
COMMON_DEPEND="
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
@@ -44,7 +43,7 @@ DEPEND="${COMMON_DEPEND}
virtual/pkgconfig
doc? (
app-text/dvipng
- virtual/python-imaging[${PY2_USEDEP},${PY32_USEDEP}]
+ virtual/python-imaging[${PYTHON_USEDEP}]
dev-python/ipython
dev-python/xlwt[${PY2_USEDEP}]
dev-python/sphinx[${PYTHON_USEDEP}]
diff --git a/dev-python/matplotlib/matplotlib-1.3.0.ebuild b/dev-python/matplotlib/matplotlib-1.3.0.ebuild
index 9af049ffc982..80413695278a 100644
--- a/dev-python/matplotlib/matplotlib-1.3.0.ebuild
+++ b/dev-python/matplotlib/matplotlib-1.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-1.3.0.ebuild,v 1.11 2014/09/08 04:04:49 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-1.3.0.ebuild,v 1.12 2014/11/23 16:36:23 floppym Exp $
EAPI=5
@@ -25,7 +25,6 @@ LICENSE="BitstreamVera BSD matplotlib MIT OFL-1.1"
# #456704 -- a lot of py2-only deps
PY2_USEDEP=$(python_gen_usedep 'python2*')
-PY32_USEDEP=$(python_gen_usedep python{3_2,3_3})
COMMON_DEPEND="
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/python-dateutil:0[${PYTHON_USEDEP}]
@@ -47,7 +46,7 @@ DEPEND="${COMMON_DEPEND}
virtual/pkgconfig
doc? (
app-text/dvipng
- virtual/python-imaging[${PY2_USEDEP},${PY32_USEDEP}]
+ virtual/python-imaging[${PYTHON_USEDEP}]
dev-python/ipython
dev-python/numpydoc[${PY2_USEDEP}]
dev-python/xlwt[${PY2_USEDEP}]
diff --git a/dev-python/matplotlib/matplotlib-1.3.1.ebuild b/dev-python/matplotlib/matplotlib-1.3.1.ebuild
index 28d933f14196..1ec6db2a3fac 100644
--- a/dev-python/matplotlib/matplotlib-1.3.1.ebuild
+++ b/dev-python/matplotlib/matplotlib-1.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-1.3.1.ebuild,v 1.6 2014/09/08 04:04:49 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-1.3.1.ebuild,v 1.7 2014/11/23 16:36:23 floppym Exp $
EAPI=5
@@ -27,8 +27,6 @@ IUSE="cairo doc excel examples fltk gtk gtk3 latex pyside qt4 test tk wxwidgets"
# #456704 -- a lot of py2-only deps
PY2_USEDEP=$(python_gen_usedep 'python2*')
-PY32_USEDEP=$(python_gen_usedep python3_2)
-PY3_USEDEP=$(python_gen_usedep python{3_2,3_3})
COMMON_DEPEND="
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/python-dateutil:0[${PYTHON_USEDEP}]
@@ -83,7 +81,6 @@ RDEPEND="${COMMON_DEPEND}
qt4? ( dev-python/PyQt4[X,${PYTHON_USEDEP}] )"
PY2_FLAGS="|| ( $(python_gen_useflags python2*) )"
-PY32_FLAGS="|| ( $(python_gen_useflags python3_2) )"
REQUIRED_USE="
doc? ( ${PY2_FLAGS} )
excel? ( ${PY2_FLAGS} )
diff --git a/dev-python/matplotlib/matplotlib-1.4.0.ebuild b/dev-python/matplotlib/matplotlib-1.4.0.ebuild
index 8b86e8ada294..7533f83eeb27 100644
--- a/dev-python/matplotlib/matplotlib-1.4.0.ebuild
+++ b/dev-python/matplotlib/matplotlib-1.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-1.4.0.ebuild,v 1.2 2014/09/17 08:53:33 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-1.4.0.ebuild,v 1.3 2014/11/23 16:36:23 floppym Exp $
EAPI=5
@@ -25,7 +25,6 @@ IUSE="cairo doc excel examples fltk gtk gtk3 latex pyside qt4 test tk wxwidgets"
# #456704 -- a lot of py2-only deps
PY2_USEDEP=$(python_gen_usedep python2_7)
-PY3_USEDEP=$(python_gen_usedep python3{_3,_4})
COMMON_DEPEND="
>=dev-python/numpy-1.6[${PYTHON_USEDEP}]
dev-python/python-dateutil:0[${PYTHON_USEDEP}]
diff --git a/dev-python/matplotlib/matplotlib-1.4.2.ebuild b/dev-python/matplotlib/matplotlib-1.4.2.ebuild
index 6bb78c9d162c..3fae52381c9a 100644
--- a/dev-python/matplotlib/matplotlib-1.4.2.ebuild
+++ b/dev-python/matplotlib/matplotlib-1.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-1.4.2.ebuild,v 1.1 2014/11/06 04:00:05 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-1.4.2.ebuild,v 1.2 2014/11/23 16:36:23 floppym Exp $
EAPI=5
@@ -25,7 +25,6 @@ IUSE="cairo doc excel examples fltk gtk gtk3 latex pyside qt4 test tk wxwidgets"
# #456704 -- a lot of py2-only deps
PY2_USEDEP=$(python_gen_usedep python2_7)
-PY3_USEDEP=$(python_gen_usedep python3{_3,_4})
COMMON_DEPEND="
>=dev-python/numpy-1.6[${PYTHON_USEDEP}]
dev-python/python-dateutil:0[${PYTHON_USEDEP}]
diff --git a/dev-python/matplotlib/matplotlib-9999.ebuild b/dev-python/matplotlib/matplotlib-9999.ebuild
index 8af467363d65..b8575b245d9d 100644
--- a/dev-python/matplotlib/matplotlib-9999.ebuild
+++ b/dev-python/matplotlib/matplotlib-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-9999.ebuild,v 1.3 2014/09/08 04:04:49 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-9999.ebuild,v 1.4 2014/11/23 16:36:23 floppym Exp $
EAPI=5
@@ -28,8 +28,6 @@ IUSE="cairo doc excel examples fltk gtk gtk3 latex pyside qt4 test tk wxwidgets"
# #456704 -- a lot of py2-only deps
PY2_USEDEP=$(python_gen_usedep 'python2*')
-PY32_USEDEP=$(python_gen_usedep python3_2)
-PY3_USEDEP=$(python_gen_usedep python{3_2,3_3})
COMMON_DEPEND="
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/python-dateutil:0[${PYTHON_USEDEP}]