summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-02-28 11:44:43 +0000
committerJustin Lecher <jlec@gentoo.org>2015-02-28 11:44:43 +0000
commit44f70247ed0b45ab360a80c294a27a04606b706c (patch)
treeccbd6adfb71e28a79aee95e54ea8fc6e472ed72f /dev-python/mistune
parentdrop condition on Prefix for gentoo-functions (diff)
downloadgentoo-2-44f70247ed0b45ab360a80c294a27a04606b706c.tar.gz
gentoo-2-44f70247ed0b45ab360a80c294a27a04606b706c.tar.bz2
gentoo-2-44f70247ed0b45ab360a80c294a27a04606b706c.zip
New package written by me
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-python/mistune')
-rw-r--r--dev-python/mistune/ChangeLog9
-rw-r--r--dev-python/mistune/metadata.xml8
-rw-r--r--dev-python/mistune/mistune-0.5.ebuild27
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/mistune/ChangeLog b/dev-python/mistune/ChangeLog
new file mode 100644
index 000000000000..1c874ae07bbc
--- /dev/null
+++ b/dev-python/mistune/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-python/mistune
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mistune/ChangeLog,v 1.1 2015/02/28 11:44:43 jlec Exp $
+
+*mistune-0.5 (28 Feb 2015)
+
+ 28 Feb 2015; Justin Lecher <jlec@gentoo.org> +metadata.xml,
+ +mistune-0.5.ebuild:
+ New package written by me
diff --git a/dev-python/mistune/metadata.xml b/dev-python/mistune/metadata.xml
new file mode 100644
index 000000000000..7bc6ee8ea837
--- /dev/null
+++ b/dev-python/mistune/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ <name>Justin Lecher</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/mistune/mistune-0.5.ebuild b/dev-python/mistune/mistune-0.5.ebuild
new file mode 100644
index 000000000000..64253f9dbf63
--- /dev/null
+++ b/dev-python/mistune/mistune-0.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mistune/mistune-0.5.ebuild,v 1.1 2015/02/28 11:44:43 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="The fastest markdown parser in pure Python"
+HOMEPAGE="https://pypi.python.org/pypi/mistune https://github.com/lepture/mistune"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/cython[$(python_gen_usedep 'python*')]
+"
+
+python_test() {
+ ${EPYTHON} tests/test.py || die
+}