summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2015-03-18 02:14:08 +0000
committerRick Farina <zerochaos@gentoo.org>2015-03-18 02:14:08 +0000
commita39b30da58f89b011e1ce1b6b6c85a3878b04c4e (patch)
treeae4f226067ab1dc06b9c5e210c90ec707834a929 /dev-python/nltk
parentAdd "-a" to egrep to force it print lines. #542534 (diff)
downloadgentoo-2-a39b30da58f89b011e1ce1b6b6c85a3878b04c4e.tar.gz
gentoo-2-a39b30da58f89b011e1ce1b6b6c85a3878b04c4e.tar.bz2
gentoo-2-a39b30da58f89b011e1ce1b6b6c85a3878b04c4e.zip
fix bug #538056
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'dev-python/nltk')
-rw-r--r--dev-python/nltk/ChangeLog9
-rw-r--r--dev-python/nltk/files/fix-newer-setuptools.patch32
-rw-r--r--dev-python/nltk/nltk-2.0.4.ebuild11
-rw-r--r--dev-python/nltk/nltk-2.0_beta9.ebuild4
-rw-r--r--dev-python/nltk/nltk-3.0.2.ebuild (renamed from dev-python/nltk/nltk-3.0.0.ebuild)4
5 files changed, 52 insertions, 8 deletions
diff --git a/dev-python/nltk/ChangeLog b/dev-python/nltk/ChangeLog
index 96c5d4de02be..22422c8af0fb 100644
--- a/dev-python/nltk/ChangeLog
+++ b/dev-python/nltk/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/nltk
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nltk/ChangeLog,v 1.18 2015/01/26 11:19:49 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nltk/ChangeLog,v 1.19 2015/03/18 02:14:08 zerochaos Exp $
+
+*nltk-3.0.2 (18 Mar 2015)
+
+ 18 Mar 2015; Rick Farina <zerochaos@gentoo.org>
+ +files/fix-newer-setuptools.patch, +nltk-3.0.2.ebuild, -nltk-3.0.0.ebuild,
+ nltk-2.0.4.ebuild, nltk-2.0_beta9.ebuild:
+ fix bug #538056
26 Jan 2015; Manuel Rüger <mrueg@gentoo.org> -nltk-2.0.1.ebuild,
-nltk-2.0.1_rc1.ebuild:
diff --git a/dev-python/nltk/files/fix-newer-setuptools.patch b/dev-python/nltk/files/fix-newer-setuptools.patch
new file mode 100644
index 000000000000..58b8eedbefcd
--- /dev/null
+++ b/dev-python/nltk/files/fix-newer-setuptools.patch
@@ -0,0 +1,32 @@
+From efe85968bb23e3afdcd331293f2c2588b1590091 Mon Sep 17 00:00:00 2001
+From: Mikhail Korobov <kmike84@gmail.com>
+Date: Fri, 9 Jan 2015 02:06:21 +0500
+Subject: [PATCH] Fixed installation with recent setuptools.
+
+These lines were introduced here: https://github.com/nltk/nltk/commit/1ecbd2edc32db24b4e6c7dd8555d0b89c668f041
+It seems they fix an issue with .svn folders. We use git now,
+there are no .svn folders.
+
+See also: http://stackoverflow.com/questions/1129180/how-can-i-make-setuptools-ignore-subversion-inventory
+---
+ setup.py | 7 -------
+ 1 file changed, 7 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 3ec0949..079bcf3 100644
+--- a/setup.py
++++ b/setup.py
+@@ -29,13 +29,6 @@
+ # setuptools
+ from setuptools import setup, find_packages
+
+-#
+-# Prevent setuptools from trying to add extra files to the source code
+-# manifest by scanning the version control system for its contents.
+-#
+-from setuptools.command import sdist
+-del sdist.finders[:]
+-
+ setup(
+ name = "nltk",
+ description = "Natural Language Toolkit",
diff --git a/dev-python/nltk/nltk-2.0.4.ebuild b/dev-python/nltk/nltk-2.0.4.ebuild
index cfb292eea2a5..74375c0a6977 100644
--- a/dev-python/nltk/nltk-2.0.4.ebuild
+++ b/dev-python/nltk/nltk-2.0.4.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nltk/nltk-2.0.4.ebuild,v 1.2 2014/12/22 10:17:58 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nltk/nltk-2.0.4.ebuild,v 1.3 2015/03/18 02:14:08 zerochaos Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7} )
PYTHON_REQ_USE="tk?,xml(+)"
-inherit distutils-r1
+inherit distutils-r1 eutils
DESCRIPTION="Natural Language Toolkit"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
@@ -24,3 +24,8 @@ RDEPEND="${RDEPEND}
DEPEND="${RDEPEND}
app-arch/unzip"
+
+src_prepare() {
+ epatch "${FILESDIR}"/fix-newer-setuptools.patch
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/nltk/nltk-2.0_beta9.ebuild b/dev-python/nltk/nltk-2.0_beta9.ebuild
index d838ea06e6a0..da200e891ced 100644
--- a/dev-python/nltk/nltk-2.0_beta9.ebuild
+++ b/dev-python/nltk/nltk-2.0_beta9.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nltk/nltk-2.0_beta9.ebuild,v 1.7 2012/02/25 16:25:58 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nltk/nltk-2.0_beta9.ebuild,v 1.8 2015/03/18 02:14:08 zerochaos Exp $
EAPI=3
diff --git a/dev-python/nltk/nltk-3.0.0.ebuild b/dev-python/nltk/nltk-3.0.2.ebuild
index 40ccf7e776a8..7a24b6651837 100644
--- a/dev-python/nltk/nltk-3.0.0.ebuild
+++ b/dev-python/nltk/nltk-3.0.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nltk/nltk-3.0.0.ebuild,v 1.1 2014/12/22 10:17:58 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nltk/nltk-3.0.2.ebuild,v 1.1 2015/03/18 02:14:08 zerochaos Exp $
EAPI="5"