summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2007-04-21 23:58:57 +0000
committerRob Cakebread <pythonhead@gentoo.org>2007-04-21 23:58:57 +0000
commit2f044829308756b22e789107841698db0286c068 (patch)
tree5a3a71a7b5fcdb9f43a5ffcfaf18ed607673ef63 /dev-python/nose
parentversion bump (diff)
downloadgentoo-2-2f044829308756b22e789107841698db0286c068.tar.gz
gentoo-2-2f044829308756b22e789107841698db0286c068.tar.bz2
gentoo-2-2f044829308756b22e789107841698db0286c068.zip
Version bump.
(Portage version: 2.1.2.4)
Diffstat (limited to 'dev-python/nose')
-rw-r--r--dev-python/nose/ChangeLog7
-rw-r--r--dev-python/nose/files/digest-nose-0.9.33
-rw-r--r--dev-python/nose/nose-0.9.3.ebuild51
3 files changed, 60 insertions, 1 deletions
diff --git a/dev-python/nose/ChangeLog b/dev-python/nose/ChangeLog
index 2b31601b00c3..0c4852d3afa9 100644
--- a/dev-python/nose/ChangeLog
+++ b/dev-python/nose/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/nose
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/ChangeLog,v 1.1 2007/02/27 23:11:10 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/ChangeLog,v 1.2 2007/04/21 23:58:57 pythonhead Exp $
+
+*nose-0.9.3 (21 Apr 2007)
+
+ 21 Apr 2007; Rob Cakebread <pythonhead@gentoo.org> +nose-0.9.3.ebuild:
+ Version bump.
03 Feb 2007; Tiziano Müller <dev-zero@gentoo.org> +metadata.xml:
Initial ebuild for bug #141662 (thanks to Brad Walker)
diff --git a/dev-python/nose/files/digest-nose-0.9.3 b/dev-python/nose/files/digest-nose-0.9.3
new file mode 100644
index 000000000000..8e81fd53a136
--- /dev/null
+++ b/dev-python/nose/files/digest-nose-0.9.3
@@ -0,0 +1,3 @@
+MD5 fc83ca1861afb598e5634f83dbe045ec nose-0.9.3.tar.gz 141603
+RMD160 5419cb1f9750e4c13780b7ad0735ef1350b2beb8 nose-0.9.3.tar.gz 141603
+SHA256 3093e91694e6bfab7b3d4aa58e1c6cd1550d83d932db4f3ab3ad8c28c7b78da8 nose-0.9.3.tar.gz 141603
diff --git a/dev-python/nose/nose-0.9.3.ebuild b/dev-python/nose/nose-0.9.3.ebuild
new file mode 100644
index 000000000000..a048ec0530a8
--- /dev/null
+++ b/dev-python/nose/nose-0.9.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/nose-0.9.3.ebuild,v 1.1 2007/04/21 23:58:57 pythonhead Exp $
+
+NEED_PYTHON=2.2
+
+inherit distutils
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="An alternate test discovery and running process for unittest."
+HOMEPAGE="http://somethingaboutorange.com/mrl/projects/nose/"
+SRC_URI="http://somethingaboutorange.com/mrl/projects/${PN}/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="doc examples"
+
+RDEPEND="dev-python/setuptools"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/docutils )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e '/ez_setup/d' \
+ setup.py || die "sed failed"
+}
+
+src_compile() {
+ distutils_src_compile
+ if use doc ; then
+ PYTHONPATH=. scripts/mkindex.py
+ fi
+}
+
+src_install() {
+ DOCS="AUTHORS NEWS"
+ distutils_src_install
+
+ use doc && dohtml index.html
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
+
+src_test() {
+ PYTHONPATH=. "${python}" setup.py test || die "test failed"
+}