summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-12-19 03:33:53 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-12-19 03:33:53 +0000
commit60924a12c257b69977f93cbeebc11a8ee65e8abd (patch)
tree17b5ea80e8921b58900a7e7521f59f3090e09423 /dev-python/numba
parentInitial import, dep of numba, ebuild by me (diff)
downloadgentoo-2-60924a12c257b69977f93cbeebc11a8ee65e8abd.tar.gz
gentoo-2-60924a12c257b69977f93cbeebc11a8ee65e8abd.tar.bz2
gentoo-2-60924a12c257b69977f93cbeebc11a8ee65e8abd.zip
Bump
(Portage version: 2.2.15/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/numba')
-rw-r--r--dev-python/numba/ChangeLog7
-rw-r--r--dev-python/numba/numba-0.16.0.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/dev-python/numba/ChangeLog b/dev-python/numba/ChangeLog
index e553c1a3d867..c5b32fba1c2f 100644
--- a/dev-python/numba/ChangeLog
+++ b/dev-python/numba/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/numba
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/numba/ChangeLog,v 1.10 2014/10/19 10:39:59 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numba/ChangeLog,v 1.11 2014/12/19 03:33:53 patrick Exp $
+
+*numba-0.16.0 (19 Dec 2014)
+
+ 19 Dec 2014; Patrick Lauer <patrick@gentoo.org> +numba-0.16.0.ebuild:
+ Bump
*numba-0.15.1 (19 Oct 2014)
diff --git a/dev-python/numba/numba-0.16.0.ebuild b/dev-python/numba/numba-0.16.0.ebuild
new file mode 100644
index 000000000000..040f28145cfc
--- /dev/null
+++ b/dev-python/numba/numba-0.16.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numba/numba-0.16.0.ebuild,v 1.1 2014/12/19 03:33:53 patrick Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="NumPy aware dynamic Python compiler using LLVM"
+HOMEPAGE="http://numba.pydata.org/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="doc examples"
+
+RDEPEND="
+ dev-python/llvmlite[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.6[${PYTHON_USEDEP}]
+ dev-python/enum34[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}"
+
+python_compile() {
+ if ! python_is_python3; then
+ local CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ export CFLAGS
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/lib* || die
+ ${PYTHON} -c "import numba; numba.test()" || die
+}
+
+python_install_all() {
+ # doc needs obsolete sphnxjp package
+ use doc && dodoc docs/Numba.pdf
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}