summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-01-11 06:46:27 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-01-11 06:46:27 +0000
commit1d28beb1b7fe2fbaa317711b5cfb87ed0cb11c6a (patch)
treee0066ddaf4bee5fc93425853dc9f487db48513b1 /dev-python/odfpy
parentBump for 451240 (diff)
downloadgentoo-2-1d28beb1b7fe2fbaa317711b5cfb87ed0cb11c6a.tar.gz
gentoo-2-1d28beb1b7fe2fbaa317711b5cfb87ed0cb11c6a.tar.bz2
gentoo-2-1d28beb1b7fe2fbaa317711b5cfb87ed0cb11c6a.zip
Bump for #451238
(Portage version: 2.2.0_alpha150/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/odfpy')
-rw-r--r--dev-python/odfpy/ChangeLog9
-rw-r--r--dev-python/odfpy/odfpy-0.9.5.ebuild43
2 files changed, 50 insertions, 2 deletions
diff --git a/dev-python/odfpy/ChangeLog b/dev-python/odfpy/ChangeLog
index 6f44dc4758ac..0da199912afe 100644
--- a/dev-python/odfpy/ChangeLog
+++ b/dev-python/odfpy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/odfpy
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/odfpy/ChangeLog,v 1.7 2011/12/15 02:34:59 floppym Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/odfpy/ChangeLog,v 1.8 2013/01/11 06:46:27 patrick Exp $
+
+*odfpy-0.9.5 (11 Jan 2013)
+
+ 11 Jan 2013; Patrick Lauer <patrick@gentoo.org> +odfpy-0.9.5.ebuild:
+ Bump for #451238
15 Dec 2011; Mike Gilbert <floppym@gentoo.org> odfpy-0.9.4.ebuild:
Just change to tests/ once instead of pushing and popping.
diff --git a/dev-python/odfpy/odfpy-0.9.5.ebuild b/dev-python/odfpy/odfpy-0.9.5.ebuild
new file mode 100644
index 000000000000..03cff06e7fae
--- /dev/null
+++ b/dev-python/odfpy/odfpy-0.9.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/odfpy/odfpy-0.9.5.ebuild,v 1.1 2013/01/11 06:46:27 patrick Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils eutils
+
+DESCRIPTION="Python API and tools to manipulate OpenDocument files"
+HOMEPAGE="https://joinup.ec.europa.eu/software/odfpy/home http://pypi.python.org/pypi/odfpy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+PYTHON_MODNAME="odf"
+
+src_prepare() {
+ distutils_src_prepare
+ epatch "${FILESDIR}/${PN}-0.9.4-tests.patch"
+}
+
+src_test() {
+ cd tests || die
+ testing() {
+ local exit_status=0 test
+ for test in test*.py; do
+ einfo "Running ${test} ..."
+ PYTHONPATH="../build-${PYTHON_ABI}/lib" "$(PYTHON)" "${test}"
+ [[ $? -ne 0 ]] && exit_status=1
+ done
+ return ${exit_status}
+ }
+ python_execute_function testing
+}