summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-01-31 05:37:33 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2015-01-31 05:37:33 +0000
commit1371d1ef191849a1769401e5a3ba5beab9f2fe5a (patch)
tree2b3d8f06f19a6910af3fa60c535a3f443429b39a /dev-python/oslo-config
parentbump (diff)
downloadgentoo-2-1371d1ef191849a1769401e5a3ba5beab9f2fe5a.tar.gz
gentoo-2-1371d1ef191849a1769401e5a3ba5beab9f2fe5a.tar.bz2
gentoo-2-1371d1ef191849a1769401e5a3ba5beab9f2fe5a.zip
bumping
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x33ED3FD25AFC78BA)
Diffstat (limited to 'dev-python/oslo-config')
-rw-r--r--dev-python/oslo-config/ChangeLog10
-rw-r--r--dev-python/oslo-config/oslo-config-1.6.0.ebuild52
2 files changed, 60 insertions, 2 deletions
diff --git a/dev-python/oslo-config/ChangeLog b/dev-python/oslo-config/ChangeLog
index 595e2b0cf7ab..e867eb77c6f3 100644
--- a/dev-python/oslo-config/ChangeLog
+++ b/dev-python/oslo-config/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/oslo-config
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/oslo-config/ChangeLog,v 1.12 2014/11/25 09:46:39 pacho Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oslo-config/ChangeLog,v 1.13 2015/01/31 05:37:33 prometheanfire Exp $
+
+*oslo-config-1.6.0 (31 Jan 2015)
+
+ 31 Jan 2015; Matthew Thode <prometheanfire@gentoo.org>
+ +oslo-config-1.6.0.ebuild:
+ bumping
25 Nov 2014; Pacho Ramos <pacho@gentoo.org> oslo-config-1.4.0.ebuild:
Support python 3.4
diff --git a/dev-python/oslo-config/oslo-config-1.6.0.ebuild b/dev-python/oslo-config/oslo-config-1.6.0.ebuild
new file mode 100644
index 000000000000..76cc5977b715
--- /dev/null
+++ b/dev-python/oslo-config/oslo-config-1.6.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oslo-config/oslo-config-1.6.0.ebuild,v 1.1 2015/01/31 05:37:33 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="Oslo Configuration API"
+HOMEPAGE="https://launchpad.net/oslo"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.config/oslo.config-${PV}.tar.gz"
+S="${WORKDIR}/oslo.config-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~amd64-linux ~x86 ~x86-linux"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.8.0[${PYTHON_USEDEP}]
+ <dev-python/pbr-1.0.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/hacking-0.9.2[${PYTHON_USEDEP}]
+ <dev-python/hacking-0.10[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-0.3.14[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.36[${PYTHON_USEDEP}]
+ !~dev-python/testtools-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ >=dev-python/netaddr-0.7.12[${PYTHON_USEDEP}]
+ >=dev-python/six-1.7.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.1.0[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPTYHON}"
+
+ testr init || die "testr init failed under ${EPYTHON}"
+ testr run || die "testr run failed under ${EPYTHON}"
+}