summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-08-28 09:34:30 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-08-28 09:34:30 +0000
commit9b005ee896d3d4b9139ae47f07828789301d17ac (patch)
tree4381a75cc456d66815c27dfa1dbf282046081b37 /dev-python/peewee
parentStable for HPPA (bug #510342). (diff)
downloadgentoo-2-9b005ee896d3d4b9139ae47f07828789301d17ac.tar.gz
gentoo-2-9b005ee896d3d4b9139ae47f07828789301d17ac.tar.bz2
gentoo-2-9b005ee896d3d4b9139ae47f07828789301d17ac.zip
Bump
(Portage version: 2.2.12/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/peewee')
-rw-r--r--dev-python/peewee/ChangeLog7
-rw-r--r--dev-python/peewee/peewee-2.3.1.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-python/peewee/ChangeLog b/dev-python/peewee/ChangeLog
index 226d9dfca6d2..548c1031894b 100644
--- a/dev-python/peewee/ChangeLog
+++ b/dev-python/peewee/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/peewee
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/peewee/ChangeLog,v 1.13 2014/08/20 06:20:21 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/peewee/ChangeLog,v 1.14 2014/08/28 09:34:30 patrick Exp $
+
+*peewee-2.3.1 (28 Aug 2014)
+
+ 28 Aug 2014; Patrick Lauer <patrick@gentoo.org> +peewee-2.3.1.ebuild:
+ Bump
*peewee-2.3.0 (20 Aug 2014)
diff --git a/dev-python/peewee/peewee-2.3.1.ebuild b/dev-python/peewee/peewee-2.3.1.ebuild
new file mode 100644
index 000000000000..6063d8f9f410
--- /dev/null
+++ b/dev-python/peewee/peewee-2.3.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/peewee/peewee-2.3.1.ebuild,v 1.1 2014/08/28 09:34:30 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Small python ORM"
+HOMEPAGE="https://github.com/coleifer/peewee/"
+SRC_URI="https://github.com/coleifer/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/apsw[${PYTHON_USEDEP}]
+ dev-python/psycopg[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
+ )"
+# Req'd to ensure a unique tmp.db for each python impl running the testsuite.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ "${PYTHON}" ./runtests.py || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( example/. )
+ distutils-r1_python_install_all
+}