summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-12-20 22:33:47 +0000
committerMichał Górny <mgorny@gentoo.org>2012-12-20 22:33:47 +0000
commit7fc14feeadd908bddcff15f3df7c7b674b373c70 (patch)
tree8d13a932cb972bea5defe048d21e6c337a01c451 /dev-python/pexpect
parentRevbump to revert my previous commit. Thanks to Arfrever (diff)
downloadgentoo-2-7fc14feeadd908bddcff15f3df7c7b674b373c70.tar.gz
gentoo-2-7fc14feeadd908bddcff15f3df7c7b674b373c70.tar.bz2
gentoo-2-7fc14feeadd908bddcff15f3df7c7b674b373c70.zip
Migrate to distutils-r1.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'dev-python/pexpect')
-rw-r--r--dev-python/pexpect/ChangeLog7
-rw-r--r--dev-python/pexpect/pexpect-2.4-r1.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-python/pexpect/ChangeLog b/dev-python/pexpect/ChangeLog
index cda18a3ffe6e..382e46169487 100644
--- a/dev-python/pexpect/ChangeLog
+++ b/dev-python/pexpect/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pexpect
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pexpect/ChangeLog,v 1.53 2012/05/13 19:59:57 rafaelmartins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pexpect/ChangeLog,v 1.54 2012/12/20 22:33:47 mgorny Exp $
+
+*pexpect-2.4-r1 (20 Dec 2012)
+
+ 20 Dec 2012; Michał Górny <mgorny@gentoo.org> +pexpect-2.4-r1.ebuild:
+ Migrate to distutils-r1.
13 May 2012; Rafael G. Martins <rafaelmartins@gentoo.org> pexpect-2.4.ebuild:
Fix python dependency.
diff --git a/dev-python/pexpect/pexpect-2.4-r1.ebuild b/dev-python/pexpect/pexpect-2.4-r1.ebuild
new file mode 100644
index 000000000000..ac1ac1a03916
--- /dev/null
+++ b/dev-python/pexpect/pexpect-2.4-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pexpect/pexpect-2.4-r1.ebuild,v 1.1 2012/12/20 22:33:47 mgorny Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7} pypy{1_8,1_9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for spawning child applications and responding to expected patterns"
+HOMEPAGE="http://pexpect.sourceforge.net/ http://pypi.python.org/pypi/pexpect"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc examples"
+
+DEPEND=""
+RDEPEND=""
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/. )
+
+ distutils-r1_python_install_all
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}