summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2007-01-06 23:43:39 +0000
committerTiziano Müller <dev-zero@gentoo.org>2007-01-06 23:43:39 +0000
commit5af7cf55c93cfa10549ffa87cbe933255393187f (patch)
tree2c37de5b3165d48bc6657c656062d211eec43aa8 /dev-python/ply/ply-2.2.ebuild
parentStable on Alpha. (diff)
downloadgentoo-2-5af7cf55c93cfa10549ffa87cbe933255393187f.tar.gz
gentoo-2-5af7cf55c93cfa10549ffa87cbe933255393187f.tar.bz2
gentoo-2-5af7cf55c93cfa10549ffa87cbe933255393187f.zip
Version bump, bug #147202. Dropped old versions.
(Portage version: 2.1.2_rc4-r1)
Diffstat (limited to 'dev-python/ply/ply-2.2.ebuild')
-rw-r--r--dev-python/ply/ply-2.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/ply/ply-2.2.ebuild b/dev-python/ply/ply-2.2.ebuild
new file mode 100644
index 000000000000..98b3638940f4
--- /dev/null
+++ b/dev-python/ply/ply-2.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ply/ply-2.2.ebuild,v 1.1 2007/01/06 23:43:39 dev-zero Exp $
+
+inherit distutils
+
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+
+DESCRIPTION="Python Lex-Yacc library"
+SRC_URI="http://www.dabeaz.com/ply/${P}.tar.gz"
+HOMEPAGE="http://www.dabeaz.com/ply/"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND=""
+
+src_install() {
+ DOCS="ANNOUNCE CHANGES"
+ distutils_src_install
+ dohtml doc/*
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r example
+ fi
+}
+
+src_test() {
+ cd test
+ python rununit.py || die "test failed"
+}