summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-01-19 11:52:03 +0000
committerMichał Górny <mgorny@gentoo.org>2013-01-19 11:52:03 +0000
commitc926b46be81a4e5bc841a4fc1a4e9487be4ecbce (patch)
treea8b9f6eb5f12209d41667a442884a0f2f667986a /dev-python/psycopg
parent[bump] virtual/perl-Term-ANSIColor-4.20.0 (diff)
downloadgentoo-2-c926b46be81a4e5bc841a4fc1a4e9487be4ecbce.tar.gz
gentoo-2-c926b46be81a4e5bc841a4fc1a4e9487be4ecbce.tar.bz2
gentoo-2-c926b46be81a4e5bc841a4fc1a4e9487be4ecbce.zip
Migrate slot 0 to python-r1.
(Portage version: 2.2.0_alpha155/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'dev-python/psycopg')
-rw-r--r--dev-python/psycopg/ChangeLog7
-rw-r--r--dev-python/psycopg/psycopg-1.1.21-r1.ebuild73
2 files changed, 79 insertions, 1 deletions
diff --git a/dev-python/psycopg/ChangeLog b/dev-python/psycopg/ChangeLog
index 734a29a0b1b7..9d4a55ec4248 100644
--- a/dev-python/psycopg/ChangeLog
+++ b/dev-python/psycopg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/psycopg
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/psycopg/ChangeLog,v 1.154 2013/01/15 18:03:38 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/psycopg/ChangeLog,v 1.155 2013/01/19 11:52:03 mgorny Exp $
+
+*psycopg-1.1.21-r1 (19 Jan 2013)
+
+ 19 Jan 2013; Michał Górny <mgorny@gentoo.org> +psycopg-1.1.21-r1.ebuild:
+ Migrate slot 0 to python-r1.
15 Jan 2013; Michał Górny <mgorny@gentoo.org> psycopg-2.4.6-r1.ebuild:
Fix recursive dohtml call.
diff --git a/dev-python/psycopg/psycopg-1.1.21-r1.ebuild b/dev-python/psycopg/psycopg-1.1.21-r1.ebuild
new file mode 100644
index 000000000000..83d9837c1b35
--- /dev/null
+++ b/dev-python/psycopg/psycopg-1.1.21-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/psycopg/psycopg-1.1.21-r1.ebuild,v 1.3 2013/01/19 11:52:03 mgorny Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit autotools-utils python-r1
+
+DESCRIPTION="PostgreSQL database adapter for Python"
+HOMEPAGE="http://www.initd.org/software/psycopg"
+SRC_URI="http://initd.org/pub/software/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples"
+
+RDEPEND=">=dev-python/egenix-mx-base-2.0.3[${PYTHON_USEDEP}]
+ dev-db/postgresql-base
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # fix for bug #134873
+ sed -e '1245s/static //' -i cursor.c || die
+ sed -e 's:$(PY_MOD_DIR):$(D)&/$$mod:' \
+ -e '/^CFLAGS/s:-I:-I. &:' \
+ -i Makefile.pre.in || die
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ python_configure() {
+ local myeconfargs=(
+ --with-mxdatetime-includes="$(python_get_includedir)/mx"
+ --with-postgres-includes="/usr/include/postgresql/server"
+ )
+
+ autotools-utils_src_configure
+
+ sed -e 's:$(BLDSHARED):& $(LDFLAGS):' \
+ -i "${BUILD_DIR}"/Makefile || die
+ }
+ python_foreach_impl python_configure
+}
+
+src_compile() {
+ python_foreach_impl autotools-utils_src_compile \
+ OPT="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_test() {
+ :
+}
+
+src_install () {
+ python_install() {
+ dodir "$(python_get_sitedir)"
+ autotools-utils_src_install
+ }
+
+ python_foreach_impl python_install
+
+ dodoc RELEASE-1.0 SUCCESS doc/python-taylor.txt
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r doc/examples/.
+ docompress -x "${INSDESTTREE}"
+ fi
+}