summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-02-07 18:56:10 +0000
committerJustin Lecher <jlec@gentoo.org>2013-02-07 18:56:10 +0000
commit083e1095499ede22f33dea94672e5f3b834238a6 (patch)
tree7f42ec7aaffeb3d186915b59fccff5b44d35c184 /dev-python/pyamg/pyamg-2.0.5.ebuild
parentoffset ROOT support for the hwdb update, thanks lu_zero (diff)
downloadgentoo-2-083e1095499ede22f33dea94672e5f3b834238a6.tar.gz
gentoo-2-083e1095499ede22f33dea94672e5f3b834238a6.tar.bz2
gentoo-2-083e1095499ede22f33dea94672e5f3b834238a6.zip
dev-python/pyamg: Version BUmp; move to new python eclasses
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'dev-python/pyamg/pyamg-2.0.5.ebuild')
-rw-r--r--dev-python/pyamg/pyamg-2.0.5.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pyamg/pyamg-2.0.5.ebuild b/dev-python/pyamg/pyamg-2.0.5.ebuild
new file mode 100644
index 000000000000..9e3ffdf53519
--- /dev/null
+++ b/dev-python/pyamg/pyamg-2.0.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyamg/pyamg-2.0.5.ebuild,v 1.1 2013/02/07 18:56:10 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Algebraic multigrid solvers in Python"
+HOMEPAGE="http://code.google.com/p/pyamg/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RESTRICT="test" # quite buggy
+
+RDEPEND="sci-libs/scipy[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${PN}"
+
+python_compile_all() {
+ if use doc; then
+ cd "${S}/Docs"
+ PYTHONPATH="${BUILD_DIR}"/lib emake html
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( Docs/build/html/* )
+ distutils-r1_python_install_all
+}