summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-08 20:36:20 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-08 20:36:20 +0000
commit277aa19fabdbecbbba49056ea0739cb9ea85a415 (patch)
treec853bba494d4ac8e8693197431154146a8e907ea /dev-python/pycairo
parentTry to avoid bashdb problems: run with sh. (diff)
downloadgentoo-2-277aa19fabdbecbbba49056ea0739cb9ea85a415.tar.gz
gentoo-2-277aa19fabdbecbbba49056ea0739cb9ea85a415.tar.bz2
gentoo-2-277aa19fabdbecbbba49056ea0739cb9ea85a415.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: 13948-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pycairo')
-rw-r--r--dev-python/pycairo/ChangeLog6
-rw-r--r--dev-python/pycairo/pycairo-1.8.6.ebuild13
2 files changed, 15 insertions, 4 deletions
diff --git a/dev-python/pycairo/ChangeLog b/dev-python/pycairo/ChangeLog
index a3996bbed68f..f4b1b4262fba 100644
--- a/dev-python/pycairo/ChangeLog
+++ b/dev-python/pycairo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pycairo
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/ChangeLog,v 1.69 2009/07/10 18:05:44 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/ChangeLog,v 1.70 2009/08/08 20:36:20 arfrever Exp $
+
+ 08 Aug 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ pycairo-1.8.6.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
10 Jul 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
pycairo-1.8.6.ebuild:
diff --git a/dev-python/pycairo/pycairo-1.8.6.ebuild b/dev-python/pycairo/pycairo-1.8.6.ebuild
index 257f39d68769..c188e7b35fd7 100644
--- a/dev-python/pycairo/pycairo-1.8.6.ebuild
+++ b/dev-python/pycairo/pycairo-1.8.6.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/pycairo-1.8.6.ebuild,v 1.2 2009/07/10 18:05:44 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/pycairo-1.8.6.ebuild,v 1.3 2009/08/08 20:36:20 arfrever Exp $
EAPI="2"
NEED_PYTHON="2.6"
+SUPPORT_PYTHON_ABIS="1"
inherit distutils
@@ -22,6 +23,8 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig
doc? ( dev-python/sphinx )"
+RESTRICT_PYTHON_ABIS="2.4 2.5 3*"
+
PYTHON_MODNAME="cairo"
DOCS="AUTHORS NEWS README"
@@ -47,8 +50,12 @@ src_compile() {
}
src_test() {
- cd test
- PYTHONPATH="$(ls -d ${S}/build/lib.*)" "${python}" test.py || die "tests failed"
+ testing() {
+ pushd test > /dev/null
+ PYTHONPATH="$(ls -d ../build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" test.py || return 1
+ popd > /dev/null
+ }
+ python_execute_function testing
}
src_install() {